Subject: Re: [rrg] Next topic?

From: [email-masked]
Date: Tue, 24 May 2011 03:53:09 EDT

In einer eMail vom 23.05.2011 10:04:24 Westeuropäische Sommerzeit schreibt  
[email-masked]:

I think  many people agrees with the host number scalability issue,
since many  research challenges are ongoing and industries may support it.
The later  routing issue is only my own idea, and I cannot find any
research paper  discussing it other than ATM PNNI. 

ikop,
ATM PNNI did try Topology Aggregation, but it was done the wrong way. I  
know for sure because I was part of the PNNI working group.
Heiner

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 24 May 2011 10:00:33 -0400

Heiner,
     I have mostly been ignoring your over-the-top assertions about your 
solution and about other solutions. However, Having also been there, I 
would have to disagree with yoru description of PNNI topology aggregation.
THere is no evidence that it is "the wrong way."  That is your personal 
opinion.
Networks of the scale that would have given evidence on the topic were 
never constructed.  Due, frankly, to IP and MPLS being better tools with 
lower complexity than ATM for the overall problem space.

You are welcome to your opinion about the likely correctness of what the 
WG adopted.  But please do not confuse that opinion with verified fact 
(as in "know for sure.")

Yours,
Joel

On 5/24/2011 3:53 AM, [email-masked] wrote:
> In einer eMail vom 23.05.2011 10:04:24 Westeuropäische Sommerzeit
> schreibt [email-masked]:
>
> _______________________________________________
> rrg mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/rrg

---

From: [email-masked]
Date: Tue, 24 May 2011 13:57:55 -0400

Joel,
there are several aspects that let me criticize the PNNI topology aggregation based on my present knowledge:

We aggregated the border-to-border physical links (based on the Aggrgation Token which was invented by G.Swallow due to my own contribution)
and not the network by skimming its topology for a view from the far.
The Complex Node Representation wasn't satisfactory at all. 
I guess those who came up with the (bad) STRETCH factor had in mind hierarchical routing a la PNNI.
 
I pointed out several times what I called Istanbul effect. That poor property applies to PNNI for sure. 

Related though not part of the topology aggregation is its address summarization: DCC, ICD, E.164. Even 3 address families. A lot of prefix building work, which is the main part of the current and so-called scalability problem. As I have demonstrated: Prefix building isn't needed at all.

The really good thing about PNNI was - from my personal point of view- to see and experience  the courage to go for implementing such a hierarchy at all. It makes me go for some better one, though.

Heiner 

-----Ursprüngliche Mitteilung----- 
Von: Joel M. Halpern <[email-masked]>
An: [email-masked]
Cc: [email-masked]
Verschickt: Di., 24. Mai. 2011, 16:00
Thema: Re: [rrg] Next topic?

Heiner, 
    I have mostly been ignoring your over-the-top assertions about your solution and about other solutions. However, Having also been there, I would have to disagree with yoru description of PNNI topology aggregation. 
THere is no evidence that it is "the wrong way."  That is your personal opinion. 
Networks of the scale that would have given evidence on the topic were never constructed.  Due, frankly, to IP and MPLS being better tools with lower complexity than ATM for the overall problem space. 
 
You are welcome to your opinion about the likely correctness of what the WG adopted.  But please do not confuse that opinion with verified fact (as in "know for sure.") 
 
Yours, 
Joel