Subject: [Rserpool] a question about TCP as transport btw PU<->ES

From: Qiaobing Xie <[email-masked]>
Date: Tue, 21 May 2002 17:04:40 -0500

Hi, all,

I don't quite remember what we decided exactly at the last IETF about
whether to support TCP btw PU and ES (we still have text in section
2.2.3 in the arch draft to support TCP). Didn't we agree to support
non-SCTP transport *only* between PU and PE?

It would be simple and clean if we only allow SCTP for PU<->ES. But if
there is strong feeling from the WG that we also need to allow TCP for
PU<->ES, I can live with it, too.

Either case, we probably need to define a well-known port number for PU
to query an ES.

-Qiaobing

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: [email-masked]
Date: Thu, 23 May 2002 12:06:29 -0500

I support this idea (as Michael Tuexen indicated).

We should call this something other than "pure" PU but that is a nit. 

I believe there will be a modification needed to Server Hunt procedure in ASAP for PUs.

-- maureen

-----Original Message-----
From: ext Qiaobing Xie [mailto:[email-masked]]
Sent: Wednesday, May 22, 2002 6:41 PM
To: Michael Tuexen
Cc: Rserpool list
Subject: Re: [Rserpool] a question about TCP as transport btw PU<->ES

Michael,

This sounds reasonable to me. This can indeed make a "pure" PU much
lighter weighted. By "pure" PU I mean one that only does name
query/response and possibly reporting unreachable PEs.

I missed this in the current ENRP, will add text in the next ENRP
revision for this feature. Some text may also be needed for ASAP to
describe such a "pure" PU running only TCP.

regards,
-Qiaobing

Michael Tuexen wrote:
> 
> Qiaobing,
> 
> we agreed on TCP being an option for PU <-> ES communication,
> because (consider a PE as a mobile phone) if a PE wants a
> UDP or TCP based service it would need SCTP 'only' to do
> name queries. Maureen thought that this might be not optimal.
> 
> Best regards
> Michael
> 
> On Wednesday, May 22, 2002, at 12:04 AM, Qiaobing Xie wrote:
> 
> > Hi, all,
> >
> [email-masked]

---

From: [email-masked]
Date: Thu, 23 May 2002 12:06:29 -0500

-- maureen

-----Original Message-----
From: ext Qiaobing Xie [mailto:[email-masked]]
Sent: Wednesday, May 22, 2002 6:41 PM
To: Michael Tuexen
Cc: Rserpool list
Subject: Re: [Rserpool] a question about TCP as transport btw PU<->ES

Michael,

regards,
-Qiaobing