Subject: [Rserpool] Applicability draft

From: Melinda Shore <[email-masked]>
Date: Mon, 24 Jun 2002 18:12:54 -0400

It's nice work, and I have a few comments:

1) This may be the discussion that never dies, but I
think in section 1 it may be best to say that rserpool
provides highly-available network sessions, rather than
highly-available services.  The latter implies that 
rserpool moves service state around.  As such, rather than
stating "The goal is to provide server based redundancy"
it might be better to say that the goal is to provide a tool
to help build redundant servers.

2) In the security section it says that TLS or IPSec will be
used to secure the connection.  IPSec will not work unless
IP addresses are transferred during failover (in which case
you wouldn't need rserpool), because of the use of addresses
as selectors in the SADB.   For TLS to be able to work you 
would need to have server certs on every server in the pool,
which is straightforward, but you'd also need a mechanism
to securely transfer session security state (negotiated
shared secret, cryptographic attributes. etc.).

Melinda

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Coene Lode <[email-masked]>
Date: Tue, 25 Jun 2002 12:59:48 +0200

I'll come up with some text describing it more explicit for the next version
after Yokohama(amind other things to add)

yours sincerly,
Lode

Siemens atea
atealaan 34          2200 Herentals, Belgium
E-mail: [email-masked]
Tel: +32-14-252081
Fax: +32-14-253212

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Tuesday, June 25, 2002 12:38 AM
> To: Michael Tuexen
> Cc: [email-masked]
> Subject: Re: [Rserpool] Applicability draft
> 
> 
> At 12:28 AM 6/25/02 +0200, Michael Tuexen wrote:
> >So you do NOT have to have a security state transfer mechanism.
> 
> Thanks for clarifying that.  Perhaps it would be clearer in
> if that were made explicit in the text?
> 
> Thanks,
> 
> Melinda
> 
>

---

From: Coene Lode <[email-masked]>
Date: Tue, 25 Jun 2002 12:59:48 +0200

yours sincerly,
Lode

Siemens atea