Subject: RE: [Rserpool] Comments on draft-ietf-rserpool-asap-04.txt

From: Tuexen Michael <[email-masked]>
Date: Tue, 1 Oct 2002 10:02:21 +0200

Qiaobing,

as far as I understand neither TCP nor SCTP can run
over m-cast. They are unicast protocols.

In my understanding the problem lies in the fact
of acknowledgements. Some of the receivers might
have received some DATA chunks, others not. Will
you retransmit? So providing reliablibilty is the
problem. There is a WG on this topic:
http://www.ietf.org/html.charters/rmt-charter.html

Best regards
Michael 

Michael Tuexen   Tel.:   +49 89 722 47210
Siemens AG       Fax:    +49 89 722 48212
ICN WN CC SE 7   e-mail: [email-masked]

> -----Original Message-----
> From: Qiaobing Xie [mailto:[email-masked]]
> Sent: Monday, September 30, 2002 9:28 PM
> To: Michael Tuexen
> Cc: Tuexen Michael; 'Randall Stewart'; Thomas Dreibholz;
> [email-masked]
> Subject: Re: [Rserpool] Comments on draft-ietf-rserpool-asap-04.txt
> 
> 
> ...
> > Hmm. I'm not an m-cast expert, but up to my understanding 
> you can not
> > use m-cast with TCP or SCTP. So UDP is the only transport 
> protocol you
> > can use. In addition to the m-cast group you need a UDP 
> port number. You
> > can use the same as the port number for TCP and SCTP.
> 
> Yes, Michael, you are correct. Although the m-cast man page 
> says you can
> do m-cast via any datagram transport, but in practice UDP is probably
> the only datagram socket usable (I don't know of any SCTP socket has
> m-cast support implemented).
> 
> -Qiaobing
> 
_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 01 Oct 2002 11:38:54 -0500

Michael,

> over m-cast. They are unicast protocols.

Of cause I know. But you missed my point. I was talking about socket
API, not the protocols themselves. In theory, it is possible to overlay
the m-cast API over any datagram socket (including SCTP's. But TCP is
not datagram, so it is out of question). I don't know whether anyone has
done it or not, but IMO it would be convenient to use a single fd to
access your SCTP stack and at the same time to join a m-cast group, send
and receive m-cast packets via the same fd. Nothing is said that m-cast
packets need to go through the SCTP stack.

I am also not saying this should be the official way for building SCTP
socket API or that I will build it. But if someone has built this
overlay in his/her SCTP socket API, please let me know and I will be
happy to use it :-)

regards,
-Qiaobing

---

From: Qiaobing Xie <[email-masked]>
Date: Tue, 01 Oct 2002 11:38:54 -0500

Michael,

regards,
-Qiaobing