Subject: [Rserpool] questions on load balancing

From: Chen Youye <[email-masked]>
Date: Thu, 17 Jul 2003 15:34:43 +0200

Hello,all,

A freshman on RserPool has some questions:

1.Why do we need to include the "Registration Life" in the message "REGISTRATION" when PE registers itself to Home NS? The timer to count life time only runs at PE. I cannot find any corresponding timer or other actions to work with the PE's life time at NS. Whether this information is not necessary to Home NS?

2. What is the reason that PE must register itself again to Home NS according to the Registration Life time? Force PE to update its loading information?

3. As described in RFC draft, PE shall actively update its loading information to Home NS when it desires. How does the PU get this updated loading information? Only through NAME-RESOLUTION? Is there any possible to ask Home NS to actively inform the registered PUs so that to reach a more dynamic load balancing?

4. There are items named "Pool Element parameter" in the message "NAME_RESOLUTION_RESPONSE". Whether the "Pool Element parameter" is directly copied from the PE "REGISTRATION" message, which means Home NS cannot do any modification on that?

Thank you ver much.

Best regards,
Youye Chen

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Chen Youye <[email-masked]>
Date: Thu, 17 Jul 2003 17:40:22 +0200

Hello, Michael,

Thank you for your reply!

From your description, only PE can modify the Policy value according to the loading situation, and PU knows the loading change only through name resolution. So, what is the difference between the two Pool Policies, Least Used and Least Used with Degradation? 

We assume local cache implemented at PU side. Since the degradation of Policy value only can be done at PE side, PU cannot get this information except of performing name resolution when the timer for local cache expires. However, with Least Used policy, PU also can know that with name resolution when the timer expires. What is the difference?

Best regards,
Youye Chen

-----Original Message-----
From: Michael Tuexen
To: Chen Youye
Cc: [email-masked]'
Sent: 7/17/03 3:54 PM
Subject: Re: [Rserpool] questions on load balancing

Hi Youye,

see my comments below.

Best regards
Michael

On Thursday, Jul 17, 2003, at 15:34 Europe/Berlin, Chen Youye wrote:

> 1.Why do we need to include the "Registration Life" in the message 
> "REGISTRATION" when PE registers itself to Home NS? The timer to count

> life time only runs at PE. I cannot find any corresponding timer or 
> other actions to work with the PE's life time at NS. Whether this 
> information is not necessary to Home NS?
>
The NS will delete the entry after the some time. That is what the 
lifetime is for.
The description of this procedure seems to me missing...
> 2. What is the reason that PE must register itself again to Home NS 
> according to the Registration Life time? Force PE to update its 
> loading information?
>
We want to make sure that there is 'up-to-date' information in the 
namespace.
> 3. As described in RFC draft, PE shall actively update its loading 
> information to Home NS when it desires. How does the PU get this 
> updated loading information? Only through NAME-RESOLUTION? Is there 
> any possible to ask Home NS to actively inform the registered PUs so 
> that to reach a more dynamic load balancing?
Only through a name resolution.
>
> 4. There are items named "Pool Element parameter" in the message 
> "NAME_RESOLUTION_RESPONSE". Whether the "Pool Element parameter" is 
> directly copied from the PE "REGISTRATION" message, which means Home 
> NS cannot do any modification on that?
>
Why should that entry be modified? The PE says that it is using this 
transport address and
the NS gives this information to PUs.

---

From: Chen Youye <[email-masked]>
Date: Thu, 17 Jul 2003 17:40:22 +0200

Hello, Michael,

Best regards,
Youye Chen

-----Original Message-----
From: Michael Tuexen
To: Chen Youye
Cc: [email-masked]'
Sent: 7/17/03 3:54 PM
Subject: Re: [Rserpool] questions on load balancing

Hi Youye,

see my comments below.

Best regards
Michael