Subject: RE: [Rserpool] FW: AD review of draft-ietf-rserpool-comp-07

From: Silverton Aron-C1710C <[email-masked]>
Date: Tue, 17 Feb 2004 10:35:11 -0600

[email-masked] <> wrote:
> Hi all,
> 
>snip
> 
> The main points raised are:
> 
> 1) Discussion of RFC3401, etc.
>    http://www.ietf.org/rfc/rfc3401.txt?number=3401
> 
>    My general feeling is that DDDS will suffer similar problems as
>    DNS, in terms of the lack of dynamicity in DDS.
> 
> 2) Discussion of draft-ietf-provreg-epp-09 is more difficult.
> 
>    http://www.ietf.org/internet-drafts/draft-ietf-provreg-epp-09
> 
>    EPP looks at some levels like it could provide some solutions, but
>    just in different ways than what has originally been thought of. 
>    I would need some other folks to review EPP and DDS, to see what
> other folks think. 
> 
> 3) Support for URNs.  We have some discussions on namespace issues &
>    identifiers for RserPool.  If we don't want to support URNs, we
>    need good reasons why we think that URNS are not a good idea for
> Rserool. 
> 
> 4) Text about SLP & l4/l7 I can probably fix.

John, according to Jon P's email, the L4/L7 stuff is ". . . I think the analysis here is sound. Same for the analysis of L4/L7 switching."  So I wouldn't waste too many cycles on that unless you feel that there is something that needs to be changed.

As for the other portions, I'm not familiar with them so I will have to read the drafts.  I think that some of the comments that Qiaobing made in the past regarding loosely-coupled approaches of trying to integrate many protocols versus a tightly-coupled protocol (RSERPOOL) will hold here as well.  All the more so if we stress that RSERPOOL is intended for system with some degree of real-time performance constraints.

> thanks,
> John

Aron

> 
> _______________________________________________
> rserpool mailing list
> [email-masked] https://www1.ietf.org/mailman/listinfo/rserpool

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Manuel Urueña <[email-masked]>
Date: Tue, 17 Feb 2004 21:21:06 +0100

> ...
>
> As for the other portions, I'm not familiar with them so I will have to 
> read the drafts.  I think that some of the comments that Qiaobing made 
> in the past regarding loosely-coupled approaches of trying to integrate 
> many protocols versus a tightly-coupled protocol (RSERPOOL) will hold 
> here as well.  All the more so if we stress that RSERPOOL is intended 
> for system with some degree of real-time performance constraints.
>
> Aron

What do you mean by systems with "real-time" performance constraints?

If it means to quickly obtain the best server from a pool maybe the
mandatory usage of SCTP is not an optimal solution.

Let's imagine an user that wants to access a web-service served by a
pool of servers. That means that first it has to establish a SCTP
connection to the ENRP server (4-way handshake), get server info, and
finally open a TCP connection (3-way handshake) to the selected web
server for the HTTP transaction. It makes more or less 4,5 RTTs.

It seems that querying ENRP servers via UDP will lead to better
server-selection latency for "real-time" services (2'5 RTTS for TCP
connections).

Regards,
--Manuel

-- 
Manuel Uruen~a - Universidad Carlos III de Madrid
GPG FP: 68A1 164B EE28 52C9 87CB  EBF9 616E 52B5 451A B6B2

---

From: Manuel Urueña <[email-masked]>
Date: Tue, 17 Feb 2004 21:21:06 +0100

Regards,
--Manuel