Subject: [Rserpool] ASAP Server Announce

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 19 Jul 2004 18:21:00 +0200

Dear all,

it would be useful when the ASAP Server Announce contains the announced ENRP 
server's server ID. Then, a PE or PU can store an internal set of available 
ENRP servers sorted by ID. When a new announcement comes in, it is then much 
easier possible to check if an entry is already existing. Otherwise, this has 
to be done by comparing addresses, which is much more inefficient.

It seems to be further useful to define that an ASAP Server Announce MUST 
contain exactly one SCTP Transport Parameter. Every ENRP server must have a 
SCTP endpoint (since PEs must use SCTP), it seems to make no sense to have 
several separate SCTP endpoints for the same ENRP server. Having the 
possibility to have more than one SCTP transport parameters only makes it 
difficult for a PE/PU to choose the right one.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz

 University of Essen,                            Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
- -----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Michael Tuexen <[email-masked]>
Date: Mon, 19 Jul 2004 20:01:20 +0200

Hi Thomas,

see my comments in-line.

Best regards
Michael

On Jul 19, 2004, at 6:21 PM, Thomas Dreibholz wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Dear all,
>
You could also store it by a hash of the IP-address... But from
my point of view, we can add that. What do others think?
> difficult for a PE/PU to choose the right one.
But not all PUs talk SCTP. To support them an ENRP server might
listen on a TCP and on a SCTP socket. Furthermore we use different
port numbers for ASAP/TLS and ENRP/TLS compared to ASAP and ENRP
not running over TLS. So I think an ENRP server might announce
4 transport addresses.
> -  
> -----------------------------------------------------------------------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
>
> iD8DBQFA+/Ts32BbsHYPLWURAnD0AKCgk4GwUu0wxG8IAzW0TpYXNrlgBgCfeSlu
> SwbCz2FHCkwhXdEa3/TosSI=
> =murA
> -----END PGP SIGNATURE-----
>