Subject: [Rserpool] Inconsistencies of ASAP and ENRP drafts

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Mon, 2 Aug 2004 18:42:31 -0500

There are many inconsistencies between the two drafts that seemed to surface when the protocols were separated into there own drafts. Will these be merged back together? Or does work need to be done to clean up the separation. I would lobby to combine both into a single consistent document but wanted to see what the group was thinking.

Here are a few of the several problems I have seen.

1) The same action is described differently between documents. For instance, Registration is described in both the ENRP and ASAP document differently. The question here should be whether Registration should even be mentioned in ENRP draft since it is a ASAP message.     

2) Definitions are inconsistent. For instance, Home ENRP server is defined as follows in the two drafts. This is a noticeable difference in definitions with using "SHOULD only have one" and "MUST only have one". 

[ASAP] 
Home ENRP server: The ENRP server to which a Pool Element currently
      uses.  A PU or PE normally chooses the ENRP server on their local
      host as the home ENRP server (if one exists).  A PU or PE should
      only have one home ENRP server at any given time.  Having a "home"
      ENRP server helps provide a mechanism to minimize the number of
      associations a given PE will have.

[ENRP]
Home ENRP server: The ENRP server to which a PE or PU currently
      belongs.  A PE MUST only have one home ENRP server at any given
      time and both the PE and its home ENRP server MUST keep track of
      this master/slave relationship between them.  A PU SHOULD select
      one of the available ENRP servers as its home ENRP server, but the
      ENRP server does not need to know, nor does it need to keep track
      of this relationship. 

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Qiaobing Xie <[email-masked]>
Date: Wed, 04 Aug 2004 01:09:55 -0700

Walter,

Thanks for the comments.

> There are many inconsistencies between the two drafts that seemed to surface when the protocols were separated into there own drafts. Will these be merged back together? Or does work need to be don…

The reason to have separate documents is to better manage the complexity. It was a working 
group decision made a long time ago and I think it worked well. I personally do not have a 
problem with multiple documents (DDDS is published in 4 separate RFCs, for example). As a 
coauthor I will do my best to fix any inconsistencies whenever they are noted and I believe 
other coauthors will do the same. And the text quality will only improve with more comments 
like yours.

> 1) The same action is described differently between documents. For instance, Registration is described in both the ENRP and ASAP document differently. The question here should be whether Registrati…

As you can guess, one place is normative and the other is informative. We will make this 
more clear. But I disagree that only one document should be allowed to have the description 
since doing that will obviously impair the readability of the document without the description.

>       ENRP server does not need to know, nor does it need to keep track

Good catch. Will have this fixed.

regards,
-Qiaobing