Subject: [Rserpool] PEER_ERROR message

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Mon, 11 Oct 2004 15:46:51 -0500

Any reference to the PEER_ERROR message should be removed from the ASAP protocol document since I believe it is not an ASAP message. It is an ENRP message. In fact, both documents define PEER_ERROR but completely differently. I think it simply got added into the ASAP document sometime accidentally and has remained there ever since. 

The locations within the ASAP protocol document where it should be removed are the TOC, the message list in section 3, and section 3.11 should be deleted. Within the ENRP document, I couldn't find the use of the PEER_ERROR message easily since it is mislabeled ENRP_ERROR in section 4.12. 

Can this be fixed?

Thanks
Walter

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Tue, 12 Oct 2004 11:00:39 +0200

On Monday 11 October 2004 22:46, Johnson Walter-CWJ002 wrote:
> Any reference to the PEER_ERROR message should be removed from the ASAP
> protocol document since I believe it is not an ASAP message.

It is useful to have this message type in ASAP, because e.g. a component (NS, 
PE or PU) could receive a bad message via ASAP. Then, it can report the 
sender that it does not understand/accept this message via a PEER_ERROR. This 
is useful for debugging.

To make ASAP and ENRP PEER_ERROR more consistent, their definitions and 
especially the message type number (currently: 0x0e or ASAP, 0x0b for ENRP) 
could be unified. For example, the message number could be 0xff for both.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz

 University of Essen,                            Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
- -----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

---

From: Randall Stewart <[email-masked]>
Date: Tue, 12 Oct 2004 10:25:54 -0400

Thomas.. I have taken this
suggestion.

Next revision we will make PEER_ERROR the same
error number (0xe)

and then change all reference to ENRP_ERROR
to PEER_ERROR

R

Thomas Dreibholz wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
> 
> iD8DBQFBa50632BbsHYPLWURAg5hAJwPJxLFPfWhNx0afzjntqKl/rmgagCdGO+G
> EDx/otU5qMtWX79xZKnCSxU=
> =K88g
> -----END PGP SIGNATURE-----
>

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 12 Oct 2004 19:27:21 +0200

Dear all,

just a general thought.

we decided to align the parameters between APAP and ENRP, that is why
we have the common parameter ID. As far as I think, we also decided not
to align the messages between ASAP and ENRP. This might become more
complex in the future.

So I'm not sure what it helps in aligning the type number, the error  
causes
will be different and the code will also be different...

Best regards
Michael

On Oct 12, 2004, at 16:25 Uhr, Randall Stewart wrote:

>> It is useful to have this message type in ASAP, because e.g. a  
>> component (NS, PE or PU) could receive a bad message via ASAP. Then,  
>> it can report the sender that it does not understand/accept this  
>> message via a PEER_ERROR. This is useful for debugging.
>> To make ASAP and ENRP PEER_ERROR more consistent, their definitions  
>> and especially the message type number (currently: 0x0e or ASAP, 0x0b  
>> for ENRP) could be unified. For example, the message number could be  
>> 0xff for both.
>> Best regards
>> - --  
>> -  
>> ---------------------------------------------------------------------- 
>> -

---

From: Randall Stewart <[email-masked]>
Date: Tue, 12 Oct 2004 15:37:16 -0400

Hmm.. that is a good point.. maybe it is
best just to leave the number..

However the error name ENRP_ERROR or PEER_ERROR needs
to be the same throughout the enrp doucment..

And if we have no use for it in ASAP.. then we may
want to get rid of it.. or if we do have a use then
lets write up how it is used :-D

I do like PEER_ERROR for both of them.. even though
it may mean something different :-o

R

Michael Tuexen wrote:
>>> and especially the message type number (currently: 0x0e or ASAP, 
>>> 0x0b  for ENRP) could be unified. For example, the message number 
>>> could be  0xff for both.
>>> Best regards
>>> - --  
>>> ====================================================================== =
>>> ---------------------------------------------------------------------- -
>>> ====================================================================== =