Subject: RE: [Rserpool] PEER_ERROR message

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Tue, 12 Oct 2004 15:29:35 -0500

Randall Stewart <> wrote:
> Hmm.. that is a good point.. maybe it is
> best just to leave the number..
> 

Agreed.

> However the error name ENRP_ERROR or PEER_ERROR needs
> to be the same throughout the enrp doucment..
> 

Agreed.

> And if we have no use for it in ASAP.. then we may
> want to get rid of it.. or if we do have a use then
> lets write up how it is used :-D
> 

Agreed.

> I do like PEER_ERROR for both of them.. even though
> it may mean something different :-o
> 

Disagree, but really don't have a strong opinion. I know one can sort on the protocol and the message type to determine how to decode the message. But having separate names makes it clear to readers new to the ASAP and ENRP drafts that these are unique messages with unique uses. Within the drafts, the message names only act as tags for the real messages sent over the wire so why not make them as descriptive as possible. In this case, it might be best to make it ASAP_ERROR and ENRP_ERROR to identify the protocol error type.  For instance, an ENRP namespace server can potentially receive both types of errors and there might be a need to describe a situation where both are received. This would be much easier to explain using unique names than describing both as PEER_ERROR. Just my thought.

> R

Walter

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 13 Oct 2004 10:26:40 +0200

On Tuesday 12 October 2004 22:29, Johnson Walter-CWJ002 wrote:
> Within the
> drafts, the message names only act as tags for the real messages sent over
> the wire so why not make them as descriptive as possible. In this case, it
> might be best to make it ASAP_ERROR and ENRP_ERROR to identify the protocol
> error type.

This is a good idea.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz

 University of Essen,                            Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
- -----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 13 Oct 2004 10:44:49 +0200

I like the idea, too.

Best regards
Michael

On Oct 13, 2004, at 10:26 Uhr, Thomas Dreibholz wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -  
> -----------------------------------------------------------------------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
>
> iD8DBQFBbObD32BbsHYPLWURAg9XAJ9vEEkB/jDFHmGbES//iXSCmcaObgCggRLI
> LmYzwgU86EPObK9OWdYrUeo=
> =0RGl
> -----END PGP SIGNATURE-----
>

---

From: Randall Stewart <[email-masked]>
Date: Wed, 13 Oct 2004 05:54:20 -0400

Done

(even though I am not sure what a ASAP_ERROR is for)... maybe
we can discuss this in Washington and I can add
some text then..

R