Subject: operation subobject

From: Rahul Aggarwal <[email-masked]>
Date: Sat, 24 Jun 2000 15:03:01 -0700

Lou et al.,
draft-ietf-mpls-lsp-tunnel-05.txt says: (4.3.2)

" The explicit route is encoded as a series of subobjects contained in
   an EXPLICIT_ROUTE object.  Each subobject may identify a group of
   nodes in the explicit route or may specify an operation to be
   performed along the path."

The 'operation subobject' is also mentioned a few times in the section on 
processing of the explicit route object (4.3.4). Eg:

 "If the first subobject is an
   operation subobject, the message is in error and the system SHOULD
   return a "Bad EXPLICIT_ROUTE object" error"

I have not been able to find encodings etc of the operation subobject. No
value has been assigned for an operation subobject in the type field of
an ERO subobject. Are the details of this object a matter of local policy?

I will appreciate it if you could shed some light on the usage, definition and
format of the operation subobject.

Thanks,
rahul

---

From: Rohit Chhapolia <[email-masked]>
Date: Mon, 26 Jun 2000 09:32:24 -0400

Rahul,

There used to be an operational sub-object in the previous
versions of this draft which has been removed after much
discussion on the mailing list and the conclusion that it
is not being used. The text in these sections has not been
updated accordingly. I guess it will get updated in the next
version.

Rohit

-- 
Rohit Chhapolia
Globespan, Inc.
mailto:[email-masked]
http://www.globespan.net

---

From: Lou Berger <[email-masked]>
Date: Tue, 27 Jun 2000 20:52:52 -0400

I believe this is correct.

Lou