Subject: RE: Implementation RSVP in Windows 2000

From: "Yoram Bernet" <[email-masked]>
Date: Wed, 7 Jun 2000 06:29:47 -0700

You can start Phone Dialer (Start-->Programs-->Accessories-->Phone
DIaler). Or, Netmeeting
(Start-->Programs-->Accessories-->Communications-->Netmeeting). Either
app will get you going, out of the box, in generating RSVP signaling and
in DiffServ/802 marking based on the results of signaling. Also - see
the Admission Control Server in Win2K server.
 
Good luck. Let me know if you need additional info.
 
Yoram

-----Original Message-----
From: X Chen [mailto:[email-masked]]
Sent: Wednesday, June 07, 2000 1:29 PM
To: [email-masked]
Cc: mankin; rap; [email-masked]
Subject: Implementation RSVP in Windows 2000

I am doing a project about implementating RSVP in the Windows 2000. Now
I have built a test beds with all the computers using window 2000 Sever
and all the NICs are 802.1p supported. But are there some applications
QoS-enabled which I can use to do the test in the test bed? Or I must
write the QoS enabled application which can generate RSVP messages
myself?
 
Please help me
Thanks a lot
 
X Chen
The university of Sheffield

---

From: "X Chen" <[email-masked]>
Date: Thu, 8 Jun 2000 13:51:27 -0700

Hi, Ramesh:
thanks for your information, I also have several questions to ask you.
1. Is NetMon you mentioned is Network monitor? If it is, I can access Network monitor.
2. In my test bed, I have 4 computers, 2 routers, one client and one sever. The NICs in the routers which are running ACS are 802.1p supported, is it nessesery that the NICs on client and server must 802.1p supported? 
3. You mentioned that "Description of the tracefiles can be found in the on-line help.", what is the on-line help you mean.

I said that the RSVP in Win2k is defferent with standard RSVP, what I mean is the application such as Netmeeting, I am not allowed to set the QoS parameters, it seems that thet are set automatically by Win2k( I can't find where I can set them.) Actually, I haven't really started using Netmeeting to do the test, I just worry about whether it can generate RSVP messages.
  ----- Original Message ----- 
  From: Ramesh Pabbati 
  To: Yoram Bernet ; X Chen 
  Sent: Wednesday, June 07, 2000 9:19 AM
  Subject: RE: Implementation RSVP in Windows 2000

  X Chen,
   
      Are you running a server with ACS? If yes you can not run NetMeeting on the server which is also ACS. 
      
      Why did you say Windows 2000 RSVP is little different than standard RSVP? 
   
      If you don't have access to NetMon you can turn on RSVP message tracing by creating the following registry key, 
   
          EnableTracing
   
          under
   
          HKLM\SYSTEM\CurrentControlSet\Services\RSVP\Parameters
   
          of type REG_DWORD and set the value to 1
   
  this will generate text files containing RSVP message. These files are created in %WINDIR%\SYSTEM32\LogFiles directory. These text files contain the Tspec, FlowSpec etc. These files come very handy for you to see what RSVP messages are being received and sent out. Description of the tracefiles can be found in the on-line help.
   
      Ramesh
    -----Original Message-----
    From: Yoram Bernet 
    Sent: Wednesday, June 07, 2000 9:04 AM
    To: X Chen
    Cc: Ramesh Pabbati
    Subject: RE: Implementation RSVP in Windows 2000

    X Chen:
     
    I just wanted to understand if you were building your own RSVP or using the one that is in Win2K. You are correct - RSVP operates as you describe in Win2K. It is standard RSVP. 
     
    The QoS parameters of Netmeeting are automatically selected by the NetMeeting app. You should be able to use netmon to capture and study the messages.
     
    I have coipied Ramesh, who is our RSVP expert.
     
    Regards,
    Yoram
      -----Original Message-----
      From: X Chen [mailto:[email-masked]]
      Sent: Wednesday, June 07, 2000 4:55 PM
      To: Yoram Bernet
      Subject: Re: Implementation RSVP in Windows 2000

      Excuse me, can you explain to me what you mean "implementing " and native rsvp?
      As far as I know, the qos in Win2k is a little bit different with the standard rsvp, if the applications(receiver and sender) can generate RSVP messages, the QoS provider and ACS can reponse for those messages, and grants the bandwidth they want.

      BTW, I just configured the Netmeeting in the server and client in my testbed, but only one can access to Internet, and I checked the configuration of the Netmeeting, I can't find that where I can set the QoS parameters? If you know, please tell me in a little bit more detail.
      Original Message ----- 
        From: Yoram Bernet 
        To: X Chen 
        Sent: Wednesday, June 07, 2000 8:01 AM
        Subject: RE: Implementation RSVP in Windows 2000

        BTW - are you actually *implementing* RSVP? or are you using the native RSVP in Win2K?
         
        Yoram
          -----Original Message-----

          I am doing a project about implementating RSVP in the Windows 2000. Now I have built a test beds with all the computers using window 2000 Sever and all the NICs are 802.1p supported. But are there some applications QoS-enabled which I can use to do the test in the test bed? Or I must write the QoS enabled application which can generate RSVP messages myself?

          Please help me
          Thanks a lot

          X Chen