Subject: RE: CR-LDP traffic parameter TLV and RSVP

From: Shahram Davari <[email-masked]>
Date: Thu, 28 Sep 2000 09:32:52 -0700

Hi,

> -----Original Message-----
> From: David Charlap [mailto:[email-masked]]
> Sent: Tuesday, September 26, 2000 10:34 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: CR-LDP traffic parameter TLV and RSVP
> 
> 
> Curtis Villamizar wrote:
> > David Charlap writes:
> >>
> >> (And if you want to only use one LSP per DiffServ class, then you
> >> don't have to signal the class at all - you can just 
> signal QoS for a
> >> bunch of LSPs and let the edge routers do all the DiffServ work.)
> > 
> > This is a unique idea.  How does the router at the edge do WFQ or
> > implement the three drop preferences for an AF class?  :-)
> 
> It doesn't.  It picks IntServ parameters that approximate the 
> QoS level
> required for each DS class and uses them when signalling the tunnels. 
> If the LSPs are signalled using the COS-type of TSpec and 
> FlowSpec, then
> the switches in the cloud will have to have some sort of 
> agreement about
> what the non-zero classes are supposed to mean.
> 
> All the edge router does on the data plane is use the DS bits to pick
> which tunnel to forward the traffic into.  If the tunnels 
> have different
> QoS or priority levels, then the different DS classes will end up with
> those levels as well.

It seems that you are mapping Diffserv PHBs to Intserv classes. In other
words
you want an Intserv network to behave like a PHB. This seems odd to me, and
probably
of no real world use. 

> 
> In this setup, the MPLS cloud is not actually using DS at all - it's
> simply mapping the DS classes onto tunnels have their own 
> QoS/COS levels
> that are signalled independantly of any DS signalling.
> 
> -- David
>

---

From: David Charlap <[email-masked]>
Date: Thu, 28 Sep 2000 12:51:18 -0400

Shahram Davari wrote:
> 
> It seems that you are mapping Diffserv PHBs to Intserv classes.  In
> other words you want an Intserv network to behave like a PHB. This
> seems odd to me, and probably of no real world use.

I didn't say what I'm doing.  And I didn't say what I want.

I merely mentioned another possible way of using DS and MPLS together. 
A way that I had already previously stated was not optimal, compared to
the current draft.  Somone else then asked a question, which I answered.

-- David