Subject: RE: CR-LDP traffic parameter TLV and RSVP

From: Shahram Davari <[email-masked]>
Date: Wed, 13 Sep 2000 09:15:25 -0700

Hi Mark,

For supporting Diffserv, a new Diffserv object/TLV is introduced for RSVP
and CR-LDP respectively in "MPLS support of Diffserv draft". In case of
RSVP, if the Diffserv object and the CoS object are not present the node
should implement Intserv, however, the presence of each one indicates
non-Intserv (Diffserv) implementation.

Regards,
-Shahram

-----Original Message-----
From: Mark Dewey [mailto:[email-masked]]
Sent: Wednesday, August 30, 2000 1:55 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: CR-LDP traffic parameter TLV and RSVP

Hi,

   I apologize for the wide distribution. I am not sure which mailing list 
this question belongs to.

   I understand, in CR-LDP, the qos characteristics(e.g bandwidth) of an LSP

tunnel can be specified in traffic parameter (e.g CDR) TLV.

How is this value  specified in RSVP if it were used to establish a LSP 
tunnel with qos characteristics?

If sender TSPEC object is used, should the node implement integrated 
services (CL,GS)?

Thanks,
-Mark

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.

---

From: Shahram Davari <[email-masked]>
Date: Thu, 28 Sep 2000 16:10:45 -0700

> From: David Charlap [mailto:[email-masked]]
> Sent: Thursday, September 28, 2000 12:41 PM
> To: [email-masked]
> Subject: Re: CR-LDP traffic parameter TLV and RSVP
> 
> 
> Shahram Davari wrote:
> > David Charlap wrote:
> >>
> >> You really can't.  There is no defined meaning for COS-type
> >> values other than zero (best effort).  Any other value may be
> >> ignored, rejected, or handled in a way you don't want.
> > 
> > Yes off course you can. You could map any COS-Type to a local
> > (non-standard) DSCP value.
> 
> And ensure that every router along the LSP accepts the 
> non-zero COS-type
> and handles it in the intended way.

This property is required and can be done by configuration of 
each router.

> 
> A human administrator may be able to make that guarantee, but 
> there's no
> way switch software can do so on its own.

After the configuration is done (which is done only once), then
the switch software could recognize the local PHB from
the DSCP.

> 
> In other words, any use of these COS-types to map DS classes 
> would have
> to be through explicit administrative control.  Such mappings 
> can not be
> made automatically, because successful implementation requres
> meta-knowledge of how the entire cloud will support this non-standard
> feature.

I don't think there is any need of making such a mapping automatic.

> 
> (Of course, a new draft may come along to solve this problem, 
> if people
> really care.  But that changes the problem - after approval of such a
> draft, use of the COS-type would no longer be non-standard.)
> 

CoS or DSCP both indicate a PHB that a packet must receive
at each node. Now that Diffserv is standardized, there is no point in using
CoS any more, because you could signal any required PHB using DSCP (Diffserv
object)

-Shahram

> -- David