Subject: Re: Allocation of resources

From: sunil zackaria <[email-masked]>
Date: Thu, 11 Jan 2001 22:44:31 -0800 (PST)

Hi,

Thanks for the reply.
But the doubt was in relation to RSVP.

I am working on a project related to SIP & it needs
Qos Support.
For that I am working on RSVP .

My doubt about Allocation of resources was in relation
to RSVP as certain quantified values of resources are
needed to be given to the Traffic Controller for the
actual reservation to happen and I think these values
should be variable. So  Who will decide on those
values.  Is it UA who will provide these or are there
any other mechanism to fill the TSpec structure
which will in turn form part of PATH message.

Also who will populate FilterSpec, FlowSpec etc.

Thanks in advance,

Sunil.

--- ajd1 <[email-masked]> wrote:
> What is the specific application you are thinking
> about?
> Typically, the audio is sampled and encoded into
> packets using
> a particular codec (e.g. G.728 or G.723 etc.). These
> packets
> are then encapsulated into the RTP protocol that
> runs over UDP.
> The codecs themselves have a fixed sampling rate (20
> ms for
> G.728, 30 ms for G.723 etc.) and produce a fixed
> rate of
> packets (16 kbits/sec for G.728, 6.3 kbits/sec for
> G.723)
> The h/w or s/w that does the encoding of the codec
> might stuff
> multiple samples into one RTP packet. But assuming
> that
> it only puts one sample into an RTP packet, you can
> figure
> out how many bytes of data  will be present in a 20
> ms
> sample of a codec that produces 16 kbits/sec. Once
> you
> have that info, you then add the size of the RTP,
> UDP and IP
> headers to get the total size of the packet. So now
> you know
> the size of the packet that will be traversing the
> network
> every 20 ms. So, you can figure out the bandwidth
> required
> for such a connection. Things get a little more
> complex if
> your application does silence detetction and does
> not send
> packets if there is no audio. The bandwidth
> requirement
> then will be less that what you calculated above.
> Anyway, the bottom line is that if you use a
> particular codec
> to transport audio, you can calculate how much
> bandwidth
> will be required by that application and you can
> configure your
> application to reserve that much bandwidth using
> rsvp before your
> application starts transporting the audio.  Hope
> this helps.
> Alfred D'Souza
> 
> sunil zackaria wrote:
> 
> > Hi,
> >
> > Does any body know as to how is it determined that
> for
> > a type of service, for eg. audio, how much of the
> > resources in the hardware  will be allocated and
> who
> > decides this, whether the higher application or
> the
> > RSVP itself.
> >
> > Is there any standards as to what is the optimal
> > allocation that is required for the services.
> >
> > Thanks in advance,
> >
> > Sunil.
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Yahoo! Photos - Share your holiday photos online!
> > http://photos.yahoo.com/
> 

__________________________________________________
Do You Yahoo!?
Yahoo! Photos - Share your holiday photos online!
http://photos.yahoo.com/

---

From: Bob Braden <[email-masked]>
Date: Fri, 12 Jan 2001 17:25:35 GMT

*> 
  *> My doubt about Allocation of resources was in relation
  *> to RSVP as certain quantified values of resources are
  *> needed to be given to the Traffic Controller for the
  *> actual reservation to happen and I think these values
  *> should be variable. So  Who will decide on those
  *> values.  Is it UA who will provide these or are there

The reservation parameters are certainly application-dependent, so the
most obvious assumption is that the application (UA) supplies them.
One might imagine other ways to organize the software in an end system --
e.g., some system daemon that reads a configuration file to handle
legacy applications that were written without QoS awareness.  But the
normal situation is surely that a QoS-aware application sets the
reservation parameters.

Bob Braden