Subject: Parse error -8?

From: Craig Rodrigues <[email-masked]>
Date: Mon, 18 Jun 2001 15:20:40 -0400

Hi,

I am doing some testing with ISI RSVPD release 4.2a4-1.

I am running things in my testbed, and am periodically
getting this error message on one of my hosts:

============================================================================
14:16:55.448|T Snd Raw  RESV      carob.bbn.com/8000[17]    0=>eth0 > athos-e0.bbn.com/63
  RESV: Sess: carob.bbn.com/8000[17]    R: 30000   NHOP: <carob.bbn.com LIH=0>        Scope={bayberry.bbn.com}   WF   [CL T=[9.2K(5K) 100B/s 368 65.5K] ]

14:16:55.460|  Rcv Raw  RCONFIRM  carob.bbn.com/8000[17]    eth0<=0 < athos-e0.bbn.com/254
  CONFIRM: Sess: carob.bbn.com/8000[17]
        ERR#: 23 Value: 1       Node: athos-e0.bbn.com  Flags:
   WF   [CL T=[9.2K(5K) 100B/s 368 65.5K] ]
 
14:16:55.467
14:16:55.467 Parse error -8 in raw pkt from 128.33.14.196
x00:  10070000 ff004c00 0c000101 80210f05
x10:  11001f40 0c000601 80210ec4 00170100
x20:  08000801 11000000 24000902 00000700
x30:  05000600 7f000500 00c00f46 00409c45
x40:  0000c842 70010000 ffff0000                                
============================================================================

Does anyone know what causes this "Parser error -8" error message?

I'm baffled by it.

Thanks.
-- 
Craig Rodrigues        Distributed Systems and Logistics, Office 6/304
[email-masked]       BBN Technologies
(617) 873-4725         Cambridge, MA

---

From: Bob Braden <[email-masked]>
Date: Mon, 18 Jun 2001 20:45:59 GMT

First of all, this message should be directed to the [email-masked]
mailing list, which is concerned with particular implementations.

  *> 
  *> ============================================================================
  *> 14:16:55.448|T Snd Raw  RESV      carob.bbn.com/8000[17]    0=>eth0 > athos-e0.bbn.com/63
  *>   RESV: Sess: carob.bbn.com/8000[17]    R: 30000   NHOP: <carob.bbn.com LIH=0>        Scope={bayberry.bbn.com}   WF   [CL T=[9.2K(5K) 100B/s 368 65.5K] ]
  *>  
  *>  
  *> 14:16:55.460|  Rcv Raw  RCONFIRM  carob.bbn.com/8000[17]    eth0<=0 < athos-e0.bbn.com/254
  *>   CONFIRM: Sess: carob.bbn.com/8000[17]
  *>         ERR#: 23 Value: 1       Node: athos-e0.bbn.com  Flags:
  *>    WF   [CL T=[9.2K(5K) 100B/s 368 65.5K] ]
  *>  
  *> 14:16:55.467
  *> 14:16:55.467 Parse error -8 in raw pkt from 128.33.14.196
  *> x00:  10070000 ff004c00 0c000101 80210f05
  *> x10:  11001f40 0c000601 80210ec4 00170100
  *> x20:  08000801 11000000 24000902 00000700
  *> x30:  05000600 7f000500 00c00f46 00409c45
  *> x40:  0000c842 70010000 ffff0000      

"Teach a man to fish..."  etc.

    gra 519% grep '\-8' *h
    rsvp_var.h:#define PKT_ERR_MISSOBJ   -8 /* Missing required object   */

Now you know what the error, is, all you have to do is decode the
hex dump of the packet enough to see what objects are there and
what objects are missing, given the message type.

Bob Braden