Subject: Refresh Time Computation

From: Madhusudhan M <[email-masked]>
Date: Tue, 19 Jun 2001 14:38:41 +0530

Hi

   Correct me if i am wrong!!!!
   In the ISI implementation, in compute_R functionality,

   It seems to be like the the refresh interval stored in the Session is always equal to 
   REFRESH_DEFAULT itself.

   The Compute_R function is called everytime a new PSB is created.The timer is added only 
   when the first PSB is created. 

   So for the first PSB being created in the session, the IN parameter is the TIMEVAL object in the 
   Session Table.The new refresh period is stored in the object itself and the old value is returned

       timnew = REFRESH_DEFAULT;
       /*  Base R could depend on load.
        */

        if ((timold = tvp->timev_R)) {
        /*
         *  Limit slew rate
	 */
               tvp->timev_R = MIN(timnew, (1+REFRESH_SLEW_MAX)*timold);
         }
	 else
	       tvp->timev_R = timnew;
	 return(timold);
								      
so when the function is called for the first PSB, the refresh interval is set to
DEFAULT_REFRESH.
Next time when the function is called, then

timold = tvp->timev_R = REFRESH_DEFAULT

REFRESH_SLEW_MAX is a +ve quantity. So the term (1+REFRESH_SLEW_MAX)*timold) is always 
greater than REFRESH_DEFAULT

So again the new refresh value is equal to REFRESH_DEFAULT only

Regards

-- 
Madhusudhan
----------------
He hath eaten me out of house and home.
		-- William Shakespeare, "Henry IV"

---

From: "Amarendra" <[email-masked]>
Date: Tue, 19 Jun 2001 19:20:08 +0530

Hi all,

What is the signeficance of NULL  object in RSVP msg?

In RFC 2205
sec 3.1.2

"NULL

                   A NULL object has a Class-Num of zero, and its C-Type
                   is ignored.  Its length must be at least 4, but can
                   be any multiple of 4.  A NULL object may appear
                   anywhere in a sequence of objects, and its contents
                   will be ignored by the receiver."

Regards
Amarendra