Subject: RE: charter goal #1b

From: Kappler Cornelia <[email-masked]>
Date: Mon, 5 Feb 2001 17:37:46 +0100

> -----Original Message-----
> From:	Juergen Quittek [SMTP:[email-masked]]
> Sent:	Thursday, February 01, 2001 6:49 PM
> To:	RTFM mailing list
> Subject:	charter goal #1b
> 
> Goal 1 of the suggested charter:
> 
> > Develop a standard for describing traffic flows, and for
> > reporting them from a meter to a flow flow data collection
> > system.  Such a standard would meet a clearly-expressed
> > need for many system vendors.
> 
> Now the second issue (#1b):
> 
> > Develop a standard for reporting them from a meter to a 
> > flow data collection system.
> 
> - What would be the resulting benefit?
>   A meter reporting actively is highly desirable. I have been
>   working in several projects where meters for accounting were
>   required. In this application the meter is required to notify
>   the reader when a new flow (table entry) is established and
>   - even more important - when a flow times out and accounting
>   for that session can be completed.
> 
I agree with this suggestion.

However, as for 1a, I think the wording of the goals can be improved. My understanding is a standard for reporting flows already was specified in the rtfm architecture. What Juergen proposes is an extension to the standard. So what is meant by the goal. Extending the standard, or completely reworking it? 

If it is extensions, I think a list of possible extensions should be given in the charter.

If it is a complete rework, reasons should be given why the current standard is insufficient, and what will be different with a new standard.

> - Is it or does it appear to be technically feasible?
>   Yes, definitely. The current RTFM architecture and the Meter
>   MIB comply with the SNMP policy of assigning the active part
>   to the reader (SNMP manager) and the passive part to the
>   meter (SNMP agent), except for some extraordinary situations.
> 
>   Now this policy has to be violated. The meter will notify
>   the reader in ordinary cases. This is technically no problem
>   nor even with SNMP.
> 
> - Is "now" the right time to work on this item?
>   Yes, there are a lot of applications that would benefit from
>   such an improvement of the current RTFM architecture.
> 
> - Can we expect sufficient support by technical,
>   experts, i.e. who is willing to contribute?
>   Yes, definitely. There a many people in the NeTraMet user
>   community waiting for such an improvement. Several of them
>   will be willing to help and contribute their ideas and
>   concerns.
> 
> - What would be the expected output documents?
>   A revision of the RTFM architecture and the Meter MIB
> 
> - What timeframe would be appropriate?
>   I estimate one year or less.
> 
> - Is the IETF the right place for this item?
>   Yes, no question. It is a modification of IETF documents
>   including an IETF standard.
> 
>  Cornelia
> 
> 
--------------------
Cornelia Kappler
Standards & Technology
ICM N MC ST3
Siemens AG, Siemensdamm 62, 13629 Berlin, Germany

---

From: Juergen Quittek <[email-masked]>
Date: Thu, 08 Feb 2001 08:36:01 +0100

Hi Cornelia,

thanks for the comments.

Kappler Cornelia wrote:
 [...]
> However, as for 1a, I think the wording of the goals can be improved.
> My understanding is a standard for reporting flows already was specified
> in the rtfm architecture. What Juergen proposes is an extension to the
> standard. So what is meant by the goal. Extending the standard, or
> completely reworking it?
> 
> If it is a complete rework, reasons should be given why the current
> standard is insufficient, and what will be different with a new standard.
> 

I tend to do neither extend the standard, nor rework it completely.
For me this is more an evolvement. The standard is out for some time,
and some shortcomings (and many benefits!) have been observed.
Now, we should work on the shortcomings. This does not need a complete
rework, but an improvement of some things. I doubt, that we can have
this as pure extensions without modifying the existing definitions.

    Juergen
-- 
Juergen Quittek     [email-masked]     Tel: +49 6221 90511-15
NEC Europe Ltd., C&C Research Laboratories   Fax: +49 6221 90511-55
Adenauerplatz 6, 69115 Heidelberg, Germany   http://www.ccrle.nec.de