Subject: RE: Review Call: draft-atlas-ip-local-protect-00.txt as WG item

From: "Don Fedyk" <[email-masked]>
Date: Mon, 10 May 2004 10:57:44 -0400

Hi Stewart

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]] 
> Sent: Monday, May 10, 2004 6:48 AM
> 
> Whilst I agree that the topic of link and node protection
> in an IP network should be a work item for the IETF, it
> is premature to accept draft-atlas-ip-local-protect-00.txt
> as WG item.
> 
> I believe that there may exist a number of alternate
> solutions to this problem. I think that we should
> fully describe the problem and properly explore
> the alternative solutions before accepting this draft
> as a WG item.
> 
Please elaborate more on the solutions.

Thanks,
Don 

> - Stewart
> 
> 
> _______________________________________________
> Rtgwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rtgwg
> 

_______________________________________________
Rtgwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rtgwg

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 11 May 2004 20:59:55 +0100

> Please elaborate more on the solutions.

We will submit a draft on our proposals.

- Stewart

---

From: Alex Zinin <[email-masked]>
Date: Thu, 13 May 2004 10:00:35 -0700

Folks-

 Based on the feedback we got on the list and I got unicast, making
 draft-atlas-ip-local-protect-00.txt as a whole a WG item would be premature. On
 the other hand, I believe we need to make progress on this topic. I suggest
 that we do the following:

  1. I believe that we have a pretty good understanding on what the _basic_ IP
     FRR mechanism should be: vanilla loop-free feasible next-hops (what is called
     "loop-free alternates" in Alia's document, or "downstream paths" in 10589,
     I believe), no U-turns-like optimizations, simple and safe. I think we
     shouldn't spend a lot of time on this topic, just write the spec.

  2. Advanced methods is where I see the field for play: U-turns, what Mike and
     Stewart have, etc. Here we can take more time to discuss and see which
     direction we want to go long-term. Note that I think these SHOULD NOT be
     part of the basic spec, but rather separate document(s).

  3. Alia's draft covers both the basic mechanism, and U-turns. Other folks are
     coming up with more drafts.

     My recommendation to Alia would be to move U-turns to a separate draft and
     revise the main draft to talk about the basic mechanism only. It seems that
     the draft would then have a good chance of becoming a WG item.

     My recommendation to others would be to submit their [advanced] proposals
     reasonably soon--I'd like us to have the first review of the available
     methods in San Diego and complete the selection process by the DC meeting.

 Opinions are welcome.

--
Alex

---

From: Alia Atlas <[email-masked]>
Date: Fri, 14 May 2004 08:43:51 -0400

>      the draft would then have a good chance of becoming a WG item.

I'll break up the draft, move the U-turns to a separate document, and 
submit a revised draft on the basic loop-free feasible alternates.

>      methods in San Diego and complete the selection process by the DC 

Yes, I'd very much like to start discussing U-turn alternates and whatever 
alternatives that Stewart is planning on describing.

Alia