Subject: one-hop forwarding loops and PLSN

From: Alia Atlas <[email-masked]>
Date: Thu, 29 Sep 2005 13:46:07 -0700

A concern that Mike and Stewart have raised in the past about PLSN is that,
because PLSN doesn't prevent 100% of the loops, there can be
collateral damage due to looping traffic on some links.

What if there were the recommendation that (in this context) packets
cannot be sent back out the same interface that the packets were received
on?

This would solve the collateral damage case for those single-hop loops that
aren't
prevented. Of course, it wouldn't help with the multi-hop loops.

Thoughts?

Alia
_______________________________________________
Rtgwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rtgwg

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 29 Sep 2005 22:11:16 +0100

Alia Atlas wrote:

> cannot be sent back out the same interface that the packets were 
> received on?

That is a change to forwarding, and hence a change to hardware.

As you say below is only a partial solution. On the other hand
we do have solutions that fully solve the problem, one
of which is control plane only change (oFIB/oSPF).

- Stewart

> 
> This would solve the collateral damage case for those single-hop loops 
> that aren't
> ------------------------------------------------------------------------
>