Subject: FYI -- Informal LISP BOF scheduled for lunch time on Thursday

From: David Meyer <[email-masked]>
Date: Wed, 5 Dec 2007 09:50:28 -0800

(Posted on behalf of Dino, who didn't have posting privileges on
ops-dir or rtgwg).

Looking forward to seeing you all on Thursday. 

Thanks,

Dino/DaveM/Vince/Darrel/Scott/Eliot/DaveO/Noel/John Curran

>> From: Dino Farinacci <[email-masked]>
>> Date: December 4, 2007 10:41:19 AM PST
>> To: Jari Arkko <[email-masked]>
>> Cc: David Meyer <[email-masked]>, [email-masked], [email-masked], [email-masked]
>> Subject: Re: [RRG] Informal LISP BOF scheduled for lunch time on Thursday
>>
>>> A few words about the background for this may be useful. This slot is
>>> primarily targeted towards educating additional people about one of the
>>> proposals in the RRG. I.e., help people get up to speed. This allows the
>>> RRG to focus on discussing the actual problems and not give tutorials
>>> about what the basics of the proposals are.
>>
>> Thanks for the clarification Jari. The plan is to give a LISP Tutorial 
>> level presentation at the lunchtime session on Thu ~11:40-1:00. 
>>
>>
>> We would like to present to give background to the audience so we can 
>> solicit reaction and feedback.
>>
>>> The second slot of the RRG meeting this week is on Friday morning. LISP
>>> is up for discussion there as well. All of the proposals in the group
>>
>> At the Friday session we plan on giving a LISP update. That is, changes 
>> what have happened since last IETF in Chicago. We will get into more 
>> protocol details at this session.
>>
>> Thanks,
>> Dino/DaveM/Vince/Darrel/Scott/Eliot/DaveO/Noel/John Curran
>>
>>
>

----- End forwarded message -----
_______________________________________________
rtgwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rtgwg

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 05 Dec 2007 19:32:33 -0800

Hi David,

So today at the Routing Area Open Meeting you have explicitly expressed 
the concern that "routing is about to collapse".

I found this statement very interesting.

I have been following and discussing with various folks this new wave of 
fixing the routing. In fact I have my own set of ideas which are in fact 
very very close to what Lixia was already proposing. Till now even 
looking ten years ahead no one can show the significant proof that 
"routing is about to collapse".

Contrary there are number of vendors with deployed platforms which are 
today carrying ten fold number of routes what today's internet carry for 
some other applications.

So I think perhaps it is late before the BOF ... do you have data 
references which would lead you to believe that routing is about to 
really collapse ?

Cheers,
R.

PS. Said all of the above I think there are many other benefits for 
introducing the hierarchy in the inter domain routing .. hence I am very 
much supporting this as individual. I am just trying to make sure we 
focus on the correct problem not the imaginary/non-existent ones :).

---

From: David Meyer <[email-masked]>
Date: Thu, 6 Dec 2007 09:42:49 -0800

On Wed, Dec 05, 2007 at 07:32:33PM -0800, Robert Raszuk wrote:
> Hi David,
>
> So today at the Routing Area Open Meeting you have explicitly expressed the 
> concern that "routing is about to collapse".
>

	I'm not sure what I said exactly, but if I said that, I
	probably misspoke (one of the dangers of speaking on the
	fly, I suppose). But in any event, there is stress on the
	routing system. And BTW, I'm sure one can find ISPs that
	will tell you, "nah, its not a problem", because they have
	the latest and great router [or whatever], but there are
	plenty of folks feeling the pain. If you dispute that,
	search, say, [email-masked] (or just the archives of the
	last meeting). Convolve with the pressure the RIR system 
	is feeling (for example; there many factors here) and one
	can see storm clouds on the (near) horizion. 

	So what we are facing is not as unidimensional as being
	able to build a bigger router. We have plenty of
	existence proofs that we can do that. 
 
> very very close to what Lixia was already proposing. Till now even looking 
> ten years ahead no one can show the significant proof that "routing is 
> about to collapse".

	Well, "about to collapse" probably isn't the way to frame
	it up. Its a complex problem, involving physics
	(dynamical systems), technology (what we are ostensibly
	working on here), economics, public policy (and
	associated regulatory environment), market dynamics,
	etc. I've done a bit of work on what the convolution of
	these various factors might mean, but this is still very
	much more an art than a science. See e.g.,  
	http://www.1-4-5.net/~dmm/talks/NANOG41/perfect_storm.pdf
	for some thinking along these lines.
	
> today carrying ten fold number of routes what today's internet carry for 

	We all know that we vendors say that. We can always build
	something bigger; that is simply not the point. IMO we
	can dispense with this. Its kind of a red herring (I do
	seem to recall someone saying "with enough thrust..." and
	yeah, I know it was Milo). So again, that one can build a
	bigger router is not the point.

	And BTW, as you know, precise models of how the routing
	system works (as a dynamical system) are not available,
	and while although we've done significant reverse
	engineering, to some exent we're all guessing about the
	properties of the system. But 

	we can say a few simple things, such as (i). the DFZ is
	growing, (ii). as the DFZ grows, more of the dynamics of
	the network are exposed in the core (simple computability
	arguments here), and (iii). the widespread deployment of
	IPv6 is a wildcard (O(2^32) >> O(2^128)). 

> much supporting this as individual. I am just trying to make sure we focus 
> on the correct problem not the imaginary/non-existent ones :).

	That seems only prudent, and I'm sure everyone feels the
	same way.

	Dave

---

From: "Greg Shepherd" <[email-masked]>
Date: Thu, 6 Dec 2007 09:50:05 -0800

Robert,

Just another thought..

Yes, we vendors can continue to make larger routers. I wonder if there
is a tangible power savings by a new routing architecture over just
building and deploying bigger routers.

Greg

---

From: David Meyer <[email-masked]>
Date: Thu, 6 Dec 2007 09:52:33 -0800

Greg,

> building and deploying bigger routers.

	Good point. Power (and associated HVAC) is part of
	the "physics" I was alluding to.

	Dave

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 06 Dec 2007 09:59:38 -0800

Greg,

But I don't see any difference in power consumption when prefixes are 
carried in new fancy mapping scheme, when routers get some routes with 
on demand caching  or if they are carried in a new instance of BGP.

Intra-domain the problem is solved today. Core P routers do not need to 
keep any routes other then routes to next hops when any form of 
tunneling is used. And this is deployed today in many networks. 
Inter-domain can be addressed in very same way.

Cheers,
R.

---

From: David Meyer <[email-masked]>
Date: Thu, 6 Dec 2007 10:02:30 -0800

> 	IPv6 is a wildcard (O(2^32) >> O(2^128)). 

	Oophs, make that O(2^32) << O(2^128), but I'm sure you
	take my point.

	Dave

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 6 Dec 2007 10:21:37 -0800

> building and deploying bigger routers.

Evidence to date is that the answer to this question is "no", at least  
for any variant which continues to rely on something resembling  
current IP forwarding (which would include all of the major proposals  
currently being discussed in RRG, AFAICT).

--John