Subject: Designated Component Link

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 28 Jan 2011 08:27:29 +0530

Hi,

Due to the nature of composite links there is a high chance that the forward and reverse traffic takes up different component links resulting in perceptible difference in the transit times. This may not be acceptable for protocols like 1588, NTP, etc that would like a symmetrical forward/reverse path for an accurate delay measurement. Can we introduce a concept of a designated component link which applications/protocols that are sensitive to symmetry can take when transiting a composite link?

Cheers, Manav

--
Manav Bhatia,
IP Division, Alcatel-Lucent,
Bangalore - India

---

From: Tony Li <[email-masked]>
Date: Thu, 27 Jan 2011 19:04:31 -0800

> Due to the nature of composite links there is a high chance that the forward and reverse traffic takes up different component links resulting in perceptible difference in the transit times. This ma…

The larger problem is that of full blown path asymmetry, which is being addressed by requirements for bidirectional LSPs.

A reasonable addition to our requirements might be that a composite link bind both directions of a bidirectional LSP to a single component.

Tony

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 28 Jan 2011 09:04:32 +0530

> A reasonable addition to our requirements might be that a 
> composite link bind both directions of a bidirectional LSP to 
> a single component.

Yes, this is precisely what I am looking at.

A designated component link is useful in adding some determinism when picking up components from a composite link. We could have an RSVP object that forces implementations to use the primary or the designated component link. This way we can also achieve this symmetry using unidirectional LSPs.

Thinking aloud - Wouldn't this also be useful for OAM? To test the liveliness of the composite link we would just need to test the liviness of the designated/primary component link.

Cheers, Manav

---

From: Tony Li <[email-masked]>
Date: Thu, 27 Jan 2011 23:21:29 -0800

> A designated component link is useful in adding some determinism when picking up components from a composite link. We could have an RSVP object that forces implementations to use the primary or the…

This is already a likely consequence of any solution that wishes to provide MPLS/TE support across composite links.  If the LSP path has component specific requirements, then the ERO computed by the head end could specify the component link.

You can achieve symmetry by either inverting the ERO, or, perhaps using the mechanisms already specified in GMPLS for an UPSTREAM LABEL, effectively creating the bidirectional LSP.

> Thinking aloud - Wouldn't this also be useful for OAM? To test the liveliness of the composite link we would just need to test the liviness of the designated/primary component link.

I'm not sure I understand what you consider to be 'primary'.  OAM already has the capabilities to test the liveness of any LSP, and a logical extension is to require the use of BFD for component liveness.

Tony

---

From: "Mcdysan, David E" <[email-masked]>
Date: Fri, 28 Jan 2011 09:47:29 -0500

Hi,

Proposed wording of an additional requirement for your review and comment:

The solution MUST support a means for LSP signaling to indicate to a
composite link that both directions of a bidirectional LSP must be bound
to a single component link. In the absence of such a signaling indication,
the different directions of a bidirectional LSP need only be bound to a
component link that is part of the composite link.

Dave

On 1/27/11 10:04 PM, "Tony Li" <[email-masked]> wrote:

>> Due to the nature of composite links there is a high chance that the
>>forward and reverse traffic takes up different component links resulting
>>in perceptible difference in the transit times. This may not be
>>acceptable for protocols like 1588, NTP, etc that would like a
>>symmetrical forward/reverse path for an accurate delay measurement. Can
>>we introduce a concept of a designated component link which
>>applications/protocols that are sensitive to symmetry can take when
>>transiting a composite link?
>
>
>The larger problem is that of full blown path asymmetry, which is being
>addressed by requirements for bidirectional LSPs.
>
>A reasonable addition to our requirements might be that a composite link
>bind both directions of a bidirectional LSP to a single component.
>
>Tony
>
>_______________________________________________
>rtgwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 28 Jan 2011 21:09:16 +0530

Yup, this should be good.

Cheers, Manav

> -----Original Message-----
> From: Mcdysan, David E [mailto:[email-masked]] 
> Sent: Friday, January 28, 2011 8.17 PM
> To: Tony Li; Bhatia, Manav (Manav)
> Cc: [email-masked]
> Subject: Re: Designated Component Link
> 
> Hi,
> 
> composite link

---

From: Tony Li <[email-masked]>
Date: Fri, 28 Jan 2011 10:32:59 -0800

Hi Dave,

> component link that is part of the composite link.

We want this to signaling option to apply to unidirectional LSPs as well, yes?  If so, we might wordsmith it this way:

The solution MUST support an optional means for LSP signaling to bind an LSP to a particular component link within a composite link.  If this option is applied to a bidirectional LSP, both directions of the LSP are bound to the component.  If this option is not exercised, then an LSP that is bound to a composite link may be bound to any component link matching all other signaled requirements, and different directions of a bidirectional LSP can be bound to different component links.

Tony