Subject: Re: Requesting adoption as WG draft

From: Alia Atlas <[email-masked]>
Date: Wed, 6 Jul 2011 17:30:09 -0400

Ning,

I have read draft-so-yong-rtgwg-cl-framework-04 and was happy to see
that there is more content about what is available in existing
protocols and what is not.  I do think this is an improvement.

I would still prefer to see discussion of the trade-offs between
different approaches in the framework draft.  An example is around
what is advertised for heterogeneous component links and the impact of
crankback versus additional data to advertise.   Tony Li gave a nice
discussion of this a couple IETFs ago and the pros/cons would be good
to capture.

I understand that the protocol extensions are not yet defined; I tend
to think of "for future study" as placing work out of scope rather
than implying that it will be coming in companion solution documents.
What would be useful is to provide criteria by which different
solutions could be judged.  I still don't see any such discussion in
the draft.

Alia

On Tue, Jun 21, 2011 at 2:10 PM, Alia Atlas <[email-masked]> wrote:
> I will read carefully the new version in the next week.
> Any acceptance as a WG draft would be after querying the list, of course.
>
> That said, please read this updated draft and comment here.  It would be good
> to get this done and a decision made before the next IETF.
>
> Alia
>
>
> On Tue, Jun 21, 2011 at 1:28 PM, So, Ning <[email-masked]> wrote:
>> Dear WG chairs,
>>
>>
>>
>> Have you had a chance to look at the updated Composite Link Framework draft
>> (draft-so-yong-rtgwg-cl-framework-04)?  Alia made the comment in last IETF
>> meeting that this draft is likely to be adopted as WG draft, because the
>> Composite Link Requirement has already passed WG last call.  Just want to
>> check and see when will you have some time to make the announcement.
>>   Thanks a lot.
>>
>>
>>
>>
>>
>> Best regards,
>>
>>
>>
>> Ning So
>>
>> Network Evolution Planning
>>
>> Verizon, Inc.
>>
>> (office) 972-729-7905
>>
>> (Cell) 972-955-0914
>>
>>
>>
>> _______________________________________________
>> rtgwg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/rtgwg
>>
>>
>

---

From: "So, Ning" <[email-masked]>
Date: Wed, 06 Jul 2011 23:07:12 +0000

Alia,

First of all, I support this draft to become WG draft (as co-author).  

The current draft kept the framework flexible, so different local implementation can be done without violating the draft.  As for the advantages and trade-offs of how to advertise component links, we have had some lengthy discussions on e-mails before between Tony, Curtis, Dave, Lucy, and myself.   I recall we come to a conclusion that either way (summary vs. detailed) would work, and we might want to leave that as a tunable nob for the operator to control.  I would welcome more discussion if anything new comes up, but I do not recall any other disagreement in previous discussions.

As for the detailed protocol gap analysis, we mentioned a few in the draft, but I don't think they will impact the framework itself.  We can further strengthen  that section, or on an equally valid note, we can also leave that to the solution draft.  I would like to hear other people's preference on that.

Best regards,
 
Ning So

-----Original Message-----
From: Alia Atlas [mailto:[email-masked]] 
Sent: Wednesday, July 06, 2011 4:30 PM
To: So, Ning
Cc: [email-masked]
Subject: Re: Requesting adoption as WG draft

Ning,

I have read draft-so-yong-rtgwg-cl-framework-04 and was happy to see that there is more content about what is available in existing protocols and what is not.  I do think this is an improvement.

I would still prefer to see discussion of the trade-offs between different approaches in the framework draft.  An example is around what is advertised for heterogeneous component links and the impact of
crankback versus additional data to advertise.   Tony Li gave a nice
discussion of this a couple IETFs ago and the pros/cons would be good to capture.

I understand that the protocol extensions are not yet defined; I tend to think of "for future study" as placing work out of scope rather than implying that it will be coming in companion solution documents.
What would be useful is to provide criteria by which different solutions could be judged.  I still don't see any such discussion in the draft.

Alia

On Tue, Jun 21, 2011 at 2:10 PM, Alia Atlas <[email-masked]> wrote:
> That said, please read this updated draft and comment here.  It would 
> be good to get this done and a decision made before the next IETF.
>
> Alia
>
>
>> Have you had a chance to look at the updated Composite Link Framework 
>> draft (draft-so-yong-rtgwg-cl-framework-04)?  Alia made the comment 
>> in last IETF meeting that this draft is likely to be adopted as WG 
>> draft, because the Composite Link Requirement has already passed WG 
>> last call.  Just want to check and see when will you have some time to make the announcement.
>>   Thanks a lot.
>>
>>
>>
>>
>>
>> Best regards,
>>
>>
>>
>> Ning So
>>

---

From: Lucy yong <[email-masked]>
Date: Thu, 07 Jul 2011 19:22:59 +0000

Hi Alia,

I support the draft to become WG draft as co-author.

If you think that "for futhre study" cause a confusion here, we can change to "will be addressed in other drafts". 

In the requirment draft, Apeendix A and B already describes today's practics and protocol usage for mutliple paths; it gives some new requirements on the compositel ink. IMHO, we don't need to respin it in this draft.

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, July 06, 2011 4:30 PM
To: So, Ning
Cc: [email-masked]
Subject: Re: Requesting adoption as WG draft

Ning,

Alia

---

From: Russ White <[email-masked]>
Date: Thu, 07 Jul 2011 18:13:54 -0400

> protocols and what is not.  I do think this is an improvement.

I do, as well...

I support adopting this as a WG draft.

Russ

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 07 Jul 2011 19:54:58 -0400

Lucy,

I think the point is that a framework document is supposed to provide
a description of what exists and provide a description of the approach
that will be taken to extend protocols to accomplish the requirements
that are not met.

After the framework document is completed we should have a clear
picture of what protocol extensions are going to be needed.  We are
not there yet.

That said, I still owe you contributed text in that area but have been
busy.  My time should be freed up quite a bit after this next IETF.  I
will try to get rough text together that we can discuss at the IETF at
least among authors.

Curtis

In message <[email-masked]>
Lucy yong writes:

Hi Alia,

Regards,
Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Wednesday, July 06, 2011 4:30 PM
To: So, Ning
Cc: [email-masked]
Subject: Re: Requesting adoption as WG draft

Ning,

Alia

---

From: Lucy yong <[email-masked]>
Date: Fri, 08 Jul 2011 15:45:55 +0000

Curtis,

The draft has pointed out where routing and signaling protocol extensions are needed. The detail protocol design should be in separated drafts and WG can work on them together. This is my understanding how IETF works.

As one of co-authors, you are certainly in help to make it clearer. Since the requirement draft is already in IESG processing, we like to move forward this work faster.

IETF81 and MEFQ3 meetings are the same week (can't believe it). I am unable to be in Quebec for the meeting. Please gather other co-authors for the discussion. 

Regards,
Lucy
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, July 07, 2011 6:55 PM
> To: Lucy yong
> Cc: Alia Atlas; So, Ning; [email-masked]
> In the requirment draft, Apeendix A and B already describes today's
> practics and protocol usage for mutliple paths; it gives some new
> requirements on the compositel ink. IMHO, we don't need to respin it in
> this draft.
> 
> Regards,
> Lucy
> 
> I have read draft-so-yong-rtgwg-cl-framework-04 and was happy to see that
> there is more content about what is available in existing protocols and
> what is not.  I do think this is an improvement.
> 
> I would still prefer to see discussion of the trade-offs between different
> approaches in the framework draft.  An example is around what is
> advertised for heterogeneous component links and the impact of
> I understand that the protocol extensions are not yet defined; I tend to
> think of "for future study" as placing work out of scope rather than
> implying that it will be coming in companion solution documents.
> What would be useful is to provide criteria by which different solutions
> could be judged.  I still don't see any such discussion in the draft.
> 
> Alia
> 
> > That said, please read this updated draft and comment here. 營t would
> >> draft (draft-so-yong-rtgwg-cl-framework-04)??Alia made the comment
> >> last call.?Just want to check and see when will you have some time to
> make the announcement.
> >> 牋Thanks a lot.
> >>
> >>
> >>
> >>
> >>
> >> Best regards,
> >>
> >>
> >>
> >> Ning So
> >>