Subject: poll on draft-karan-mofrr-02 to become a WG draft

From: Alia Atlas <[email-masked]>
Date: Tue, 12 Jun 2012 16:41:43 -0400

This email is to start a poll and discussion on whether
draft-karan-mofrr-02 should
become an RTGWG draft.   Please include comments, details, and whether you have
read the draft.

The earlier version was presented positively to the PIM WG as well.

Authors, please indicate whether there is any IPR associated with this draft.

Thanks,
Alia

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 12 Jun 2012 23:33:00 +0200

Hi Alia,

> become an RTGWG draft.   Please include comments, details, and whether you have

I support this draft to become a WG document.

> Authors, please indicate whether there is any IPR associated with this draft.

Yes, there is IPR. I contact the Cisco legal department and requested to issue an IPR statement.

Thx,

Ice.

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 12 Jun 2012 19:02:37 -0400

Hi Alia,

Yes/support, having product implementation since 2009.
There's an IPR associated with the draft:
(https://datatracker.ietf.org/ipr/search/?option=document_search&document_search=draft-karan-mofrr)

Regards,
Jeff

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Tuesday, June 12, 2012 1:42 PM
To: [email-masked]; [email-masked]
Subject: poll on draft-karan-mofrr-02 to become a WG draft

Thanks,
Alia
_______________________________________________
rtgwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: András Császár <[email-masked]>
Date: Wed, 13 Jun 2012 11:22:44 +0200

Hi Alia,

MoFRR to me is a kind of applying the LFA idea to multicast, and also given that implementations already exist (for quite some time now, if I'm correct), I do support it.

Trying to be constructive again, I would give some feedback for this one, too :-)

1. I suggest a little more glue between the text in chapter 7 (non-ECMP mode MoFRR) and the LFA spec. Non-ECMP mode seems very much like the LFA rules, yet they are redefined, which is not a problem, but I'd prefer having a similar notation/syntax/terminology and rules as far as possible. If there are differences, they should be highlighted.

2. Chapter 5, detecting failures. I think we should try to give a little more details. Packet comparison details, what needs to be stored? Complete packet? Packet hash? RTP seq number? ...

I think the "third option", to rely on IGPs is by definition not FRR, so this should be the last option.

The fourth option is "leveraging connected link failure". I think this option could be the easiest/most natural approach, and I guess since LoS, BFD and any local DP failure detection mechanism is usually tied already to unicast FRR, why not propose this to be the primary option for MoFRR, too? 

3. Chapter 10: "The MoFRR principle may be applied to MVPNs." Let's give more details, if possible.

4. Due to mLDP, probably the MPLS WG chairs should be involved, too, not only PIM.

5. Why is the intended status "informational"? Why should it be different from LFA or remote LFA? I agree the solution practically does not require any novel cooperation method from other nodes, which is an advantage, so there is little to be a "Standard", but that's true for LFA or RLFA as well. So?

6. We often used the terminology "live-live" in other drafts, such as in MRT. I actually thought that it came from MoFRR, but now I did find no trace of it in the doc. Maybe we should add a sentence about it, saying that MoFRR implements what is often called "live-live" protection.

I started to realise I'm often too long, sorry for that :-)

András

> Sent: 2012. június 12. 22:42

---

From: <[email-masked]>
Date: Mon, 25 Jun 2012 15:37:57 +0200

Support!

 Regards

    Nic

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Alia Atlas
Gesendet: Dienstag, 12. Juni 2012 22:42
An: [email-masked]; [email-masked]
Betreff: poll on draft-karan-mofrr-02 to become a WG draft

Thanks,
Alia

---

From: IJsbrand Wijnands <[email-masked]>
Date: Mon, 25 Jun 2012 15:40:05 +0200

Hi Andras,

> I started to realise I'm often too long, sorry for that :-)

For this time we'll see it through the fingers (Dutch joke) :-)

So in short, you're supporting the draft but some updates need to be made, right?

Thx!

Ice.

---

From: Greg Shepherd <[email-masked]>
Date: Mon, 25 Jun 2012 07:18:42 -0700

I'm in support of this draft becoming a WG item.

Greg

---

From: <[email-masked]>
Date: Mon, 25 Jun 2012 14:27:26 +0000

Hi Alia,

>From: Alia Atlas
>Sent: Tuesday, June 12, 2012 10:42 PM
>

I've read this draft and support it to become a WG document.

>Authors, please indicate whether there is any IPR associated with this draft.

I'm not aware of any IPR on my side.
(For the sake of exhaustively, I'm aware of the IPR already disclosed in the datatracker: https://datatracker.ietf.org/ipr/search/?option=document_search&document_search=draft-karan-mofrr )

Thanks,
Bruno

>Alia

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: András Császár <[email-masked]>
Date: Fri, 29 Jun 2012 13:31:48 +0200

Yes, absolutely.
András

> From: IJsbrand Wijnands [mailto:[email-masked]]
> Sent: 2012. június 25. 15:40
> To: András Császár
> Cc: Alia Atlas; [email-masked]; [email-masked]
> Subject: Re: poll on draft-karan-mofrr-02 to become a WG draft
> 
> Hi Andras,
> 
> >> become an RTGWG draft.   Please include comments, details, and
> whether
> >> you have
> >> read the draft.
> >>