Subject: IPR Disclosure: Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR related to draft-ietf-rtgwg-mrt-frr-architecture-01

From: IETF Secretariat <[email-masked]>
Date: Mon, 18 Jun 2012 08:50:48 -0700

Dear Gabor Sandor Envedi, Alia Atlas, Robert Kebler, Andras Csaszar, Russ White, Mike Shand, Maciek Konstantynowicz:

 An IPR disclosure that pertains to your Internet-Draft entitled "An
Architecture for IP/LDP Fast-Reroute Using Maximally Redundant Trees" (draft-
ietf-rtgwg-mrt-frr-architecture) was submitted to the IETF Secretariat on
2012-06-18 and has been posted on the "IETF Page of Intellectual Property Rights
Disclosures" (https://datatracker.ietf.org/ipr/1801/). The title of the IPR
disclosure is "Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR
related to draft-ietf-rtgwg-mrt-frr-architecture-01."");

The IETF Secretariat

---

From: András Császár <[email-masked]>
Date: Tue, 19 Jun 2012 12:21:56 +0200

Dear All,
FYI, we had an IPR statement already a year ago for the individual draft, but after WG adoption and renaming, the IPR disclosure was not transferred by the IETF systems onto the WG adopted draft, that's why it had to be done again, i.e. it is the same as before.

András

-----Original Message-----
From: IETF Secretariat [mailto:[email-masked]] 
Sent: 2012. június 18. 17:51
To: Gábor Sándor Enyedi; [email-masked]; [email-masked]; András Császár; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: IPR Disclosure: Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR related to draft-ietf-rtgwg-mrt-frr-architecture-01

 An IPR disclosure that pertains to your Internet-Draft entitled "An Architecture for IP/LDP Fast-Reroute Using Maximally Redundant Trees" (draft-
ietf-rtgwg-mrt-frr-architecture) was submitted to the IETF Secretariat on
2012-06-18 and has been posted on the "IETF Page of Intellectual Property Rights Disclosures" (https://datatracker.ietf.org/ipr/1801/). The title of the IPR disclosure is "Telefonaktiebolaget LM Ericsson (publ)'s Statement about IPR related to draft-ietf-rtgwg-mrt-frr-architecture-01."");

The IETF Secretariat

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 20 Jun 2012 11:52:54 -0400

In message <[email-masked]>
IETF Secretariat writes:
 
>  
> Dear Gabor Sandor Envedi, Alia Atlas, Robert Kebler, Andras Csaszar,
> Russ White, Mike Shand, Maciek Konstantynowicz:
>  
> Architecture for IP/LDP Fast-Reroute Using Maximally Redundant Trees"
> (draft- ietf-rtgwg-mrt-frr-architecture) was submitted to the IETF
> Secretariat on 2012-06-18 and has been posted on the "IETF Page of
> Intellectual Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/1801/). The title of the IPR
> disclosure is "Telefonaktiebolaget LM Ericsson (publ)'s Statement
> about IPR related to draft-ietf-rtgwg-mrt-frr-architecture-01."");
>  
> The IETF Secretariat

Prior reasons to be hesitant about this work included the rather
substantial change to routing and forwarding, and the need to deploy
network wide (no accommodation for legacy equipment).  Regardless, it
became a WG item.

Now that there is an IPR disclosure with no statement at all regarding
licensing terms, it might be time to reconsider whether the WG should
go forward with this work.

IMHO- If the IPR disclosure is not updated with a reasonable and
non-discriminatory, preferably royalty-free, licensing statement, the
MRT work should be abandoned by RTGWG.

Curtis

---

From: "Retana, Alvaro" <[email-masked]>
Date: Wed, 20 Jun 2012 16:44:11 +0000

As a reminder, having an IPR claim does not disqualify a draft from advancing in the IETF, being adopted by a working group or from eventually becoming a standard.  It just represents one more item to be considered by the working group.    

http://www.ietf.org/ipr/policy.html

To help in the evaluation, the following link is to the patent application itself (provided by the authors):

http://www.wipo.int/patentscope/search/en/detail.jsf?docId=WO2010055408&recNum=1&docAn=IB2009007467&queryString=FP:%28PCT/IB2009/007467%29&maxRec=1

As a chair, my job is to remind the WG of the IETF policy -- the decision of whether we should continue to work on this item is to be made by the individuals participating in the WG.  Because the concern expressed by Curtis has come up several times (from different people), including at the meeting in Taipei, I would like to hear other opinions specific to the impact of the terms of the IPR filing with respect to the architecture proposed.

Thanks!

Alvaro.

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Curtis Villamizar
> Sent: Wednesday, June 20, 2012 11:53 AM
> To: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: IPR Disclosure: Telefonaktiebolaget LM Ericsson (publ)'s
> Statement about IPR related to draft-ietf-rtgwg-mrt-frr-architecture-01
> 
> 
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 20 Jun 2012 15:02:23 -0400

Alvaro,

Please remind me.  Has there been any discussion as to whether the XRO
(exclude route object) in RSVP-TE (RFC 4874) would qualify as prior
art, since the XRO specifies a "system and method of implementing a
lightweight not-via fast reroute in a telecommunications network"?
The patent seems to be a method patent and not a use patent.  It
appears to me that the only major difference between the XRO and the
Ericson patent (which may affect not-via and use of redundant trees of
which maximally redundant would be a subset), is that XRO is applied
to RSVP-TE and was intended to aid in multi-domain use of RSVP-TE and
the Ericson patent uses a functionally identical approach (indicate
which resources to avoid) applied to IP rather than RSVP-TE.

The XRO was introduced in draft-ietf-ccamp-rsvp-te-exclude-route-00 in
June 2003 which became an RFC in 2007.  The patent was submitted in
2006, three years after XRO publication (not counting individual
submissions prior to the first WG draft).  If this counts as prior
art, the patent is invalid.

I'm not sure how this could affect MRT but not affect the notvia work
(no IPR disclosure from Ericson on that).  The
draft-bryant-shand-ipfrr-notvia-addresses-00 individual submission was
published in March 2005.  This also precedes the patent.

The only reason I can see that notvia and XRO might be considered
different is that they don't specify a redundant tree.

Another question for legal types is whether computing redundant trees
is an algorithm (specifically a graph theory algorithm) and therefore
not patentable at all.  Should a patent of this type specify the use
of a redundant tree algorithm in IP or LDP?  Can a patent apply to the
use of *any* algorithm which falls within the classification of a
redundant tree algorithm in IP or LDP?

Of course, I am not an attorney so I cannot give a legal opinion on
this matter or any other legal matter.  I am asking if there has ever
been such a discussion and whether my layperson legally uniformed
opinion might by chance be accurate or close to accurate.

If the patent is valid, does apply to the MRT work, and has no
licensing specified, IMHO the WG should cease to work on this.

Curtis

In message <[email-masked]>
"Retana, Alvaro" writes:

Thanks!

Alvaro.

---

From: "Retana, Alvaro" <[email-masked]>
Date: Wed, 20 Jun 2012 19:51:45 +0000

Curtis:

No, if that discussion has happened, it didn't take place in the rtgwg list.

Quoting from rfc3979 (IP in IETF Technology):

   "... Although the IETF can
   make no actual determination of validity, enforceability or
   applicability of any particular IPR claim, it is reasonable that a
   working group will take into account on their own opinions of the
   validity, enforceability or applicability of Intellectual Property
   Rights in their evaluation..."

I am not a lawyer either, but it is clear to me that any discussion we (IETF/rtgwg) could have would obviously be non-binding.  It is not in our domain to determine what is or not prior art.

Having said that, I would imagine (as a member of the WG) that the authors have a clear picture of what is prior art and why some technologies may not be.  Again, not something for us to evaluate...but information that may be useful in forming individual opinions.

Alvaro.

> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Wednesday, June 20, 2012 3:02 PM
> To: Retana, Alvaro
> Cc: [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; White, Russell;
> [email-masked]
> In message
> <[email-masked]>
> "Retana, Alvaro" writes:
> 
> As a reminder, having an IPR claim does not disqualify a draft from
> advancing in the IETF, being adopted by a working group or from
> eventually becoming a standard.  It just represents one more item to be
> considered by the working group.
> 
> To help in the evaluation, the following link is to the patent
> application itself (provided by the authors):
> 
> http://www.wipo.int/patentscope/search/en/detail.jsf?docId=WO2010055408
> &recNum=1&docAn=IB2009007467&queryString=FP:%28PCT/IB2009/007467%29&max
> Rec=1
> 
> 
> As a chair, my job is to remind the WG of the IETF policy -- the
> decision of whether we should continue to work on this item is to be
> made by the individuals participating in the WG.  Because the concern
> expressed by Curtis has come up several times (from different people),
> including at the meeting in Taipei, I would like to hear other opinions
> specific to the impact of the terms of the IPR filing with respect to
> the architecture proposed.
> 
> Thanks!
> 
> Alvaro.
> 
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 21 Jun 2012 10:50:57 -0400

Curtis,

First, this is EXACTLY the same IPR claim that was attached to the
original draft before it became a WG draft.  While I, personally, am
not thrilled with the terms, the WG made a decision to accept the
draft at the time regardless of those terms.

Second, the MRT solution has changed somewhat from the original draft
- including the ability to pre-select the alternate.

Third, MRT is NOT a solution that has to be deployed across the entire
network to be useful.  Nor does it change normal forwarding and
routing.  For the LDP case, it simply provides additional forwarding
paths using existing MPLS mechanisms.  Naturally, it computes those
forwarding paths with a algorithm other than basic SPF to obtain the
desired results.

I would certainly welcome your thoughtful comments on the drafts and
would encourage you to read the more recent version.

Alia  (wg-chair hat off)