Subject: a MRT algorithm

From: Yasuhiro Ohara <[email-masked]>
Date: Wed, 23 Jul 2014 16:33:25 -0400 (EDT)

Hi,

Regarding Maximally Redundant Trees algorithms, please take a look
at my IEEE INFOCOM paper in 2009, which is titled "MARA: Maximum
Alternative Routing Algorithm".

It is a extended version of Dijkstra, and we've succeeded to extend the
Dijkstra's shortest path tree. This means that the calculated DAG is
compatible to the current SPF Tree, so you might not need multi-topology
in the first place.

http://ieeexplore.ieee.org/xpl/articleDetails.jsp?tp=&arnumber=5061933&searchWithin%3Dp_Authors%3A.QT.Ohara%2C+Y..QT.%26searchWithin%3Dp_Author_Ids%3A37302386400

http://web.sfc.keio.ac.jp/~rdv/publications/ohara-mara-infocom09.pdf

regards,
Yasu

---

From: Alia Atlas <[email-masked]>
Date: Wed, 23 Jul 2014 20:45:36 +0000

Thanks for the pointer.

Alia

-----Original Message-----
From: Yasuhiro Ohara [mailto:[email-masked]] 
Sent: Wednesday, July 23, 2014 4:33 PM
To: [email-masked]; Alia Atlas; [email-masked]
Cc: [email-masked]
Subject: a MRT algorithm

Hi,

Regarding Maximally Redundant Trees algorithms, please take a look at my IEEE INFOCOM paper in 2009, which is titled "MARA: Maximum Alternative Routing Algorithm".

It is a extended version of Dijkstra, and we've succeeded to extend the Dijkstra's shortest path tree. This means that the calculated DAG is compatible to the current SPF Tree, so you might not need multi-topology in the first place.

regards,
Yasu