Subject: rtgwg Rechartering

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 22 Sep 2014 19:28:01 +0000

Hi!

I hope many/most of you followed the 'RTG Area Tuning' discussions over the last couple of months..and in the rtgarea meeting in Toronto.  As part of the tuning it was proposed to clarify rtgwg's charter to better explain our mission of developing work proposals that do "not yet rise to the level where a new working group is justified, yet the topic does not fit with an existing working group,
and it is either not ready for a BOF or a single BOF would not provide the time to ensure a mature proposal" (from the current charter).

To that end we have written up a new charter with the help of the ADs.  Please take a look:  http://datatracker.ietf.org/doc/charter-ietf-rtgwg/

As you read the proposed new charter, you should notice that there are 3 components to what the WG will be doing:

  1.  Larger topics on demand, such as the current FRR work.  No change.
  2.  Small topics (that don't fit in other WGs).  "An example of a small topic is a draft that might otherwise be AD-sponsored but which could benefit from the review and consensus that RTGWG can provide."  We have already put forth for WG consideration a couple of these (draft-ietf-rtgwg-bgp-routing-large-dc is an example).
  3.  Be an "optional venue to discuss, evaluate, support and develop proposals for new work in the Routing Area".  I don't think this type of work is new to rtgwg: you may recall the energy efficiency work we discussed a few meetings ago.  But we do spend more time discussing this item on the charter.

Please send comments/question/concerns/suggestions in reply to this e-mail.

Thanks!

Alvaro.

---

From: Lucy yong <[email-masked]>
Date: Mon, 22 Sep 2014 21:37:18 +0000

One clarification:

The WG have different treatments on small and large topics. The latter one requires explicitly recharter to add the topic. How to judge if a topic is small or large?  My guess: ADs and/or WG chair's call?

Thanks,
Lucy

From: rtgwg [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: Monday, September 22, 2014 2:28 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: rtgwg Rechartering

Hi!

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Mon, 22 Sep 2014 21:44:09 +0000

On 9/22/14 5:37 PM, "Lucy yong" <[email-masked]<mailto:[email-masked]>> wrote:

Lucy:

The WG have different treatments on small and large topics. The latter one requires explicitly recharter to add the topic. How to judge if a topic is small or large?  My guess: ADs and/or WG chair’s call?

Right..the Chairs or ADs will provide guidance.

A simple way (for me) to look at it is that "large" topics require rechartering, which probably implies that there may be more than one deliverable/milestone/document..while small topics will probably be contained within a single document (like the example of an AD-sponsored draft).

Thanks!

Alvaro.

---

From: <[email-masked]>
Date: Tue, 23 Sep 2014 08:27:51 +0000

Hi,

Please find below 2 feedbacks:

1)      Small topics
"and may work on specific small topics that do not fit with an existing working group."

"RTGWG may also work on specific small topics that do not fit with an existing working group."

What about work which is general to Link State Protocols i.e. not specific to IS-IS and OSPF protocols. Should it be done once in RTGWG or twice in both IS-IS & OSPF WGs?
e.g. draft-litkowski-rtgwg-spf-uloop-pb-statement<http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-1.pdf> , draft-decraene-rtgwg-backoff-algo<http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-2.pdf>

2)      BoF/new WG

"Options for handling new work include:

- Developing a proposal for a BoF.

- Developing a charter and establishing consensus for a new WG"

It seems to me that so far the above work was currently performed in Routing Area plenary meetings.
Do we want to move this to RTGWG? If so
- I'm a bit concerned that such activities are less technically oriented, possibly political and involving many discussions and hence could delay the technical work in RTGWG.
- What's the remaining use of the Routing Area plenary meeting? A top down summary of latest WG status?

Thanks,
Regards,
Bruno

From: rtgwg [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: Monday, September 22, 2014 9:28 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: rtgwg Rechartering

Hi!

Thanks!

Alvaro.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 23 Sep 2014 11:04:58 +0100

On 23/09/2014 09:27, [email-masked] wrote:
> 1)Small topics
> What about work which is general to Link State Protocols i.e. not 
> specific to IS-IS and OSPF protocols. Should it be done once in RTGWG 
> or twice in both IS-IS & OSPF WGs?
>
> e.g. draft-litkowski-rtgwg-spf-uloop-pb-statement 
> <http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-1.pdf> , 
> draft-decraene-rtgwg-backoff-algo 
> <http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-2.pdf>
>
Bruno,

I don't think either of these as being a problem.

For RTGWG to take on new work it needs to be noted in the charter and 
that in turn needs to be approved by the IESG. Minor, non-controversial, 
items are nodded through so there is no drama there. However part of the 
discussion with the AD would surely be whether the work belonged in 
RTGWG, or some other WG, and thus matter such as you are concerned about 
would normally be handled on a case by case basis.

I therefore would be reluctant to see anything in the charter on this 
(the concept not the specific drafts) because every case is different.
> 2)BoF/new WG
> - I'm a bit concerned that such activities are less technically 
> oriented, possibly political and involving many discussions and hence 
> could delay the technical work in RTGWG.
>
I am sure the ADs will change the time allocated to the Open meeting on 
a case by case basis, and of course cross area work is often discussed 
there.

The goal as here is to use RTGWG to fulfill the role of the RIA area 
DISPATCH WG, and have a lightweight and speedy way of introducing new 
work into the IETF Routing Area, something that I am sure will be needed 
as we ride through the various transitions taking place in our industry.

I am sure the RTGWG chairs will request additional meeting time and 
partition the agenda if there is a need to ensure that a controversial 
new work item does not impinge on existing technical work.

- Stewart

> Thanks,
>
> Regards,
>
> Bruno
>
> *From:*rtgwg [mailto:[email-masked]] *On Behalf Of *Alvaro 
> Retana (aretana)
> *Sent:* Monday, September 22, 2014 9:28 PM
> *To:* [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* rtgwg Rechartering
>
> Hi!
>
> I hope many/most of you followed the 'RTG Area Tuning' discussions 
> over the last couple of months..and in the rtgarea meeting in Toronto. 
>  As part of the tuning it was proposed to clarify rtgwg's charter to 
> better explain our mission of developing work proposals that do "not 
> yet rise to the level where a new working group is justified, yet the 
> topic does not fit with an existing working group,
>
> and it is either not ready for a BOF or a single BOF would not provide 
> the time to ensure a mature proposal" (from the current charter).
>
> To that end we have written up a new charter with the help of the ADs. 
>  Please take a look: http://datatracker.ietf.org/doc/charter-ietf-rtgwg/
>
> As you read the proposed new charter, you should notice that there are 
> 3 components to what the WG will be doing:
>
>  2. Small topics (that don't fit in other WGs).  "An example of a
>     small topic is a draft that might otherwise be AD-sponsored but
>     which could benefit from the review and consensus that RTGWG can
>     provide."  We have already put forth for WG consideration a couple
>     of these (draft-ietf-rtgwg-bgp-routing-large-dc is an example).
>  3. Be an "optional venue to discuss, evaluate, support and develop
>     proposals for new work in the Routing Area".  I don't think this
>     type of work is new to rtgwg: you may recall the energy efficiency
>     work we discussed a few meetings ago.  But we do spend more
>     time discussing this item on the charter.
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 23 Sep 2014 10:52:48 +0000

Hi Bruno,

Please see inline

Cheers,
Jeff

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, September 23, 2014 at 1:27 AM
To: Alvaro Retana <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: rtgwg Rechartering

Hi,

1)      Small topics
“and may work on specific small topics that do not fit with an existing working group.”

“RTGWG may also work on specific small topics that do not fit with an existing working group.”

What about work which is general to Link State Protocols i.e. not specific to IS-IS and OSPF protocols. Should it be done once in RTGWG or twice in both IS-IS & OSPF WGs?
e.g. draft-litkowski-rtgwg-spf-uloop-pb-statement<http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-1.pdf>, draft-decraene-rtgwg-backoff-algo<http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-2.pdf>

[jeff] As you rightly mentioned the problem statement is evenly applicable to both OSPF and ISIS as well as neither require any protocol specific extensions, hence RTGWG is the right place to handle it

2)      BoF/new WG

“Options for handling new work include:

- Developing a charter and establishing consensus for a new WG”

It seems to me that so far the above work was currently performed in Routing Area plenary meetings.
Do we want to move this to RTGWG? If so
- I’m a bit concerned that such activities are less technically oriented, possibly political and involving many discussions and hence could delay the technical work in RTGWG.
[jeff] the idea is to provide “low(er) entry” to potentially good but not ready for BoF ideas, as well as cover new network architectural areas, good example – DC (bgp-routing-large-dc), there are more to come
It should not take years to develop new concepts if there’s enough interest from operators and vendors communities.
 What’s the remaining use of the Routing Area plenary meeting? A top down summary of latest WG status?

Thanks,
Regards,
Bruno

From: rtgwg [mailto:[email-masked]] On Behalf Of Alvaro Retana (aretana)
Sent: Monday, September 22, 2014 9:28 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: rtgwg Rechartering

Hi!

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 23 Sep 2014 12:57:27 +0000

On 9/23/14 6:04 AM, "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>> wrote:

On 23/09/2014 09:27, [email-masked]<mailto:[email-masked]> wrote:
Hi,

1)      Small topics

Bruno,

For RTGWG to take on new work it needs to be noted in the charter and that in turn needs to be approved by the IESG. Minor, non-controversial, items are nodded through so there is no drama there. However part of the discussion with the AD would surely be whether the work belonged in RTGWG, or some other WG, and thus matter such as you are concerned about would normally be handled on a case by case basis.

I therefore would be reluctant to see anything in the charter on this (the concept not the specific drafts) because every case is different.

Right..   Not referring specifically to Bruno's work (or any other specific draft)..

Any proposed work in the WG will be considered individually (of course, some proposals may have multiple drafts).  As with any work, large or small, the WG will have to reach consensus to adopt, move forward, etc.  IOW, just because something doesn't fit in another WG, or because it spans multiple WGs, the acceptance as a WG item in rtgwg is not guaranteed: that's what discussion and consensus are for.  None of that is new or different..it is normal WG operation and (agreeing with Stewart) shouldn't have to be explicitly spelled out in the charter.

The only thing that is new in the charter is that if the WG decides that the work should be looked at by a different WG, then we don't just tell people to "go away", we (the chairs) "will recommend the work to the Routing ADs with a summary of the evaluation."  The intent is that this will help have a better handoff between WGs, as needed.

This brings me to suggest a change to the charter text.  Right now it reads:

If RTGWG decides that a particular topic should be addressed by
a new WG, the chairs will recommend the work to the Routing ADs
with a summary of the evaluation.

Proposal:  s/new WG/different WG (new or existing)

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 23 Sep 2014 12:59:53 +0000

On 9/23/14 4:27 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

Bruno:

To complement what Stewart and Jeff already said..

2)      BoF/new WG

Note that the text you quoted talks about developing a proposal/charter, not just discussing the proposals, which is what I think happens in the rtgarea meetings.  The development and preparation for those meetings happens somewhere else.

One of the reasons to move some of these discussions to rtgwg is to benefit from the wide knowledge base in the WG, from more discussion and review..along with the structure of being a WG.  After all we all know that the real work in the IETF happens in the WGs. ;-)

We are defining a process (that will be posted in the wiki soon for everyone to review) to handle this type of work.  One of the items that you will see there is the assignment of a shepherd (from the RTG Directorate) to help figure out the details of the proposals/charters.  I would expect that the shepherd and the authors would do some of the work off-line and then have the WG comment/review.  Similar to what happens today, but with the structure of a WG to reach consensus, etc.

Even though we don't have any specific new work, we have already asked for additional time at the next in-person meeting.  One of the challenges is to know in advance what new topics will need to be discussed so that we can ask for and allocate enough time.

As we did before when discussing the energy efficiency work, for example, the intent is to allocate a specific block of time to specific discussions.  We don't want these new topics to starve the existing work, or vise versa.  As always, discussion on the list is very, very important for all the topics.

- What’s the remaining use of the Routing Area plenary meeting? A top down summary of latest WG status?

I'll let the ADs answer.

Alvaro.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 23 Sep 2014 13:25:36 +0000

Hi Bruno,

On Sep 23, 2014, at 4:27 AM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

1)      Small topics

I think these can stay in the RTG WG for two reasons:

          1. They don’t require changes to the OSPF/ISIS protocol encodings or protocol-specific changes to the mechanisms.
          2. These drafts flow naturally from previous RTG WG drafts and the general theme of avoiding/minimizing traffic loss  in the presence of failures.

Thanks,
Acee

2)      BoF/new WG

Thanks,
Regards,
Bruno

Hi!

Thanks!

Alvaro.

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 23 Sep 2014 15:49:14 +0100

It's a can't have linked I-Ds (like linked files) so that they show up 
in the document trail in other relevant WGs.

- Stewart

On 23/09/2014 14:25, Acee Lindem (acee) wrote:
> Hi Bruno,
>
> On Sep 23, 2014, at 4:27 AM, <[email-masked] 
> <mailto:[email-masked]>> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>> Hi,
>> e.g.draft-litkowski-rtgwg-spf-uloop-pb-statement 
>> <http://tools.ietf.org/agenda/90/slides/slides-90-rtgwg-1.pdf>,draft-decraene-rtgwg-backoff-algo 
>           1. They don't require changes to the OSPF/ISIS protocol 
> encodings or protocol-specific changes to the mechanisms.
>           2. These drafts flow naturally from previous RTG WG drafts 
> and the general theme of avoiding/minimizing traffic loss  in the 
> presence of failures.
>
> Thanks,
> Acee
>
>
>> 2)BoF/new WG
>>   
>> *From:*rtgwg [mailto:[email-masked]]*On Behalf Of*Alvaro 
>> Retana (aretana)
>> *Sent:*Monday, September 22, 2014 9:28 PM
>> *To:[email-masked] <mailto:[email-masked]>
>> *Cc:[email-masked] 
>> <mailto:[email-masked]>;[email-masked] 
>> <mailto:[email-masked]>
>> *Subject:*rtgwg Rechartering
>> Hi!
>> over the last couple of months..and in the rtgarea meeting in 
>> Toronto.  As part of the tuning it was proposed to clarify rtgwg's 
>> charter to better explain our mission of developing work proposals 
>> that do "not yet rise to the level where a new working group 
>> is justified, yet the topic does not fit with an existing working group,
>> and it is either not ready for a BOF or a single BOF would 
>> not provide the time to ensure a mature proposal" (from the current 
>> charter).
>> To that end we have written up a new charter with the help of the 
>> ADs.  Please take a look: 
>> http://datatracker.ietf.org/doc/charter-ietf-rtgwg/
>> As you read the proposed new charter, you should notice that there 
>> are 3 components to what the WG will be doing:
>>
>>     provide."  We have already put forth for WG consideration a
>>     couple of these (draft-ietf-rtgwg-bgp-routing-large-dc is an
>>     example).
>>     type of work is new to rtgwg: you may recall the energy
>>     efficiency work we discussed a few meetings ago.  But we do spend
>>     more time discussing this item on the charter.
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 23 Sep 2014 15:50:11 +0100

(two missing words!)

On 23/09/2014 15:49, Stewart Bryant wrote:
> It's a pity we can't have linked I-Ds (like linked files) so that they 
> show up in the document trail in other relevant WGs.
>
> - Stewart
>
>>> specific to IS-IS and OSPF protocols. Should it be done once in 
>>> RTGWG or twice in both IS-IS & OSPF WGs?
>>> oriented, possibly political and involving many discussions and 
>>> hence could delay the technical work in RTGWG.
>>>     efficiency work we discussed a few meetings ago.  But we do
>>>     spend more time discussing this item on the charter.
>>>

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Thu, 25 Sep 2014 13:24:55 +0000

Hi,

As we are discussing it; it would be of interest to see if this working group should not consider as part of its charter "extensions" for protocols for which there is no dedicated working group anymore (other areas have similar working groups e.g. TCPm)

Thanks,
-dimitri.

Hi!

Thanks!

Alvaro.

---

From: Alia Atlas <[email-masked]>
Date: Thu, 25 Sep 2014 09:51:11 -0400

Hi Dmitri,

On Thu, Sep 25, 2014 at 9:24 AM, Papadimitriou, Dimitri (Dimitri) <
[email-masked]> wrote:

>  Hi,
>
>
>
> As we are discussing it; it would be of interest to see if this working
> group should not consider as part of its charter “extensions” for protocols
> for which there is no dedicated working group anymore (other areas have
> similar working groups e.g. TCPm)
>

I think that falls into work that doesn't fit in another WG.  If it is
small, then this charter lets RTGWG pick it up.
If it's big, then rechartering would be necessary.

Alia

>  Thanks,
>
> -dimitri.
>
>
>
> *From:* rtgwg [mailto:[email-masked]] *On Behalf Of *Alvaro
> Retana (aretana)
> I hope many/most of you followed the 'RTG Area Tuning' discussions over
> the last couple of months..and in the rtgarea meeting in Toronto.  As part
> of the tuning it was proposed to clarify rtgwg's charter to better explain
> our mission of developing work proposals that do "not yet rise to the level
> where a new working group is justified, yet the topic does not fit with an
> existing working group,
>
> and it is either not ready for a BOF or a single BOF would not provide the
> time to ensure a mature proposal" (from the current charter).
>
>
>
>    2. Small topics (that don't fit in other WGs).  "An example of a small
>    topic is a draft that might otherwise be AD-sponsored but which could
>    benefit from the review and consensus that RTGWG can provide."  We have
>    already put forth for WG consideration a couple of these (draft-ietf-rtgwg-bgp-routing-large-dc
>    is an example).
>    proposals for new work in the Routing Area".  I don't think this type of
>    work is new to rtgwg: you may recall the energy efficiency work we
>    discussed a few meetings ago.  But we do spend more time discussing this
>    item on the charter.
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 25 Sep 2014 12:49:40 -0400

Hi Bruno,

On Tue, Sep 23, 2014 at 8:59 AM, Alvaro Retana (aretana) <[email-masked]>
wrote:

>  On 9/23/14 4:27 AM, "[email-masked]" <
> [email-masked]> wrote:
>

The Routing Area meeting is for a variety of things - part of it is top
down summaries, part of it
is what's happening in the Routing Area, part of it is an open forum for
discussion.  It's also been
used to present some more research-related topics that aren't looking for
standardization.

Alia

---

From: Uma Chunduri <[email-masked]>
Date: Thu, 25 Sep 2014 18:49:28 +0000

On Thu, Sep 25, 2014 at 9:24 AM, Papadimitriou, Dimitri (Dimitri) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,
As we are discussing it; it would be of interest to see if this working group should not consider as part of its charter “extensions” for protocols for which there is no dedicated working group anymore (other areas have similar working groups e.g. TCPm)

I think that falls into work that doesn't fit in another WG.  If it is small, then this charter lets RTGWG pick it up.
If it's big, then rechartering would be necessary.

Alia

===
Thanks Alia for clarifying this and I agree with you stated.
This is important as there could be small work items where things are specific interest to routing and quite critical in deployments (example security aspects, as KARP is closed now).
In those matters guidance from WG as well as specific suggestions from RTGWG chairs will be quite helpful.

$0.02
--
Uma C.