Subject: rtg-cfg draft hierarchy (Reply to this one)

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 12 Feb 2015 23:05:57 +0000

Hi Thomas, 

It is my understanding that the RIBs were moved out of the
routing-instance in response to your comment that a RIB would need to be
attached to multiple routing instances. I don¹t agree with this model. I
believe that a routing instance implies a VRF, virtual router or something
in between and that a RIB should be associated with one and only one
routing instance. Additionally, I feel that RIBs are basically passive
entities with respect to import/export of routes between RIBs in the same
or other routing-instances. Rather, all import/export is under the control
of a routing-protocol. For example, this would be handled by a BGP
routing-protocol instance for L3VPNs.

I¹d like to get the opinions of others on this fundamental aspect of the
rtg-cfg model. 

Thanks,
Acee

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 12 Feb 2015 23:18:00 +0000

In short, I agree with Mr. Lindem (unsurprisingly).

An "n to 1"  model between (same) routing protocol instances and RIB presents many unresolvable problems as soon address spaces overlap. Basically route from instance 1 becomes undistinguishable from route from instance 2 with same address (RDs are not intended to be in RIB, they are local concepts within a protocol).  One could image different ADs _per_ instance of same protocol but I'd like to see the use case for that. 

Same for interfaces, an interface has an address (generally, let's not discuss link locals and unnumbered and such) and the address is in an address space. RIB is basically a closure of an 'routable' address space and its summaries (prefixes) over multiple protocols dealing with reachability computation.

--- tony 

> -----Original Message-----
> From: rtgwg [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
> Sent: Thursday, February 12, 2015 3:06 PM
> To: Routing YANG; Routing WG; Thomas Morin; Ladislav Lhotka
> Subject: rtg-cfg draft hierarchy (Reply to this one)
> 
> Hi Thomas,
> 
> It is my understanding that the RIBs were moved out of the routing-instance in
> response to your comment that a RIB would need to be attached to multiple
> routing instances. I don¹t agree with this model. I believe that a routing instance
> implies a VRF, virtual router or something in between and that a RIB should be
> associated with one and only one routing instance. Additionally, I feel that RIBs
> are basically passive entities with respect to import/export of routes between
> RIBs in the same or other routing-instances. Rather, all import/export is under
> the control of a routing-protocol. For example, this would be handled by a BGP
> I¹d like to get the opinions of others on this fundamental aspect of the rtg-cfg
> model.
> 
> Thanks,
> Acee
> 
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg