Subject: Request for WG adoption of draft-rtg-dt-encap-02

From: Jeff Tantsura <[email-masked]>
Date: Fri, 22 May 2015 21:58:27 +0000

Hi RTGWG,

The authors have requested the RTGWG to adopt draft-rtg-dt-encap-02 as
working group document.

Please indicate support or no-support by June 8, 2015.

If you are listed as a document author or contributor please respond to
this email stating of whether or not you are aware of any relevant IPR.
The response needs to be sent to the RTGWG mailing list. The document will
not advance to the next stage until a response has been received from each
author and each individual that has contributed to the document.

Cheers,
Jeff & Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 23 May 2015 16:24:07 +0000

I support adopting the product of the encapsulation design team as a WG
document.
Thanks,
Acee 

On 5/22/15, 5:58 PM, "Jeff Tantsura" <[email-masked]> wrote:

>_______________________________________________
>rtgwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 27 May 2015 18:04:09 -0400

+1, I support adoption of this draft as a WG item. It has been helpful 
to the NVO3 WG and I believe adoption is in our (collective) best interests.

Cheers,
-Benson

Jeff Tantsura wrote:
> Jeff&  Chris

---

From: Alia Atlas <[email-masked]>
Date: Thu, 28 May 2015 11:16:44 -0400

I support adopting this draft in RTGWG.
I do hope to see the WG expand it to include more considerations around MPLS
as well as IP/UDP.

Thanks,
Alia

---

From: Antoni Przygienda <[email-masked]>
Date: Thu, 28 May 2015 16:06:36 +0000

Support +1 

Excellent draft & almost a 'required reading' for anyone touching any encaps ;-) 

thanks 

-- tony 

There are basically two types of people. People who accomplish things, and people who claim to have accomplished things. The first group is less crowded.
~~~ Mark Twain

> -----Original Message-----
> From: rtgwg [mailto:[email-masked]] On Behalf Of Benson Schliesser
> Sent: Wednesday, May 27, 2015 3:04 PM
> To: Jeff Tantsura
> Cc: [email-masked]; [email-masked]
> Subject: Re: Request for WG adoption of draft-rtg-dt-encap-02
>

---

From: Lucy yong <[email-masked]>
Date: Thu, 28 May 2015 20:57:11 +0000

This is a useful draft. Support!
Lucy

On Fri, May 22, 2015 at 5:58 PM, Jeff Tantsura <[email-masked]<mailto:[email-masked]>> wrote:
Hi RTGWG,

Cheers,
Jeff & Chris

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 29 May 2015 01:17:41 +0000

Support the WG adoption of this draft and fully agree with Alia that it would be much constructive to include more consideration around MPLS and IP/UDP . For instance, does the MPLS encapsulation need an explicit protocol identifier field to indicate the payload type in the long run (e.g., completely eliminate the trouble of first nibble issue for any future MPLS payload type)? Does IP/UDP need a mandatory fragmentation capability on the tunnel layer?

Best regards,
Xiaohu

From: rtgwg [mailto:[email-masked]] On Behalf Of Alia Atlas
Sent: Thursday, May 28, 2015 11:17 PM
To: Jeff Tantsura
Cc: [email-masked]; [email-masked]
Subject: Re: Request for WG adoption of draft-rtg-dt-encap-02

Thanks,
Alia

Cheers,
Jeff & Chris

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 28 May 2015 22:43:37 -0700

On 5/28/15 6:17 PM, Xuxiaohu wrote:
>
> Support the WG adoption of this draft and fully agree with Alia that 
> it would be much constructive to include more consideration around 
> MPLS and IP/UDP . For instance, does the MPLS encapsulation need an 
> explicit protocol identifier field to indicate the payload type in the 
> long run (e.g., completely eliminate the trouble of first nibble issue 
> for any future MPLS payload type)?
>
Xiaohu,
In -02 we added some text about the considerations for the first nibble 
over MPLS. But as the rest of the document this is phrased as a 
consideration and not a requirement.

> Does IP/UDP need a mandatory fragmentation capability on the tunnel layer?
>
That is a very good question. The IETF and Internet experience is that 
successful protocols are likely to be deployed outside of their initial 
target domain. So even if the initial target domain(s) don't need 
fragmentation it would seem prudent to at least include the option to be 
able to do fragmentation and reassembly. (Likewise goes for having 
sufficient extensibility to add higher levels of security should the 
protocol be used in different domains.)

Regards,
     Erik

> Best regards,
>
> Xiaohu
>
> *From:*rtgwg [mailto:[email-masked]] *On Behalf Of *Alia Atlas
> *Sent:* Thursday, May 28, 2015 11:17 PM
> *To:* Jeff Tantsura
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: Request for WG adoption of draft-rtg-dt-encap-02
>
> On Fri, May 22, 2015 at 5:58 PM, Jeff Tantsura 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Hi RTGWG,
>
> [email-masked] <mailto:[email-masked]>