Subject: Brian Haberman's No Objection on draft-ietf-rtgwg-mrt-frr-architecture-09: (with COMMENT)

From: "Brian Haberman" <[email-masked]>
Date: Wed, 03 Feb 2016 07:04:07 -0800

Brian Haberman has entered the following ballot position for
draft-ietf-rtgwg-mrt-frr-architecture-09: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-mrt-frr-architecture/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

The IANA Considerations section creates a new registry for the MRT
Profiles. It allocates "Values 221-255 are for vendor private use." Are
there limitations/guidance on how vendors use this range? Should Section
8,14 or 17 say something about dealing with these ranges in operational
networks?

---

From: Chris Bowers <[email-masked]>
Date: Sat, 6 Feb 2016 01:25:16 +0000

Brian,

Thanks for the feedback.  See inline[CB].

This is incorporated in the latest version.
https://tools.ietf.org/html/draft-ietf-rtgwg-mrt-frr-architecture-10
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-mrt-frr-architecture-10

Chris

-----Original Message-----
From: Brian Haberman [mailto:[email-masked]] 
Sent: Wednesday, February 03, 2016 9:04 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; Janos Farkas <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Brian Haberman's No Objection on draft-ietf-rtgwg-mrt-frr-architecture-09: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

The IANA Considerations section creates a new registry for the MRT Profiles. It allocates "Values 221-255 are for vendor private use." Are there limitations/guidance on how vendors use this range? Should Section
8,14 or 17 say something about dealing with these ranges in operational networks?

[CB]I have modified the IANA considerations section to use the exact terms defined in RFC 5226 "Guidelines for Writing an IANA Considerations Section in RFCs", and also to give IANA clearer guidance on the structure of table.  I added a reference to RFC5226 as well. 

I think RFC5226 gives pretty good guidance about what to expect when using these ranges, that additional text in Section 8,14, or 17 would not add much.  

==================

16.  IANA Considerations

   IANA is requested to create a registry entitled "MRT Profile
   Identifier Registry".  The range is 0 to 255.  The Default MRT
   Profile defined in this document has value 0.  Values 1-200 are
   allocated by Standards Action.  Values 201-220 are for Experimental
   Use.  Values 221-254 are for Private Use.  Value 255 is reserved for
   future registry extension.  (The allocation and use policies are
   described in [RFC5226].)

   The initial registry is shown below.

      Value    Description                               Reference
      -------  ----------------------------------------  ------------
      0        Default MRT Profile                       [This draft]
      1-200    Unassigned
      201-220  Experimental Use
      221-254  Private Use
      255      Reserved (for future registry extension)

   The MRT Profile Identifier Registry is a new registry in the IANA
   Matrix.  Following existing conventions, http://www.iana.org/
   protocols should display a new header entitled "Maximally Redundant
   Tree (MRT) Parameters".  Under that header, there should be an entry
   for "MRT Profile Identifier Registry" with a link to the registry
   itself at http://www.iana.org/assignments/mrt-parameters/mrt-
   parameters.xhtml#mrt-profile-registry.

---

From: Brian Haberman <[email-masked]>
Date: Sun, 7 Feb 2016 13:43:49 -0500

Hi Chris,
    This looks good. Thanks for considering my comment!

Regards,
Brian