Subject: draft-ietf-rtgwg-yang-key-chain: YANG compilation

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Jun 2016 08:51:55 +0200

Dear draft-ietf-rtgwg-yang-key-chain-03,

The YANG module compilation in your draft fails with the following warning:
[email-masked]:1: warning: unexpected modulename 
"ietf-key-chain" in [email-masked], should be 
ietf-routing-key-chain
See http://www.claise.be/IETFYANGPageCompilation.html

The previous version 02 was fine in that regards.

This warning should have been flagged in idnits. Let me know if this was 
not the case.
www.yangvalidator.com can also be useful.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Jun 2016 08:59:25 +0200

Also, note that 7 YANG modules currently fail because of this issue, 
while they compiled fine with v2.
     ietf-bier.yang
     [email-masked]
     [email-masked]
     [email-masked]
     [email-masked]
     [email-masked]
     [email-masked]

Search for "ietf-routing-key-chain" in 
http://www.claise.be/IETFYANGPageCompilation.html

Regards, Benoit
> [email-masked]:1: warning: unexpected 
> modulename "ietf-key-chain" in [email-masked], 
> should be ietf-routing-key-chain
> This warning should have been flagged in idnits. Let me know if this 
> was not the case.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 28 Jun 2016 11:39:09 +0000

Fixed. 

On 6/28/16, 2:51 AM, "rtgwg on behalf of Benoit Claise (bclaise)"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>rtgwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 28 Jun 2016 11:42:15 +0000

Derek, Stephane, and Xufeng,

Due to popular demand, we have restored the name of the key-chain module
to simply “ietf-key-chain”. Please update references prior to the July 8th
cut-off. 

Thanks,
Acee

---

From: Benoit Claise <[email-masked]>
Date: Tue, 28 Jun 2016 14:26:45 +0200

Thank you Acee.
All updated at http://www.claise.be/IETFYANGPageCompilation.html

Regards, B.