Subject: Re: draft-ietf-rtgwg-yang-key-chain: YANG compilation

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 4 Jul 2016 01:36:26 +0000

Is there still a small issue in draft-ietf-rtgwg-yang-key-chain-03

4 Key Chain YANG Model

   <CODE BEGINS> file "[email-masked]"

On 2016-06-28, 7:42 AM, "rtgwg on behalf of Acee Lindem (acee)"
<[email-masked] on behalf of [email-masked]> wrote:

>Derek, Stephane, and Xufeng,
>
>Due to popular demand, we have restored the name of the key-chain module
>to simply ³ietf-key-chain². Please update references prior to the July 8th
>cut-off. 
>
>Thanks,
>Acee 
>
>On 6/28/16, 2:59 AM, "rtgwg on behalf of Benoit Claise (bclaise)"
><[email-masked] on behalf of [email-masked]> wrote:
>
>>Also, note that 7 YANG modules currently fail because of this issue,
>>while they compiled fine with v2.
>>     ietf-bier.yang
>>     [email-masked]
>>     [email-masked]
>>     [email-masked]
>>     [email-masked]
>>     [email-masked]
>>     [email-masked]
>>
>>Search for "ietf-routing-key-chain" in
>>http://www.claise.be/IETFYANGPageCompilation.html
>>
>>Regards, Benoit
>>> Dear draft-ietf-rtgwg-yang-key-chain-03,
>>>
>>> The YANG module compilation in your draft fails with the following
>>> warning:
>>> [email-masked]:1: warning: unexpected
>>> modulename "ietf-key-chain" in [email-masked],
>>> should be ietf-routing-key-chain
>>> See http://www.claise.be/IETFYANGPageCompilation.html
>>>
>>> The previous version 02 was fine in that regards.
>>>
>>> This warning should have been flagged in idnits. Let me know if this
>>> was not the case.
>>> www.yangvalidator.com can also be useful.
>>>
>>> Regards, Benoit
>>
>>_______________________________________________
>>rtgwg mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/rtgwg
>
>_______________________________________________
>rtgwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 4 Jul 2016 01:43:57 +0000

Reshad - you are looking at an older version. Look at the latest,
https://www.ietf.org/id/draft-ietf-rtgwg-yang-key-chain-06.txt
Acee

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Mon, 4 Jul 2016 01:53:38 +0000

Thanks Acee. I was on
https://tools.ietf.org/html/draft-ietf-rtgwg-yang-key-chain-03 and it
showed 03 as latest. When I went to 02 it showed up to 06.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 4 Jul 2016 08:29:43 +0200

Please report it as a bug
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-yang-key-chain/
     => very last line of the page.

Regards, B.