Subject: Q&A at Microphone on GRPC

From: "Eric Voit (evoit)" <[email-masked]>
Date: Thu, 21 Jul 2016 20:12:41 +0000

Hi Sam,

Looking at the Etherpad notes for Tuesday's session in GRPC there is the following Q&A exchange:
Alia: how yang push could interwork from model perspective.
Sam: YANG is not the only thing that we are looking at, there are other modelling approaches available.

Based on the NETCONF WG's adoption of RFC-5277bis on Wednesday, a simplified yang push subscription model can now be applied to event streams of non-YANG data.

If you guys want to work though how we might merge this with GRPC transport, let me know.  Some pretty cool capabilities could result.

Thanks,
Eric

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 21 Jul 2016 15:10:35 -0700

Hi Eric,

Thanks for reaching out.
We could continue the conversation and work towards getting the IETF
community benefit from the operators point of view, like we are doing with
OpenConfig.

cheers
-sam

On Thu, Jul 21, 2016 at 1:12 PM, Eric Voit (evoit) <[email-masked]> wrote:

> Hi Sam,
>
>
>
> Looking at the Etherpad notes for Tuesday’s session in GRPC there is the
> following Q&A exchange:
>
> Based on the NETCONF WG’s adoption of RFC-5277bis on Wednesday, a
> simplified yang push subscription model can now be applied to event streams
> of non-YANG data.
>
>
>
> If you guys want to work though how we might merge this with GRPC
> transport, let me know.  Some pretty cool capabilities could result.
>
>
>
> Thanks,
>
> Eric
>
>
>