Subject: Random numbers and In-situ OAM

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 15 Nov 2016 08:40:19 -0000

Hi Frank,

Thought I had possibly mis-heard in RTGWG, but heard you again in OPSAWG say
something about "using part of a random number" .

I just ran off to look at draft-brockners*.txt and searched "random".

I see some discussion of random numbers that looks fine, but I don't see
anything (which may be my eyesight :-) about taking part of a random number.

Do you have a pointer or a quick explanation? (Or you can tell me that my
hearing is impaired!)

Thanks,
Adrian

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 15 Nov 2016 08:55:00 +0000

Hi Adrian,

what I was referring to was protecting against preplay attacks - see section 8.4 of draft-brockners-proof-of-transit-02:
https://tools.ietf.org/html/draft-brockners-proof-of-transit-02#section-8.4

To protect against pre-play, we suggest to leverage a part of the HMAC of a part of the packet which isn't modified as it traverses the network for the random number RND which serves as a unique identifier for the packet for POT.

Regards, Frank

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Dienstag, 15. November 2016 17:40
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Random numbers and In-situ OAM

Hi Frank,

Thought I had possibly mis-heard in RTGWG, but heard you again in OPSAWG say something about "using part of a random number" .

I see some discussion of random numbers that looks fine, but I don't see anything (which may be my eyesight :-) about taking part of a random number.

Do you have a pointer or a quick explanation? (Or you can tell me that my hearing is impaired!)

Thanks,
Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 15 Nov 2016 08:59:42 -0000

Brilliant, thanks Frank.

My eyesight failed me.

I'll read and digest.

Adrian

> From: Frank Brockners (fbrockne) [mailto:[email-masked]]
> Sent: 15 November 2016 08:55
> To: [email-masked]
> Subject: RE: Random numbers and In-situ OAM
> 
> Hi Adrian,
> 
> what I was referring to was protecting against preplay attacks - see section
8.4 of
> draft-brockners-proof-of-transit-02:
> To protect against pre-play, we suggest to leverage a part of the HMAC of a
part
> of the packet which isn't modified as it traverses the network for the random
> number RND which serves as a unique identifier for the packet for POT.