Subject: Draft-rtgyangdt-rtgwg-routing-types

From: Robert Raszuk <[email-masked]>
Date: Fri, 18 Nov 2016 02:13:26 +0100

Hi,

I have a question on the intention on how complete the document should be ?

As example on vpn section why RT is described and SOO is not mentioned ?

Similar why extended communities are mentioned and no format is defined for
standard or cost communities also necessary for some vpn provisioning ?

Similar I do not see defined format for static mpls labels ...

For router-id is this per protocol, global or per vrf ?

In other words is the intention here to only list cherry picked elements
which are found in at least two protocols ?

I think to make it complete much more work is needed ... provided I
understand the main objective of this proposal.

Many thx,
R.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 18 Nov 2016 04:56:10 +0000

Hi Robert,

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 17, 2016 at 8:13 PM
To: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: Draft-rtgyangdt-rtgwg-routing-types

Hi,

This was taken from one of the other models. Can you indicate what is missing from the syntax of the RT for Site of Origin (SOO)?

Similar why extended communities are mentioned and no format is defined for standard or cost communities also necessary for some vpn provisioning ?

We will check with the BGP and L3VPN model owners.

This could be something we could add.

This router-id  type could apply to any of these. It is the type as opposed to an instance of a router-id.

In other words is the intention here to only list cherry picked elements which are found in at least two protocols ?

Yes - this is to allow common definitions without having to redefine them or import entire models.

Thanks,
Acee

I think to make it complete much more work is needed ... provided I understand the main objective of this proposal.

Many thx,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 19 Nov 2016 12:34:00 +0100

Hi Acee,

SOO has similar format to RT however RT is defined only partially. There is
existing extension to RFC4360 in the form of RFC5668 which defines new
structure of both RT and SOO (Route Origin).

Also I think there important this draft needs to define type for VRF as VRF
as such is used across a lot of different applications way beyond original
L3VPN use intention.

And I think there is many more common elements ... just think of recent geo
coordinates shred by 4 WGs (if not more ...).

Thx,
R.

On Fri, Nov 18, 2016 at 5:56 AM, Acee Lindem (acee) <[email-masked]> wrote:

> Hi Robert,
>
> From: rtgwg <[email-masked]> on behalf of Robert Raszuk <
> [email-masked]>
> To: Routing WG <[email-masked]>
> This was taken from one of the other models. Can you indicate what is
> missing from the syntax of the RT for Site of Origin (SOO)?
>
> Similar why extended communities are mentioned and no format is defined
> for standard or cost communities also necessary for some vpn provisioning ?
>