Subject: presentation slides for SD-WAN (Overlay VPN) at the RTGwg meeting in IETF97

From: Linda Dunbar <[email-masked]>
Date: Sun, 13 Nov 2016 20:45:17 +0000

RTGwg Chairs,

Attached is our presentation slide for Tuesday RTGwg session.

Thank you very much for giving us the slot.

Linda

From: Linda Dunbar
Sent: 2016年11月3日 11:43
To: [email-masked]' <[email-masked]>; [email-masked]' <[email-masked]>; Alia Atlas <[email-masked]>
Cc: '<[email-masked]>' <[email-masked]>; [email-masked]' <[email-masked]>; Lucy yong <[email-masked]>; Songxiaolin <[email-masked]>; Chenrui (Richard) <[email-masked]>
Subject: request a presentation slot at the RTGwg meeting in IETF97

Chris, Jeff, and Alia:

We would like a 10-minutes slot at the RTGwg meeting in IETF97 to describe a new type of private network service:  https://datatracker.ietf.org/doc/draft-dunbar-opsawg-private-networks-over-thin-cpe/

In a nutshell, this new type of private network service
- is like SD-WAN in the way that IP tunnels are automatically established from a thin-CPE at customer site,
- but different from SD-WAN because there are interactions with the underlay network (even though the interaction to underlay network is transparent to users), and  there are gateways (for private networks) instantiated in the underlay network to establish secure connections between Thin-CPEs and the gateways, and guaranteed QoS from the underlay networks.

The draft was submitted to opsawg. But after discussing with several IETF veterans of the draft, we have been told that the RTGwg is more suitable, as the new type of service described in the draft will need some protocol work. Some of the protocol work needed are documented in https://datatracker.ietf.org/doc/draft-templin-aerolink/, such as Interface Characteristics, Relay Behavior, Interface Forwarding Algorithm, Router Discovery, Prefix Delegation and Autoconfiguration, Interface Route Optimization, etc. (not to say the protocols described are 100% correct & applicable).

Some items listed in "draft-kanugovi-intarea-mams-protocol-01" are applicable too, such as
- Access technology agnostic interworking
- Independent Access path selection for Uplink and Downlink
- IP anchor selection independent of uplink and downlink access
- Adaptive network path selection
- Configuring network middleboxes based on negotiated protocols

The draft describes a private network laid over multiple Thin CPEs   (or Overlay VPN for easy of description).
"Overlay VPN" is a type of private networks that interconnect thin CPEs at multiple client sites by IP tunnels, or more specifically, lay over multiple client sites’ Thin CPEs via IP tunnels. Those private overlay networks not only interconnect those sites by secure IP tunnels but can also enforce the client specified policies to govern how applications or hosts within those sites communicate and how to access public internet.

Thank you very much.

Linda Dunbar

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 13 Nov 2016 17:07:10 -0800

Hi Linda,

Thanks for the slides!

2nd slide needs to be fixed.

In my earlier feedback I asked you to add more slides to expand on generic issues is the space, such as jungle of on the wire encaps, lack of standardized control plane to mention just a few. I’d appreciate if you could add those to facilitate the discussion.

There are number of front runners on this space, startups such as Versa, Viptela, VeloCloud, etc, more established companies such as Citrix, Cisco, Juniper, Nokia and Riverhead. Most of them have people who used to participate in IETF work and could be approached for collaboration.

Personally, during the panel at SD-WAN summit in Paris I brought up set of issues described above and there seems to be willingness (and push from their customers) to work together on data models, standardized encodings and potentially control plane.

Thanks!

Cheers,

Jeff

From: Linda Dunbar <[email-masked]>
Date: Sunday, November 13, 2016 at 12:45
To: Chris Bowers <[email-masked]>, "[email-masked]" <[email-masked]>, Alia Atlas <[email-masked]>
Cc: "<[email-masked]>" <[email-masked]>, RTGWG <[email-masked]>, Lucy yong <[email-masked]>, Songxiaolin <[email-masked]>, "Chenrui (Richard)" <[email-masked]>
Subject: presentation slides for SD-WAN (Overlay VPN) at the RTGwg meeting in IETF97

RTGwg Chairs,

Linda

From: Linda Dunbar 
Sent: 2016年11月3日 11:43

Chris, Jeff, and Alia:

 

Thank you very much. 

Linda Dunbar

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 14 Nov 2016 02:24:03 +0100

Jeff,

In this space there are two ways the below topic could be addressed:

• try to standardize control plane and data plane (or force everyone to use
one of already available ones ex: LISP)

• accept that it is to our common advantage to have different control
planes, use different wire encapsulation between edges and edges to control
plane and only focus on building the standard  interconnects

With the above let's also keep in mind that what we are putting under
sd-wan umbrella are quite often very different use cases and solutions to
address them:

- L3vpn/l2vpn replacement
- easy secure access to public clouds
- light  CPE + cloud based application execution
- IoT sensor placements and their central mgmt

I am not sure if putting all of those under the same control and data plane
is actually a good thing to any of the above.

Cheers,
R.

On Nov 14, 2016 02:07, "Jeff Tantsura" <[email-masked]> wrote:

Hi Linda,

Thanks for the slides!

In my earlier feedback I asked you to add more slides to expand on generic
issues is the space, such as jungle of on the wire encaps, lack of
standardized control plane to mention just a few. I’d appreciate if you
could add those to facilitate the discussion.

There are number of front runners on this space, startups such as Versa,
Viptela, VeloCloud, etc, more established companies such as Citrix, Cisco,
Juniper, Nokia and Riverhead. Most of them have people who used to
participate in IETF work and could be approached for collaboration.

Personally, during the panel at SD-WAN summit in Paris I brought up set of
issues described above and there seems to be willingness (and push from
their customers) to work together on data models, standardized encodings
and potentially control plane.

Thanks!

Cheers,

Jeff

*From: *Linda Dunbar <[email-masked]>
*Date: *Sunday, November 13, 2016 at 12:45
*To: *Chris Bowers <[email-masked]>, "[email-masked]" <
[email-masked]>, Alia Atlas <[email-masked]>
*Cc: *"<[email-masked]>" <[email-masked]>, RTGWG <[email-masked]>, Lucy
yong <[email-masked]>, Songxiaolin <[email-masked]>, "Chenrui
(Richard)" <[email-masked]>
*Subject: *presentation slides for SD-WAN (Overlay VPN) at the RTGwg
meeting in IETF97

RTGwg Chairs,

Linda

*From:* Linda Dunbar
*Sent:* 2016年11月3日 11:43
*To:* [email-masked]' <[email-masked]>; [email-masked]'
<[email-masked]>; Alia Atlas <[email-masked]>
*Cc:* '<[email-masked]>' <[email-masked]>; [email-masked]' <
[email-masked]>; Lucy yong <[email-masked]>; Songxiaolin <
[email-masked]>; Chenrui (Richard) <[email-masked]>
*Subject:* request a presentation slot at the RTGwg meeting in IETF97

Chris, Jeff, and Alia:

We would like a 10-minutes slot at the RTGwg meeting in IETF97 to describe
a new type of private network service: *
https://datatracker.ietf.org/doc/draft-dunbar-opsawg-private-networks-over-thin-cpe/
<https://datatracker.ietf.org/doc/draft-dunbar-opsawg-private-networks-over-thin-cpe/>*

- is like SD-WAN in the way that IP tunnels are automatically established
from a thin-CPE at customer site,

- but different from SD-WAN because there are interactions with the
underlay network (even though the interaction to underlay network is
transparent to users), and  there are gateways (for private networks)
instantiated in the underlay network to establish secure connections
between Thin-CPEs and the gateways, and guaranteed QoS from the underlay
networks.

The draft was submitted to opsawg. But after discussing with several IETF
veterans of the draft, we have been told that the RTGwg is more suitable,
as the new type of service described in the draft will need some protocol
work. Some of the protocol work needed are documented in
https://datatracker.ietf.org/doc/draft-templin-aerolink/, such as Interface
Characteristics, Relay Behavior, Interface Forwarding Algorithm, Router
Discovery, Prefix Delegation and Autoconfiguration, Interface Route
Optimization, etc. (not to say the protocols described are 100% correct &
applicable).

Some items listed in "draft-kanugovi-intarea-mams-protocol-01" are
applicable too, such as

The draft describes a private network laid over multiple Thin CPEs   (or
Overlay VPN for easy of description).

"Overlay VPN" is a type of private networks that interconnect thin CPEs at
multiple client sites by IP tunnels, or more specifically, lay over
multiple client sites’ Thin CPEs via IP tunnels. Those private overlay
networks not only interconnect those sites by secure IP tunnels but can
also enforce the client specified policies to govern how applications or
hosts within those sites communicate and how to access public internet.

Thank you very much.

Linda Dunbar

_______________________________________________
rtgwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 13 Nov 2016 17:45:51 -0800

Robert,

Perhaps there are more than two…

The intention is to bring those issues up and start the discussion (which is exactly in RTGWG charter), there’s definitely interest from the industry and urgent need for alignment. 

>From my personal point of view – the most urgent part would be the data modeling, so the service intent could be expressed in a vendor agnostic way.

Please note – there’s absolutely no intention to “invent” a new control plane and the push it thru everyone’s throat, we know better than that J

The issues are there, lack of interoperability is hurting people who use it and I believe – RTGWG’ job is to provide a stage for the discussion and potentially home, may WG decide so. 

Cheers,

Jeff

From: <[email-masked]> on behalf of "[email-masked]" <[email-masked]>
Date: Sunday, November 13, 2016 at 17:24
To: Jeff Tantsura <[email-masked]>
Cc: RTGWG <[email-masked]>
Subject: Re: presentation slides for SD-WAN (Overlay VPN) at the RTGwg meeting in IETF97

Jeff,

• try to standardize control plane and data plane (or force everyone to use one of already available ones ex: LISP)

• accept that it is to our common advantage to have different control planes, use different wire encapsulation between edges and edges to control plane and only focus on building the standard  interconnects 

With the above let's also keep in mind that what we are putting under sd-wan umbrella are quite often very different use cases and solutions to address them:

I am not sure if putting all of those under the same control and data plane is actually a good thing to any of the above.

Cheers,
R.

Hi Linda,

Thanks for the slides!

Thanks!

Cheers,

Jeff

RTGwg Chairs,

Linda

From: Linda Dunbar 
Sent: 2016年11月3日 11:43

Chris, Jeff, and Alia:

 

Thank you very much. 

Linda Dunbar

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 14 Nov 2016 11:55:45 +0000

Jeff,

Thank you very much for the useful feedback.

Tomorrow introduction is to solicit people in the community interested to work together. We also should bring this to other places to solicit more feedback and collaboration.

Attached is the revised slides.

Linda

From: Jeff Tantsura [mailto:[email-masked]]
Sent: 2016年11月14日 10:07
To: Linda Dunbar <[email-masked]>; [email-masked]; Alia Atlas <[email-masked]>
Cc: <[email-masked]> <[email-masked]>; [email-masked]; Lucy yong <[email-masked]>; Songxiaolin <[email-masked]>; Chenrui (Richard) <[email-masked]>
Subject: Re: presentation slides for SD-WAN (Overlay VPN) at the RTGwg meeting in IETF97

Hi Linda,

Thanks for the slides!

Thanks!

Cheers,
Jeff

From: Linda Dunbar <[email-masked]<mailto:[email-masked]>>
Date: Sunday, November 13, 2016 at 12:45
To: Chris Bowers <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>
Cc: "<[email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]>>, RTGWG <[email-masked]<mailto:[email-masked]>>, Lucy yong <[email-masked]<mailto:[email-masked]>>, Songxiaolin <[email-masked]<mailto:[email-masked]>>, "Chenrui (Richard)" <[email-masked]<mailto:[email-masked]>>
Subject: presentation slides for SD-WAN (Overlay VPN) at the RTGwg meeting in IETF97

RTGwg Chairs,

Linda

From: Linda Dunbar
Sent: 2016年11月3日 11:43
To: [email-masked]' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; Alia Atlas <[email-masked]<mailto:[email-masked]>>
Cc: '<[email-masked]<mailto:[email-masked]>>' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; Lucy yong <[email-masked]<mailto:[email-masked]>>; Songxiaolin <[email-masked]<mailto:[email-masked]>>; Chenrui (Richard) <[email-masked]<mailto:[email-masked]>>
Subject: request a presentation slot at the RTGwg meeting in IETF97

Chris, Jeff, and Alia:

Thank you very much.

Linda Dunbar