Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain

From: Jeff Tantsura <[email-masked]>
Date: Mon, 06 Feb 2017 10:35:09 -0800

Dear RTGWG,

There have been significant changes to the draft-ietf-rtgwg-yang-key-chain draft.

We would like the wg to review the updated draft and hence start another, 1 week long WGLC.

Please indicate support/ no-support by February 13, 2017.

Thanks,

Jeff & Chris

From: Jeff Tantsura <[email-masked]>
Date: Friday, September 9, 2016 at 16:11
To: RTGWG <[email-masked]>
Cc: rtgwg-chairs <[email-masked]>, <[email-masked]>
Subject: Last Call for draft-ietf-rtgwg-yang-key-chain 

Dear RTGWG,

The authors have requested the RTGWG to last call draft-ietf-rtgwg-yang-key-chain 

There was consensus that document is ready for the last call during the last IETF meeting and the authors have addressed all the comments from Directorate QA review.

Please indicate support or no-support by September 23rd, 2016. 

IPR:

If you are listed as a document author or contributor, please respond to this email.

of whether or not you are aware of any relevant IPR. The response needs to be sent to the RTGWG mailing list. 

The document will not advance to the next stage until a response has been received from each author and each 

individual that has contributed to the document.

Thanks,

Jeff & Chris

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Mon, 6 Feb 2017 23:53:26 +0000

I support as a co-author. This IETF YANG model is currently referenced by a number or the other protocol models for specification of authentication keys including OSPF, IS-IS, RIP, and VRRP.

Thanks,
Acee
P.S. Not aware of any IPR in case you want to ask again ;^)

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 6, 2017 at 1:35 PM
To: Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: rtgwg-chairs <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeffrey Zhang <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, Helen Chen <[email-masked]<mailto:[email-masked]>>, Yingzhen Qu <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Monday, February 6, 2017 at 1:35 PM

Dear RTGWG,

Thanks,
Jeff & Chris

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Friday, September 9, 2016 at 16:11
To: RTGWG <[email-masked]<mailto:[email-masked]>>
Cc: rtgwg-chairs <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Subject: Last Call for draft-ietf-rtgwg-yang-key-chain

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: Benoit Claise <[email-masked]>
Date: Tue, 7 Feb 2017 11:57:49 +0100

On 2/7/2017 12:53 AM, Acee Lindem (acee) wrote:
> I support as a co-author. This IETF YANG model is currently referenced 
> by a number or the other protocol models for specification of 
> authentication keys including OSPF, IS-IS, RIP, and VRRP.
And note that there are dependencies on some NETCONF WG documents.
http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-keychain&orgs[]=ietf&recurse=1&rfcs=1

Basically, this "Client/Server Configuration Model" package, i.e. those 
drafts:
     draft-ietf-netconf-keystore-00 Keystore Model
     draft-ietf-netconf-ssh-client-server-00 SSH Client and Server Models
     draft-ietf-netconf-tls-client-server-00 TLS Client and Server Models
     draft-ietf-netconf-netconf-client-server-00 NETCONF Client and 
Server Models
     draft-ietf-netconf-restconf-client-server-00 RESTCONF Client and 
Server Models

For this package, see 
http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-tls-client&modules[]=ietf-tls-server&modules[]=ietf-ssh-client&modules[]=ietf-ssh-server&modules[]=ietf-restconf-client&modules[]=ietf-restconf-server&modules[]=ietf-key-store&modules[]=ietf-netconf-client&modules[]=ietf-netconf-server&orgs[]=ietf&recurse=&rfcs=1

Copying the NETCONF chairs, to get the latest status, and to make sure 
this NETCONF package progresses at the same pace.

Regards, Benoit
> To: Routing WG <[email-masked] <mailto:[email-masked]>>
> Cc: rtgwg-chairs <[email-masked] 
> <mailto:[email-masked]>>, 
> "[email-masked] 
> <mailto:[email-masked]>" 
> <[email-masked] 
> <mailto:[email-masked]>>
> Resent-From: <[email-masked] <mailto:[email-masked]>>
> Resent-To: Acee Lindem <[email-masked] <mailto:[email-masked]>>, 
> Jeffrey Zhang <[email-masked] <mailto:[email-masked]>>, 
> <[email-masked] <mailto:[email-masked]>>, Helen Chen 
> <[email-masked] <mailto:[email-masked]>>, Yingzhen Qu 
> <[email-masked] <mailto:[email-masked]>>, 
> <[email-masked] <mailto:[email-masked]>>
>     *From: *Jeff Tantsura <[email-masked]
>     <mailto:[email-masked]>>
>     *Date: *Friday, September 9, 2016 at 16:11
>     *To: *RTGWG <[email-masked] <mailto:[email-masked]>>
>     *Cc: *rtgwg-chairs <[email-masked]
>     <mailto:[email-masked]>>,
>     <[email-masked]
>     <mailto:[email-masked]>>
>     *Subject: *Last Call for draft-ietf-rtgwg-yang-key-chain
>
>     Dear RTGWG,
>
>     There was consensus that document is ready for the last call
>     during the last IETF meeting and the authors have addressed all
>     the comments from Directorate QA review.
>
>     of whether or not you are aware of any relevant IPR. The response
>     needs to be sent to the RTGWG mailing list.
>
>     The document will not advance to the next stage until a response
>     has been received from each author and each
>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 7 Feb 2017 12:11:39 +0000

Hi Benoit,

This is the IETF key-chain model which is comprised of a lists of symmetric keys that are used for applications such as routing protocol authentication and encryption. The IETF keystore model is comprised of lists of asymmetric keys and certificates that are used for applications such as NETCONF authentication and encryption. The two models are in no way dependent on one another.

Thanks,
Acee

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 7, 2017 at 5:57 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: rtgwg-chairs <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kent Watsen <[email-masked]<mailto:[email-masked]>>
Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain

Basically, this "Client/Server Configuration Model" package, i.e. those drafts:
    draft-ietf-netconf-keystore-00 Keystore Model
    draft-ietf-netconf-ssh-client-server-00 SSH Client and Server Models
    draft-ietf-netconf-tls-client-server-00 TLS Client and Server Models
    draft-ietf-netconf-netconf-client-server-00 NETCONF Client and Server Models
    draft-ietf-netconf-restconf-client-server-00 RESTCONF Client and Server Models

For this package, see http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-tls-client&modules[]=ietf-tls-server&modules[]=ietf-ssh-client&modules[]=ietf-ssh-server&modules[]=ietf-restconf-client&modules[]=ietf-restconf-server&modules[]=ietf-key-store&modules[]=ietf-netconf-client&modules[]=ietf-netconf-server&orgs[]=ietf&recurse=&rfcs=1

Copying the NETCONF chairs, to get the latest status, and to make sure this NETCONF package progresses at the same pace.

Regards, Benoit

Thanks,
Acee

Dear RTGWG,

Thanks,
Jeff & Chris

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Benoit Claise <[email-masked]>
Date: Tue, 7 Feb 2017 17:45:59 +0100

Hi Acee,

Yes, I've been confused (more than once) by ietf-key-chain and 
ietf-key-store. Sorry.

The correct graph is here.
http://www.yangcatalog.org/yang-search/impact_analysis.php?modules[]=ietf-key-chain&orgs[]=ietf&recurse=0&rfcs=1
And thanks to Joe Clarke for improving the tool in real-time.

The graph shows a dependency on the ietf-netconf-acm YANG module.
Checking the draft...

    <CODE BEGINS> file "[email-masked]"
    module ietf-key-chain {
        namespace "urn:ietf:params:xml:ns:yang:ietf-key-chain";
        // replace with IANA namespace when assigned
        prefix "key-chain";
       import ietf-yang-types {
            prefix "yang";
        }

        import ietf-netconf-acm {
            prefix "nacm";

The normative reference shows:

        [NETCONF-ACM]
                   Bierman, A. and M. Bjorklund, "Network Configuration
                   Protocol (NETCONF) Access Control Model",RFC 6536 <https://tools.ietf.org/html/rfc6536>, March
                   2012

We have in fact two ietf-netconf-acm YANG modules
     One from RFC 6536
     One from [email-masked], 
draft-ietf-netconf-rfc6536bis-00.txt 
<http://datatracker.ietf.org/doc/draft-ietf-netconf-rfc6536bis>

Which one do you depend on? Do you want to use import by revision, or 
you want to use the future draft-ietf-netconf-rfc6536bis-00.txt 
<http://datatracker.ietf.org/doc/draft-ietf-netconf-rfc6536bis>?

Regards, Benoit
> Hi Benoit,
>
> This is the IETF key-chain model which is comprised of a lists of 
> symmetric keys that are used for applications such as routing protocol 
> authentication and encryption. The IETF keystore model is comprised of 
> lists of asymmetric keys and certificates that are used for 
> applications such as NETCONF authentication and encryption. The two 
> models are in no way dependent on one another.
>
> Thanks,
> Acee
>
> To: Acee Lindem <[email-masked] <mailto:[email-masked]>>, Jeff 
> Tantsura <[email-masked] <mailto:[email-masked]>>, 
> Routing WG <[email-masked] <mailto:[email-masked]>>
> <mailto:[email-masked]>>, 
> "[email-masked] <mailto:[email-masked]>" 
> <[email-masked] <mailto:[email-masked]>>, Kent 
> Watsen <[email-masked] <mailto:[email-masked]>>
>>     I support as a co-author. This IETF YANG model is currently
>>     referenced by a number or the other protocol models for
>>     specification of authentication keys including OSPF, IS-IS, RIP,
>>     and VRRP.
>     Copying the NETCONF chairs, to get the latest status, and to make
>     sure this NETCONF package progresses at the same pace.
>
>     Regards, Benoit
>>
>>     Thanks,
>>     Acee
>>         during the last IETF meeting and the authors have addressed
>>         all the comments from Directorate QA review.
>>
>>         of whether or not you are aware of any relevant IPR. The
>>         response needs to be sent to the RTGWG mailing list.
>>
>>         The document will not advance to the next stage until a
>>         response has been received from each author and each
>>
>>     [email-masked]://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 7 Feb 2017 18:13:23 +0000

Hi Benoit,

The extension we are using, “default-deny-all”, is available in either version of the model. The detriment of referencing the new version is that publication would delay until 6536BIS is published.

Thanks,
Acee

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 7, 2017 at 11:45 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Cc: rtgwg-chairs <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Kent Watsen <[email-masked]<mailto:[email-masked]>>, "Joe Clarke (jclarke)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain

Hi Acee,

Yes, I've been confused (more than once) by ietf-key-chain and ietf-key-store. Sorry.

   <CODE BEGINS> file "[email-masked]"<mailto:[email-masked]>
   module ietf-key-chain {
       namespace "urn:ietf:params:xml:ns:yang:ietf-key-chain";
       // replace with IANA namespace when assigned
       prefix "key-chain";
      import ietf-yang-types {
           prefix "yang";
       }

   [NETCONF-ACM]
              Bierman, A. and M. Bjorklund, "Network Configuration
              Protocol (NETCONF) Access Control Model", RFC 6536<https://tools.ietf.org/html/rfc6536>, March
              2012

We have in fact two ietf-netconf-acm YANG modules
    One from RFC 6536
    One from [email-masked]<mailto:[email-masked]>, draft-ietf-netconf-rfc6536bis-00.txt<http://datatracker.ietf.org/doc/draft-ietf-netconf-rfc6536bis>

Which one do you depend on? Do you want to use import by revision, or you want to use the future draft-ietf-netconf-rfc6536bis-00.txt<http://datatracker.ietf.org/doc/draft-ietf-netconf-rfc6536bis>?

Regards, Benoit
Hi Benoit,

Thanks,
Acee

Regards, Benoit

Thanks,
Acee

Dear RTGWG,

Thanks,
Jeff & Chris

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: Derek Yeung <[email-masked]>
Date: Tue, 7 Feb 2017 20:49:26 +0000

Support as a co-author. I am not aware of any IPR related to this draft.

Thanks,
Derek

From: Jeff Tantsura <[email-masked]>
Date: Monday, February 6, 2017 at 10:35 AM
To: RTGWG <[email-masked]>
Cc: rtgwg-chairs <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain
Resent-From: <[email-masked]>
Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
Resent-Date: Monday, February 6, 2017 at 10:35 AM

Dear RTGWG,

Thanks,
Jeff & Chris

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: "Xufeng Liu" <[email-masked]>
Date: Thu, 9 Feb 2017 09:31:44 -0500

Support.

Thanks,

- Xufeng

From: rtgwg [mailto:[email-masked]] On Behalf Of Jeff Tantsura
Sent: Monday, February 6, 2017 1:35 PM
To: RTGWG <[email-masked]>
Cc: rtgwg-chairs <[email-masked]>; [email-masked]
Subject: Re: Last Call for draft-ietf-rtgwg-yang-key-chain 

Dear RTGWG,

Thanks,

Jeff & Chris

From: Jeff Tantsura <[email-masked] <mailto:[email-masked]> >
Date: Friday, September 9, 2016 at 16:11
To: RTGWG <[email-masked] <mailto:[email-masked]> >
Cc: rtgwg-chairs <[email-masked] <mailto:[email-masked]> >, <[email-masked] <mailto:[email-masked]> >
Subject: Last Call for draft-ietf-rtgwg-yang-key-chain 

Dear RTGWG,

 

 

IPR:

 

Thanks,

Jeff & Chris

---

From: Ing-Wher Chen <[email-masked]>
Date: Mon, 13 Feb 2017 21:41:52 +0000

Support as a co-author.  I’m not aware of any IPR related to this draft.

Thanks,
helen

From: Jeff Tantsura [mailto:[email-masked]]

Dear RTGWG,

Thanks,
Jeff & Chris

Dear RTGWG,

IPR:

Thanks,
Jeff & Chris

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 16 Feb 2017 09:31:15 -0800

Dear RTGWG,

This concludes the WGLC for draft-ietf-rtgwg-yang-key-chain.

I’d like to thanks Yang-doctors for their thoughtful reviews and the authors for timely (pretty much immediate!) responses and updated draft! 

I’ll be done with the shepherd review in a day and will send the draft to the IESG for publication.

Cheers,

Jeff

Date: Monday, February 6, 2017 at 10:35

Dear RTGWG,

Thanks,

Jeff & Chris

Dear RTGWG,

 

 

IPR:

 

Thanks,

Jeff & Chris