Subject: QA review of draft-ietf-rtgwg-device-model-02

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 2 May 2017 22:21:48 +0000

Hello,

i've been selected as the QA reviewer for draft-ietf-rtgwg-device-model-02.

I believe the draft is well written and quite easy to understand, I just have some minor suggestion that might be help improving the readability (mostly for non subject experts).

-          Title: the title is not very clear, while the abstract explains very well in the first sentence what the goal of the draft is, what about changing it into: "A logical organization for network device YANG models" ?

-          Introduction: You are referencing an individual draft. This could be a block for the draft, but most of all does it make sense to have two separate drafts (in two different WGs), one to say the value of organizing YANG models  and the other one defining a logical organization for the models? (maybe too late for such change)

-          Introduction: this sentence is a bit confusing:

"  This document refers to two new modules that are expected to be  implemented.  These models are defined to support the configuration  and operation of network-devices that allow for the partitioning of  resources from both, or either, management and networking   perspectives.  Two forms of resource partitioning are referenced:"
                Maybe a modules/models mismatch? You start saying that the doc refers to two MODULES, then you say that MODELS are defined and the list two FORMS OF RESOURCE PARTITIONING.

-          Intro: "    Should structural-mount/YSDL not be available, the more explicit tree structure presented in earlier versions of this document will need to  be utilized." If it was described in previous versions of the document it is no longer available, or ?

-          Scope: as I got it while reading and as it is confirmed in the draft, the scope is "limited"  to physical and virtual switches and routers and not devices operating at the lower layers. Since you say "we consider network devices that support protocols  and functions defined within the IETF Routing Area" I would expect it to cover also lower layer devices.

-          Section 2: Section 2 and its subsection are very clear and explain well the concepts but it is not clear where the list comes from. It partially overlaps with the "overall structure" example above but at least having all of them in the overall structure plus some others (provided as example and not analyzed in the details with dedicated subsection ) would help.

BR
Daniele

---

From: Daniele Ceccarelli <[email-masked]>
Date: Tue, 2 May 2017 22:27:00 +0000

Resending with the right exploder.

BR
Daniele

From: Daniele Ceccarelli
Sent: mercoledì 3 maggio 2017 00:22
To: [email-masked]; [email-masked]
Cc: <[email-masked]> ([email-masked]) <[email-masked]>; [email-masked]; Jonathan Hardwick ([email-masked]) <[email-masked]>; Yemin (Amy) <[email-masked]>
Subject: QA review of draft-ietf-rtgwg-device-model-02

Hello,

BR
Daniele