Subject: WG last call for draft-ietf-rtgwg-uloop-delay

From: Chris Bowers <[email-masked]>
Date: Fri, 2 Jun 2017 20:43:09 +0000

RTGWG,

This email starts the two week WG last call for draft-ietf-rtgwg-uloop-delay.

https://datatracker.ietf.org/doc/draft-ietf-rtgwg-uloop-delay/

Please indicate support for or opposition to the publication of this
standards track document, along with the reasoning for that support or
opposition.

IPR:
If you are listed as a document author or contributor, please respond to
this email stating whether or not you are aware of any relevant IPR. The
response needs to be sent to the RTGWG mailing list. The document will
not advance to the next stage until a response has been received from
each author and each individual that has contributed to the document.

The document currently has the following IPR disclosure associated
with it.
https://datatracker.ietf.org/ipr/2565/

This last call will end on Friday June 16th.

Thanks,
Chris and Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 3 Jun 2017 23:04:35 +0000

I support advancement and publication of this draft.  I think we should have the discussion of whether or not it should be standards track, BCP, or informational as invariably this question will arise during all the reviews.
Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Chris Bowers <[email-masked]<mailto:[email-masked]>>
Date: Friday, June 2, 2017 at 4:43 PM
To: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

---

From: Chris Bowers <[email-masked]>
Date: Sun, 4 Jun 2017 16:47:32 +0000

As a WG participant, I think standards track makes most sense, since it specifies a precise behavior for a router under certain conditions.  It is likely that network operators and software implementers will want to use the document as a means of communicating about whether or not a given implementation supports that precise behavior.  In my opinion, a standards track document is the best format to support that interaction.

Chris

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Saturday, June 3, 2017 6:05 PM
To: Chris Bowers <[email-masked]>; RTGWG <[email-masked]>
Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 5 Jun 2017 10:36:45 +0100

In section 3 it states:

    This ordered convergence, is similar to the ordered FIB proposed
    defined in [RFC6976], but limited to only a "one hop" distance.  As a
    consequence, it is simpler and becomes a local only feature not
    requiring interoperability; at the cost of only covering the
    transient forwarding loops involving this local router.

Thus this mechanism is a private matter to the PLR and therefore does 
not introduce a requirement for multiple routers to co-operate, it seems 
like it ought to be informational.

- Stewart

On 04/06/2017 00:04, Acee Lindem (acee) wrote:
> I support advancement and publication of this draft.  I think we 
> should have the discussion of whether or not it should be standards 
> track, BCP, or informational as invariably this question will arise 
> during all the reviews.
> Thanks,
> Acee
>
> From: rtgwg <[email-masked] <mailto:[email-masked]>> 
> on behalf of Chris Bowers <[email-masked] 
> <mailto:[email-masked]>>
> To: Routing WG <[email-masked] <mailto:[email-masked]>>
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 5 Jun 2017 10:47:48 +0100

Hi Chris

An RFC is surely sufficient to specify the behaviour of the router, and 
communicate to others the capability of a product.

If multiple routers needed to act identically across the network I could 
see ST as better, but this is really a single router feature.

- Stewart

On 04/06/2017 17:47, Chris Bowers wrote:
>
> As a WG participant, I think standards track makes most sense, since 
> it specifies a precise behavior for a router under certain 
> conditions.  It is likely that network operators and software 
> implementers will want to use the document as a means of communicating 
> about whether or not a given implementation supports that precise 
> behavior.  In my opinion, a standards track document is the best 
> format to support that interaction.
>
> Chris
>
> *From:*Acee Lindem (acee) [mailto:[email-masked]]
> *Sent:* Saturday, June 3, 2017 6:05 PM
> *To:* Chris Bowers <[email-masked]>; RTGWG <[email-masked]>
> *Subject:* Re: WG last call for draft-ietf-rtgwg-uloop-delay
>
> *From: *rtgwg <[email-masked] <mailto:[email-masked]>> 
> *Date: *Friday, June 2, 2017 at 4:43 PM
> *To: *Routing WG <[email-masked] <mailto:[email-masked]>>
> *Subject: *WG last call for draft-ietf-rtgwg-uloop-delay
>
>     RTGWG,
>

---

From: Chris Bowers <[email-masked]>
Date: Mon, 5 Jun 2017 15:22:59 +0000

Stewart,

It seems to me that this document is not qualitatively different from the LFA, RLFA, and
node-protecting LFA RFCs which were all published as standards track.  The behavior of the PLR
in those documents is also a local matter, and in principle can be deployed on a single router without
the knowledge of the rest of the network (except for allowing establishment of targeted LDP
sessions in the case of remote LFA).

Publishing this draft as standards track seems to be consistent with the decision made on those drafts.

Chris

From: Stewart Bryant [mailto:[email-masked]]
Sent: Monday, June 5, 2017 4:48 AM
To: Chris Bowers <[email-masked]>; Acee Lindem (acee) <[email-masked]>; RTGWG <[email-masked]>
Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

Hi Chris

An RFC is surely sufficient to specify the behaviour of the router, and communicate to others the capability of a product.

If multiple routers needed to act identically across the network I could see ST as better, but this is really a single router feature.

- Stewart

Chris

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Saturday, June 3, 2017 6:05 PM
To: Chris Bowers <[email-masked]><mailto:[email-masked]>; RTGWG <[email-masked]><mailto:[email-masked]>
Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

rtgwg mailing list

[email-masked]<mailto:[email-masked]>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 5 Jun 2017 16:34:14 +0100

I will accept whatever the consensus is.

- Stewart

On 05/06/2017 16:22, Chris Bowers wrote:
> *From:*Stewart Bryant [mailto:[email-masked]]
> *Sent:* Monday, June 5, 2017 4:48 AM
> *To:* Chris Bowers <[email-masked]>; Acee Lindem (acee) 
> <[email-masked]>; RTGWG <[email-masked]>
> An RFC is surely sufficient to specify the behaviour of the router, 
> and communicate to others the capability of a product.
>
> If multiple routers needed to act identically across the network I 
> could see ST as better, but this is really a single router feature.
>
> - Stewart
>
>     As a WG participant, I think standards track makes most sense,
>     since it specifies a precise behavior for a router under certain
>     implementers will want to use the document as a means of
>     communicating about whether or not a given implementation supports
>     that precise behavior.  In my opinion, a standards track document
>     is the best format to support that interaction.
>
>     Chris
>
>     *To:* Chris Bowers <[email-masked]>
>     <mailto:[email-masked]>; RTGWG <[email-masked]>
>     <mailto:[email-masked]>
>     should have the discussion of whether or not it should be
>     standards track, BCP, or informational as invariably this question
>     will arise during all the reviews.
>
>     Thanks,
>
>     Acee
>
>     *From: *rtgwg <[email-masked]
>     <mailto:[email-masked]>> on behalf of Chris Bowers
>     <[email-masked] <mailto:[email-masked]>>
>     [email-masked] <mailto:[email-masked]>
>

---

From: <[email-masked]>
Date: Tue, 6 Jun 2017 06:52:42 +0000

Support as author

From: rtgwg [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: Friday, June 02, 2017 22:43
To: RTGWG
Subject: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Tue, 6 Jun 2017 09:14:26 +0000

Hi Chris,

I'm not aware of non-disclosed IPR.

Regards,
--Bruno

From: rtgwg [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: Friday, June 02, 2017 10:43 PM
To: RTGWG
Subject: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

---

From: <[email-masked]>
Date: Tue, 6 Jun 2017 09:32:25 +0000

From: rtgwg [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Monday, June 05, 2017 11:37 AM
To: [email-masked]
Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

In section 3 it states:

Thus this mechanism is a private matter to the PLR and therefore does not introduce a requirement for multiple routers to co-operate, it seems like it ought to be informational.

[Bruno] It seems to me that LFA and remote LFA are also a local behavior. They both are a STD track document so I don’t find that argument compelling.

--Bruno

- Stewart

RTGWG,

IPR:

Thanks,
Chris and Jeff

rtgwg mailing list

---

From: <[email-masked]>
Date: Tue, 6 Jun 2017 09:47:46 +0000

I agree with Chris.
In addition, this document is likely/may be referenced by RFC defining FRR solutions. Having it STD track would avoid downward normative references.

--Bruno

From: rtgwg [mailto:[email-masked]] On Behalf Of Chris Bowers
Sent: Sunday, June 04, 2017 6:48 PM
To: Acee Lindem (acee); RTGWG
Subject: RE: WG last call for draft-ietf-rtgwg-uloop-delay

Chris

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Saturday, June 3, 2017 6:05 PM
To: Chris Bowers <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>
Subject: Re: WG last call for draft-ietf-rtgwg-uloop-delay

RTGWG,

IPR:

Thanks,
Chris and Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 6 Jun 2017 11:10:58 +0000

This is fine with me as well. I simply anticipated this being a point of discussion.
Thanks,
Acee

From: Bruno Decraene <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, June 6, 2017 at 5:47 AM
To: Chris Bowers <[email-masked]<mailto:[email-masked]>>, Acee Lindem <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: WG last call for draft-ietf-rtgwg-uloop-delay

I agree with Chris.

--Bruno

Chris

RTGWG,

IPR:

Thanks,
Chris and Jeff

---

From: <[email-masked]>
Date: Tue, 6 Jun 2017 12:36:35 +0000

In addition, I'm not aware of any non disclosed IPR.

From: rtgwg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, June 06, 2017 08:53
To: Chris Bowers; RTGWG
Subject: RE: WG last call for draft-ietf-rtgwg-uloop-delay

Support as author

RTGWG,

IPR:

Thanks,
Chris and Jeff

Thank you.