Subject: RE: Protecting SR policy midpoints (draft-bashandy-rtgwg-segment-routing-ti-lfa)

From: Huzhibo <[email-masked]>
Date: Thu, 23 Nov 2017 13:15:45 +0000

Because the normal FRR can not protect the designated node of SR-TE, a method is provided to perform the label POP action by the penultimate hop of the specified node replacing the specified node and forward it to the node corresponding to the next label. However, Here are some questions we can discuss, if it is a loose path, SR-TE designated node failure, the packet can not be forwarded to the penultimate hop of the specified node.

发件人: rtgwg [mailto:[email-masked]] 代表 Muthu Arul Mozhi Perumal
发送时间: 2017年11月23日 21:04
收件人: [email-masked]
抄送: [email-masked]
主题: Re: Protecting SR policy midpoints (draft-bashandy-rtgwg-segment-routing-ti-lfa)

My understanding is that draft wants to provide a solution for the problem where the active segment is a prefix/adjacency segment of the neighbor and the neighbor fails. A solution to this is possible only at a node that is enforcing the SR policy (consisting of the segment list). For a transit node, its data plane would have to peek into the label stack and determine the type of the segment/label following the active segment and act accordingly, which is not inline with the SR architecture which requires SR to work 'as is' on traditional MPLS data plane

​Muthu​

On Wed, Nov 22, 2017 at 8:22 PM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:
Muthu and all,
I do not see how the draft in quesrion us related to "SR Policy".

From my POV its scope is a SR LSP comprised of multiple Node SIDs within a single IGP domain, and it provides local fast protection against failure of a node that terminates one of the segments comprising this LSP. Pritection action is performed by the penultimate node.

My 2c.
Sent from Yahoo Mail on Android<https://overview.mail.yahoo.com/mobile/?.src=Android>

On Wed, Nov 22, 2017 at 3:27, Muthu Arul Mozhi Perumal
<[email-masked]<mailto:[email-masked]>> wrote:
Section 5.3 of draft-bashandy-rtgwg-segment-routing-ti-lfa describes protecting SR policy midpoints against node failure for the case where the active segment is the prefix or adjacency segment of a neighbor.

I believe the steps described in the procedure is applicable only for a node steering packets into the SR policy. This could be an ingress PE steering IP packets into a SR-TE tunnel or an intermediate node steering labeled packets received with a BSID into a SR-TE tunnel identified by that BSID.

A transit node that has no idea about the SR policy itself is not expected to perform the procedure described in that section.

Is my understanding correct?

Regards,
Muthu
_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Ahmed Bashandy (bashandy)" <[email-masked]>
Date: Tue, 28 Nov 2017 06:38:02 -0800

I do not understand the question

Ahmed

On 11/23/2017 5:15 AM, Huzhibo wrote:
>
> Because the normal FRR can not protect the designated node of SR-TE, a 
> method is provided to perform the label POP action by the penultimate 
> hop of the specified node replacing the specified node and forward it 
> to the node corresponding to the next label. However, Here are some 
> questions we can discuss, if it is a loose path, SR-TE designated node 
> failure, the packet can not be forwarded to the penultimate hop of the 
> specified node.
>
> *? ??:*rtgwg [mailto:[email-masked]] *? ? *Muthu Arul Mozhi 
> Perumal
> *? ???:*2017?11?23?21:04
> *???:[email-masked]
> *??:[email-masked]
> *??:*Re: Protecting SR policy midpoints 
> (draft-bashandy-rtgwg-segment-routing-ti-lfa)
>
> My understanding is that draft wants to provide a solution for the 
> problem where the active segment is a prefix/adjacency segment of the 
> neighbor and the neighbor fails. A solution to this is possible only 
> at a node that is enforcing the SR policy (consisting of the segment 
> list). For a transit node, its data plane would have to peek into the 
> label stack and determine the type of the segment/label following the 
> active segment and act accordingly, which is not inline with the SR 
> architecture which requires SR to work 'as is' on traditional MPLS 
> data plane
>
> Muthu
>
> On Wed, Nov 22, 2017 at 8:22 PM, Alexander Vainshtein 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Muthu and all,
>
>     From my POV its scope is a SR LSP comprised of multiple Node SIDs
>     within a single IGP domain, and it provides local fast protection
>     against failure of a node that terminates one of the segments
>     comprising this LSP. Pritection action is performed by the
>     penultimate node.
>
>     My 2c.
>
>     Sent from Yahoo Mail on Android
>     <https://overview.mail.yahoo.com/mobile/?.src=Android>
>
>         <[email-masked] <mailto:[email-masked]>> wrote:
>
>         Section 5.3 of draft-bashandy-rtgwg-segment-routing-ti-lfa
>         describes protecting SR policy midpoints against node failure
>         for the case where the active segment is the prefix or
>         adjacency segment of a neighbor.
>
>         I believe the steps described in the procedure is applicable
>         only for a node steering packets into the SR policy. This
>         could be an ingress PE steering IP packets into a SR-TE tunnel
>         or an intermediate node steering labeled packets received with
>         a BSID into a SR-TE tunnel identified by that BSID.
>
>         A transit node that has no idea about the SR policy itself is
>         not expected to perform the procedure described in that section.
>
>         [email-masked] <mailto:[email-masked]>
> [email-masked]