Subject: Numbering Exchange Protocol (NEP) ID.

From: Khaled Omar <[email-masked]>
Date: Fri, 8 Dec 2017 16:01:28 +0000

Hi everyone,

Below is one of the IDs that I uploaded to the IETF and looking for discussing it with the appropriate people and the appropriate area of discussion.

https://datatracker.ietf.org/doc/draft-omar-nep/

I tried to make it not so long so it can be read quickly and still clear for everyone.

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Sat, 9 Dec 2017 19:32:46 +0000

Hi everyone,

Please let me have the opportunity to ask all of you to reserve some time in your agenda for the discussion of NEP and give it a priority on the kist of your discussion as it will not take long time looking for something more to add.

I have confidence that this ID has more to add but the contents is just the start of the new protocol.

I hope I'm not bothering you by my question but I'm sure everyone of you has something on mind to add to make the ID take the best shape and please do not be afraid of posting any comment regarding the contents of the 2nd version of the I-D.

This long e-mail is to encourage you to participate and I'm sure the discussion will be exciting and please do not understand as i'm pushing you to participate, eventually it is up to you.

P.S. After finding the appropriate area or wg for the discussion I will stop sending e-mails to the ietf mailing list.

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]
CC: [email-masked]

Hi everyone,

Regards,

Khaled Omar

---

From: Christopher Morrow <[email-masked]>
Date: Sat, 9 Dec 2017 12:14:46 -0800

what problem were you trying to solve?

On Sat, Dec 9, 2017 at 11:32 AM, Khaled Omar <[email-masked]>
wrote:

> Hi everyone,
>
> Please let me have the opportunity to ask all of you to reserve some time
> in your agenda for the discussion of NEP and give it a priority on the kist
> of your discussion as it will not take long time looking for something more
> to add.
>
> I hope I'm not bothering you by my question but I'm sure everyone of you
> has something on mind to add to make the ID take the best shape and please
> do not be afraid of posting any comment regarding the contents of the 2nd
> version of the I-D.
>
> This long e-mail is to encourage you to participate and I'm sure the
> discussion will be exciting and please do not understand as i'm pushing you
> to participate, eventually it is up to you.
>
> P.S. After finding the appropriate area or wg for the discussion I will
> stop sending e-mails to the ietf mailing list.
>
> Thanks,
>
> Khaled Omar
>
>
> Below is one of the IDs that I uploaded to the IETF and looking for
> discussing it with the appropriate people and the appropriate area of
> discussion.
>
>
>
> *Regards,*
> *Khaled Omar*

---

From: Khaled Omar <[email-masked]>
Date: Sat, 9 Dec 2017 20:40:20 +0000

Hi Christopher,

The problem is how to choose the best route based on the metric.

RIP uses only the number of hops.
OSPF uses only the cost (bandwidth).
EIGRP uses the least bandwidth and total delay.
IS-IS uses a default metric of 10 for all links.
NEP uses the total bandwidth, total delay, and the number of hops.

So, the challenge is to find the best metric that will chose the best route.

The ID lists the equation of how to calculate the metric.

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked],ietf

On Sat, Dec 9, 2017 at 11:32 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 9 Dec 2017 22:44:00 +0000

Khaled,

The existing IGPs will allow for alternate metrics, we don’t need a new protocol. In fact, it will be supported at the per-prefix granularity.

https://datatracker.ietf.org/doc/draft-hegdeppsenak-isis-sr-flex-algo/

No time in my agenda for NEP…

Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Khaled Omar <[email-masked]<mailto:[email-masked]>>
Date: Saturday, December 9, 2017 at 3:40 PM
To: Christopher Morrow <[email-masked]<mailto:[email-masked]>>
Cc: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Sat, 9 Dec 2017 23:03:18 +0000

Hi Acee,

The NEP metric is unique, there is no other protocol uses this composite metric, the link in your e-mail has no metric as I read, also it is newer than NEP as I wrote the ID before this suggested protocol, hope the copyright is protected.

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: "Acee Lindem (acee)"
To: Khaled Omar ,Christopher Morrow
CC: rtgwg

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 9 Dec 2017 23:17:07 +0000

From: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Date: Saturday, December 9, 2017 at 6:03 PM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Christopher Morrow <[email-masked]<mailto:[email-masked]>>
Cc: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Hi Acee,

Any composite metric can be used – it doesn’t even need to be standardized.

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Sat, 9 Dec 2017 23:27:29 +0000

Acee,

What are the elments of the metric? Is it like NEP?

-------- Original Message --------

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: Luis Balbinot <[email-masked]>
Date: Sun, 10 Dec 2017 22:17:59 -0200

Yeah, these are not the people you are looking for. Talk to operators, they
will let you know how IGP metrics are useless in today's networks, even the
enhanced metrics you are proposing.

You must take into consideration that almost all traffic engineering on
large networks is actually done using other protocols, even with external
controllers nowadays. These external controllers have much more knowledge
about the network and running applications than the network nodes do. IGP
metrics are informational at best.

Luis

On Dec 8, 2017 14:02, "Khaled Omar" <[email-masked]> wrote:

> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>
>

---

From: Khaled Omar <[email-masked]>
Date: Mon, 11 Dec 2017 08:23:02 +0000

> Yeah, these are not the people you are looking for. Talk to operators, they will let you know how IGP metrics are useless in today's networks, even the enhanced metrics you are proposing.

So what is the replacement for IGP metric if they are useless?

You mentioned as well other protocols, will be great to know more about these protocols.

Khaled

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Luis Balbinot
To: Khaled Omar
CC: [email-masked]

Yeah, these are not the people you are looking for. Talk to operators, they will let you know how IGP metrics are useless in today's networks, even the enhanced metrics you are proposing.

You must take into consideration that almost all traffic engineering on large networks is actually done using other protocols, even with external controllers nowadays. These external controllers have much more knowledge about the network and running applications than the network nodes do. IGP metrics are informational at best.

Luis

On Dec 8, 2017 14:02, "Khaled Omar" <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,

Regards,

Khaled Omar

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Raymond Burkholder <[email-masked]>
Date: Mon, 11 Dec 2017 21:58:58 -0400

On 12/11/2017 04:23 AM, Khaled Omar wrote:
>  > Yeah, these are not the people you are looking for. Talk to 
> operators, they will let you know how IGP metrics are useless in today's 
> networks, even the enhanced metrics you are proposing.
> 

It isn't necessarily protocols any more.  It has more to do with how 
calculations are made.  They are starting to be made in centrally 
controlled distributed fashion (if that makes sense).  Look at min/max 
linear optimizations as a start where individual nodes make flow 
decisions based upon capacity available and bandwidth available not only 
locally, but on the path(s) towards the destination.  And the 
calculations may be made on a per flow or flow batch mechanism.

Shortest path may no longer win, but the path established locally based 
upon global parameters provided by neighbors as well as a central authority.

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: Khaled Omar <[email-masked]>
Date: Tue, 12 Dec 2017 12:14:04 +0000

> Shortest path may no longer win, but the path established locally based upon global parameters provided by neighbors as well as a central authority.

NEP does not uses the shortest path, it learns full topology information and then decide which route (path) is the best at the moment based on the total route bandwidth, total route delay, and the no. of hops, there is no need for other protocols or a central authority. 

Best regards,

Khaled Omar

-----Original Message-----
From: rtgwg [mailto:[email-masked]] On Behalf Of Raymond Burkholder
Sent: Tuesday, December 12, 2017 3:59 AM
To: [email-masked]
Subject: Re: Numbering Exchange Protocol (NEP) ID.

On 12/11/2017 04:23 AM, Khaled Omar wrote:
> operators, they will let you know how IGP metrics are useless in 
> today's networks, even the enhanced metrics you are proposing.
> 

It isn't necessarily protocols any more.  It has more to do with how calculations are made.  They are starting to be made in centrally controlled distributed fashion (if that makes sense).  Look at min/max linear optimizations as a start where individual nodes make flow decisions based upon capacity available and bandwidth available not only locally, but on the path(s) towards the destination.  And the calculations may be made on a per flow or flow batch mechanism.

Shortest path may no longer win, but the path established locally based upon global parameters provided by neighbors as well as a central authority.

--
This message has been scanned for viruses and dangerous content by MailScanner, and is believed to be clean.

---

From: "Raymond Burkholder" <[email-masked]>
Date: Tue, 12 Dec 2017 08:36:48 -0400

> NEP does not uses the shortest path, it learns full topology information
and
> then decide which route (path) is the best at the moment based on the
total
> route bandwidth, total route delay, and the no. of hops, there is no need
for
> other protocols or a central authority.
> 

Hmm, sounds like the 'bees knees', as some else mentioned elsewhere, not too
long ago.

Sorry, I missed seeing the documentation on the algorithm.  

I am new to finding my way around.  Where would I be able to find the latest
notes and information on how this works?

---

From: Khaled Omar <[email-masked]>
Date: Tue, 12 Dec 2017 12:59:56 +0000

> Where would I be able to find the latest notes and information on how this works?

You can find the latest version of NEP through the following link:

It is not too long ID, but the information is clear.

Khaled

-----Original Message-----
From: rtgwg [mailto:[email-masked]] On Behalf Of Raymond Burkholder
Sent: Tuesday, December 12, 2017 2:37 PM
To: [email-masked]
Subject: RE: Numbering Exchange Protocol (NEP) ID.

and
total
for
> other protocols or a central authority.

Hmm, sounds like the 'bees knees', as some else mentioned elsewhere, not too long ago.

I am new to finding my way around.  Where would I be able to find the latest notes and information on how this works?

---

From: Khaled Omar <[email-masked]>
Date: Thu, 14 Dec 2017 15:22:01 +0000

Acee,

Every working IGP has its own way of metric calculations, they cannot be variables based on the network, the most important is that how many factors can affect choosing the best route simultaneously.

I encourage more participation to work on NEP as there is more to add.

Best Regards,

K. O.

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Sunday, December 10, 2017 1:17 AM
To: Khaled Omar; Christopher Morrow
Cc: rtgwg
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 14 Dec 2017 15:27:38 +0000

From: Khaled Omar <[email-masked]<mailto:[email-masked]>>
Date: Thursday, December 14, 2017 at 10:22 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>
Cc: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: Numbering Exchange Protocol (NEP) ID.

Acee,

Every working IGP has its own way of metric calculations, they cannot be variables based on the network,

Please read https://www.ietf.org/id/draft-hegdeppsenak-isis-sr-flex-algo-01.txt. There will be similar extensions to OSPF.

the most important is that how many factors can affect choosing the best route simultaneously.

If you read the above draft, you will see that these are covered.

Thanks,
Acee

Best Regards,

K. O.

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Thu, 14 Dec 2017 15:32:38 +0000

> If you read the above draft, you will see that these are covered.

I read it earlier and found no specific equation of metric calculations.

You can tell me what are those factors and we can compare it to NEP as I’m sure that NEP metric calculation is unique since it was developed.

Thanks,

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Thursday, December 14, 2017 5:28 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Acee,

Thanks,
Acee

Best Regards,

K. O.

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 14 Dec 2017 15:37:02 +0000

Date: Thursday, December 14, 2017 at 10:32 AM

As I stated earlier, the draft supports any metric calculation – even routing domain specific ones.

Acee

Thanks,

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Thursday, December 14, 2017 5:28 PM
To: Khaled Omar
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Acee,

Thanks,
Acee

Best Regards,

K. O.

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Thu, 14 Dec 2017 15:41:27 +0000

> As I stated earlier, the draft supports any metric calculation – even routing domain specific ones.

Hmm, sounds like it is a magical draft, support any metric including NEP as well.

Khaled

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Thursday, December 14, 2017 5:37 PM
To: Khaled Omar
Cc: [email-masked]
Subject: Re: Numbering Exchange Protocol (NEP) ID.

Acee

Thanks,

Acee,

Thanks,
Acee

Best Regards,

K. O.

Hi Acee,

Thanks,
Acee

-------- Original Message --------

Khaled,

Thanks,
Acee

Hi Christopher,

-------- Original Message --------
Subject: Re: Numbering Exchange Protocol (NEP) ID.
From: Christopher Morrow
To: Khaled Omar
CC: [email-masked]<mailto:[email-masked]>,ietf

Thanks,

Khaled Omar

-------- Original Message --------
Subject: Numbering Exchange Protocol (NEP) ID.
From: Khaled Omar
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>

Hi everyone,

Regards,

Khaled Omar