Subject: Benoit Claise's No Objection on draft-ietf-rtgwg-yang-vrrp-08: (with COMMENT)

From: Benoit Claise <[email-masked]>
Date: Tue, 09 Jan 2018 00:35:12 -0800

Benoit Claise has entered the following ballot position for
draft-ietf-rtgwg-yang-vrrp-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-yang-vrrp/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

- I support Kathleen's DISCUSS.

- I like the way sections 2.2 and 2.3 are constructed. Thanks.
In section 2.4 that's a pity that we don't see which per instance oper states
and stats are available.

         +--ro <per instance operational states>
            +--ro statistics
               +--ro <per instance statistics>

I have to refer to an appendix to find the answer
https://tools.ietf.org/html/draft-ietf-rtgwg-yang-vrrp-08#appendix-A Why don't
you have the full tree as from the appendix in 2.X?

- No need to include the WG chairs in the YANG module, as per 6087bis

        WG Chair: Jeff Tantsura
                  <mailto:[email-masked]>

        WG Chair: Chris Bowers
                  <mailto:[email-masked]>

- The following two references must point to the working group documents

   [I-D.bjorklund-netmod-rfc7223bis]
              Bjorklund, M., "A YANG Data Model for Interface
              Management", draft-bjorklund-netmod-rfc7223bis-00 (work in
              progress), August 2017.

   [I-D.bjorklund-netmod-rfc7277bis]
              Bjorklund, M., "A YANG Data Model for IP Management",
              draft-bjorklund-netmod-rfc7277bis-00 (work in progress),
              August 2017.

- Thanks for the appendix B. It's always useful.
Note: I have not validated the instance.

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 10 Jan 2018 15:45:46 +0000

Hi Benoit,

Thanks for the comments. We have updated the document to address these comments, in a new revision https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-yang-vrrp-09. Please check if this is ok.

Regards,
- Xufeng

> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Tuesday, January 9, 2018 3:35 AM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Yingzhen Qu
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Benoit Claise's No Objection on draft-ietf-rtgwg-yang-vrrp-08: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> In section 2.4 that's a pity that we don't see which per instance oper states and
> stats are available.
>

---

From: Benoit Claise <[email-masked]>
Date: Wed, 10 Jan 2018 17:01:40 +0100

Thank you Xufeng,

Just one comment left:

I have to refer to an appendix to find the answerhttps://tools.ietf.org/html/draft-ietf-rtgwg-yang-vrrp-08#appendix-A
Why don't you have the full tree from the appendix in a new section 2.X?

Anyway, this is a comment, so up to the responsible AD to decide.

Regards, Benoit