Subject: Fwd: New Version Notification for draft-sun-opsawg-sdwan-service-model-01.txt

From: "Wubo (lana)" <[email-masked]>
Date: Mon, 22 Oct 2018 09:09:58 +0000

Dear all,

We would like to define a CE-based VPN service model to differentiate from PE-based L3&L2 service model. The link is at https://tools.ietf.org/html/draft-sun-opsawg-sdwan-service-model-01

Since we feel the SD-WAN related work in IETF, like https://tools.ietf.org/html/draft-dukes-spring-sr-for-sdwan-00, https://tools.ietf.org/html/draft-rosen-bess-secure-l3vpn-01,
https://tools.ietf.org/html/draft-ietf-i2nsf-sdn-ipsec-flow-protection-02, are all enhanced CE-based VPN. But there is no consistent SD-WAN or CE-based VPN service definition.
In the drafts, each assumes a different SD-WAN functionality of CE, like hybrid WAN and L3-L7 flow classification in SR for sdwan draft, and L3 virtual network separation inside IPSEC VPN 
In secure L3VPN draft.

So, in this draft, based on our understanding of SD-WAN service and together with other SD-WAN draft, we define the SD-WAN main service components and hope that this will help
clarifying the main service feature of SD-WAN and  helping to automate the service management.

We'd like to solicit more comments on whether this service model meets your thought of the SD-WAN service.

Thanks,

 Bo, on behalf of the co-authors

> -----邮件原件-----
> 发件人: [email-masked] [mailto:internet-
> [email-masked]]
> 发送时间: 2018年10月22日 15:53
> 收件人: Qin Wu <[email-masked]>; Honglei Xu
> <[email-masked]>; Wubo (lana)
> <[email-masked]>; Qiong Sun
> <[email-masked]>; Wubo (lana)
> <[email-masked]>
> 主题: New Version Notification for draft-sun-opsawg-
> sdwan-service-model-01.txt
> 
> 
> A new version of I-D, draft-sun-opsawg-sdwan-service-
> model-01.txt
> has been successfully submitted by Bo Wu and posted to
> the IETF repository.
> 
> Name:		draft-sun-opsawg-sdwan-service-model
> Revision:	01
> Title:		A YANG Data Model for SD-WAN VPN
> Service Delivery
> Document date:	2018-10-21
> Group:		Individual Submission
> Pages:		40
> URL:            https://www.ietf.org/internet-drafts/draft-sun-
> opsawg-sdwan-service-model-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-sun-
> opsawg-sdwan-service-model/
> Htmlized:       https://tools.ietf.org/html/draft-sun-opsawg-
> sdwan-service-model-01
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-
> sun-opsawg-sdwan-service-model
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-sun-
> opsawg-sdwan-service-model-01
> 
> Abstract:
>    This document defines a SD-WAN VPN service model to
> enable a Service
>    Provider to deliver SD-WAN VPN services to its customers
> by
>    provisioning the CE devices on behalf of the customer.
> This document
>    is based on provider-provisioned CE-based VPNs as
> described in
>    [RFC4110].
> 
>    This model provides an abstracted view of the SD-WAN
> VPN service
>    configuration components, and is intended to be
> instantiated at the
>    management system to deliver the overall service.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the
> time of submission until the htmlized version and diff are
> available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: <[email-masked]>
Date: Wed, 31 Oct 2018 13:58:37 +0800

Dear All,

We are going to provide SD-WAN related service in our network. For this draft, we have updated to include L3 & L2 service model for CE-based VPN service model. This service is different with PE-based L3&L2 service model. And we are also trying to implement the SD-WAN service model in ONAP platform. 

Hope to get more comments on whether this service model meets your thought of the SD-WAN service.

Thanks a lot!

Best wishes
Qiong Sun from China Telecom

-----邮件原件-----
发件人: Wubo (lana) <[email-masked]> 
发送时间: 2018年10月22日 17:10
收件人: [email-masked]; [email-masked]
抄送: Qin Wu <[email-masked]>; Honglei Xu <[email-masked]>; Qiong Sun <[email-masked]>
主题: Fwd: New Version Notification for draft-sun-opsawg-sdwan-service-model-01.txt

Dear all,

Since we feel the SD-WAN related work in IETF, like https://tools.ietf.org/html/draft-dukes-spring-sr-for-sdwan-00, https://tools.ietf.org/html/draft-rosen-bess-secure-l3vpn-01,
https://tools.ietf.org/html/draft-ietf-i2nsf-sdn-ipsec-flow-protection-02, are all enhanced CE-based VPN. But there is no consistent SD-WAN or CE-based VPN service definition.
In the drafts, each assumes a different SD-WAN functionality of CE, like hybrid WAN and L3-L7 flow classification in SR for sdwan draft, and L3 virtual network separation inside IPSEC VPN In secure L3VPN draft.

So, in this draft, based on our understanding of SD-WAN service and together with other SD-WAN draft, we define the SD-WAN main service components and hope that this will help clarifying the main service feature of SD-WAN and  helping to automate the service management.

Thanks,

> -----邮件原件-----
> 发件人: [email-masked] [mailto:internet- [email-masked]]
> 发送时间: 2018年10月22日 15:53
> <[email-masked]>; Wubo (lana) <[email-masked]>; 
> Qiong Sun <[email-masked]>; Wubo (lana) 
> <[email-masked]>
> A new version of I-D, draft-sun-opsawg-sdwan-service- model-01.txt has 
> been successfully submitted by Bo Wu and posted to the IETF 
> repository.
> 
>    This document defines a SD-WAN VPN service model to enable a 
> Service
>    Provider to deliver SD-WAN VPN services to its customers by
>    is based on provider-provisioned CE-based VPNs as described in
>    [RFC4110].
> 
>    This model provides an abstracted view of the SD-WAN VPN service
>    configuration components, and is intended to be instantiated at the
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
> 
> The IETF Secretariat