Subject: quick question on draft-ietf-rtgwg-net2cloud-problem-statement-00

From: Alia Atlas <[email-masked]>
Date: Sun, 2 Jun 2019 16:59:18 -0400

Hi Linda, Andy, Christian, and Mehmet,

I finally took a quick read through both the problem-statement and
gap-analysis drafts
for net2cloud.  The problem-statement one is very clear and well-written.

I do have a quick question about this bullet point.

" - Many cloud DCs use an overlay to connect their gateways to the
        workloads located inside the DC. There has not been any
        standard to address the interworking between the Cloud Overlay
        and the enterprise' existing underlay networks."

Can you clarify what need you see for the interworking?  Currently, BGP is
just
used for exchanging routes and liveness.  I didn't see anything
specifically called out.

The drafts also touch only briefly on the direct interconnect.  Is that
because you see the connectivity provided by the MPLS VPN provider to be a
better fit into the SD-WAN use-case?

Regards,
Alia

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 3 Jun 2019 15:52:08 +0000

Alia,

Thank you very much for reviewing the draft. Answers to your questions are inserted below:

From: Alia Atlas <[email-masked]>
Sent: Sunday, June 02, 2019 3:59 PM
To: Andrew G. Malis <[email-masked]>; Linda Dunbar <[email-masked]>; JACQUENET Christian IMT/OLN <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: quick question on draft-ietf-rtgwg-net2cloud-problem-statement-00

I finally took a quick read through both the problem-statement and gap-analysis drafts
for net2cloud.  The problem-statement one is very clear and well-written.
[Linda] Thank you.
I do have a quick question about this bullet point.

Can you clarify what need you see for the interworking?  Currently, BGP is just
used for exchanging routes and liveness.  I didn't see anything specifically called out.
[Linda] https://tools.ietf.org/html/draft-dunbar-idr-sdwan-port-safi-01 identifies one extension needed. As the overlay network have WAN ports facing the 3rd party networks (ISPs), its WAN ports properties need to be propagated to its authorized peers via the secure channel between the overlay edge nodes and the Controller, instead of directly among each other.

The drafts also touch only briefly on the direct interconnect.  Is that because you see the connectivity provided by the MPLS VPN provider to be a better fit into the SD-WAN use-case?
[Linda] For many of our SD-WAN deployment, the overlay edge nodes (most likely virtual ones) in Cloud DC are connected to On-Prem data centers via multiple connections: Direct Connect & Overlay. It is necessary for BGP to manage both.

Regards,
Alia