Subject: RE: A new draft on APN for your review, thank you!

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Wed, 20 Jan 2021 06:17:56 +0000

Dear all,

In the MEF 70 “SD-WAN Service Attribute and Services”, Table 4 on Page 36 has defined the fields (from layer 2 through layer 4) which are expected to be able to match against ingress IP Packets. APPID is explicitly listed as a criterion.

“The APPID Policy Criterion provides the ability for the Service Provider to define and name both simple and complex matches. These can include standard matches available to all of the Service Provider’s Subscribers from a catalog and/or custom matches developed by the Service Provider by agreement with a particular Subscriber.”

https://www.mef.net/wp-content/uploads/2019/07/MEF-70.pdf

Is there anybody who knows more about the details about this criterion and its implementations of the catalog and the interactions? How does the standard match and the custom match work in the real system? What are the key elements in the system? How do they interact?

Many thanks!

Best regards,
Shuping

From: Pengshuping (Peng Shuping)
Sent: Tuesday, December 15, 2020 11:12 AM
To: [email-masked]; [email-masked]
Subject: A new draft on APN for your review, thank you!

Dear all,

A new draft on APN has been posted, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis.

In this draft, we clarified the scope of the APN work in IETF, introduced an example use case and the basic solution. Moreover, we compared with the existing “similar” work/solutions and did corresponding gap analysis.

Your review and comments are very much appreciated. Thank you!

Best regards,

Shuping

A new version of I-D, draft-peng-apn-scope-gap-analysis-00.txt

has been successfully submitted by Shuping Peng and posted to the IETF repository.

Name:              draft-peng-apn-scope-gap-analysis

Revision: 00

Title:                 APN Scope and Gap Analysis

Document date:      2020-12-16

Group:              Individual Submission

Pages:              11

URL:            https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt

Status:         https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/

Htmlized:       https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis

Htmlized:       https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00

Abstract:

   The APN work in IETF is focused on developing a framework and set of

   mechanisms to derive, convey and use an identifier to allow for

   implementing fine-grain user-, application-, and service-level

   requirements at the network layer.  This document describes the scope

   of the APN work and the solution gap analysis.

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 20 Jan 2021 16:27:18 +0000

ShuPing,

As described in the MEF70 document,
"APPID matches could be simple protocol matches (that could be accomplished with the other Criteria such as DPORT) such as "SSH" or "SNMP" or "RTP", but they can also support deeper inspection of packets such as "SNMP GET NEXT" or "HTTP POST" or "TWAMP [15] STOP-SESSION".

How does the standard match and the custom match work in the real system?
[Linda] Standard Match can be the combination of packet's 5 tuple header. Custom match can be using the DPI to extract out the payload as matching criteria (such as HTTP Post).

What are the key elements in the system? How do they interact?
[Linda] If the packets are encrypted, which are more and more often now, a subscriber has to provide the Key to the Service Provider for decrypt the packets if the subscribe needs the service provider to perform the application based forwarding.

Please let me know if you have further questions.

Linda Dunbar
From: rtgwg <[email-masked]> On Behalf Of Pengshuping (Peng Shuping)
Sent: Wednesday, January 20, 2021 12:18 AM
To: [email-masked]; [email-masked]
Subject: RE: A new draft on APN for your review, thank you!

Dear all,

In the MEF 70 "SD-WAN Service Attribute and Services", Table 4 on Page 36 has defined the fields (from layer 2 through layer 4) which are expected to be able to match against ingress IP Packets. APPID is explicitly listed as a criterion.

"The APPID Policy Criterion provides the ability for the Service Provider to define and name both simple and complex matches. These can include standard matches available to all of the Service Provider's Subscribers from a catalog and/or custom matches developed by the Service Provider by agreement with a particular Subscriber."

https://www.mef.net/wp-content/uploads/2019/07/MEF-70.pdf<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.mef.net%2Fwp-content%2Fuploads%2F2019%2F07%2FMEF-70.pdf&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005954259%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=VYMC84%2BEEFnTHMK9WEt53EU7Voj%2FJPKOKgtHKJsS1sc%3D&reserved=0>

Many thanks!

Best regards,
Shuping

From: Pengshuping (Peng Shuping)
Sent: Tuesday, December 15, 2020 11:12 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: A new draft on APN for your review, thank you!

Dear all,

A new draft on APN has been posted, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005964256%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=C%2BchzeUr4e%2BHvC1avNuFQ0N7kzY1IhzR5Vo%2BtPc26W4%3D&reserved=0>.

In this draft, we clarified the scope of the APN work in IETF, introduced an example use case and the basic solution. Moreover, we compared with the existing "similar" work/solutions and did corresponding gap analysis.

Best regards,

Shuping

Revision: 00

Pages:              11

URL:            https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-peng-apn-scope-gap-analysis-00.txt&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005964256%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=g7Aqz9wEarRwCFgxGiMtxaA7Y0YcQkCFJ6cjItNIUXY%3D&reserved=0>

Status:         https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-peng-apn-scope-gap-analysis%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005974253%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=oMC2LPj%2FeBc3qAW5qMiy42PpK%2F6NisLSZIt4nybx6Nk%3D&reserved=0>

Htmlized:       https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005974253%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=n2Bh%2F7hNbJfYrgJ1x6JMro8qFukhHN4B93SCYtZm5w0%3D&reserved=0>

Htmlized:       https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-00&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C892e480ad68740030b8208d8bd0b2e21%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637467203005984248%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=V9etnojzROD4BiNUyChWgqyI%2B3SQOiWb5iqr8CjDly0%3D&reserved=0>

Abstract:

---

From: "Pengshuping (Peng Shuping)" <[email-masked]>
Date: Thu, 21 Jan 2021 02:42:03 +0000

Hi Linda,

Thank you very much! The standards and corresponding implementations are much more clear now.

It is worth of thinking about how to leverage and integrate this edge intelligence with the network capabilities.

Best regards,
Shuping

From: Linda Dunbar [mailto:[email-masked]]
Sent: Thursday, January 21, 2021 12:27 AM
To: Pengshuping (Peng Shuping) <[email-masked]>; [email-masked]; [email-masked]
Subject: RE: A new draft on APN for your review, thank you!

ShuPing,

Linda Dunbar
From: rtgwg <[email-masked]<mailto:[email-masked]>> On Behalf Of Pengshuping (Peng Shuping)
Sent: Wednesday, January 20, 2021 12:18 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: A new draft on APN for your review, thank you!

Dear all,

Many thanks!

Best regards,
Shuping

Dear all,

Best regards,

Shuping

Revision: 00

Pages:              11

Abstract:

---

From: "Feng Yang" <[email-masked]>
Date: Fri, 22 Jan 2021 15:53:30 +0800

Hi Shuping,

SD-WAN is expected to carry quite some applications over hybrid links, such as internet, mpls, etc. Only with the application information, , it is possible for SD-WAN CPE to direct the traffic over different paths according to the application requirement.

For the application information, quite some ways work properly if the traffic is not encrypted. So the problem here is how to get the application information from the encrypted packets.  

Application information is the base that we can provide a lot of services. We expect to combine this with SRv6  in order to provide a new competitive SD-WAN service which can put SLA service、cloud based VAS(Value Added Service) together in a flexible way.

BR，

杨锋

Feng Yang

发件人: Apn [mailto:[email-masked]] 代表 Pengshuping (Peng Shuping)
发送时间: 2021年1月20日 14:18
收件人: [email-masked]; [email-masked]
主题: Re: [Apn] A new draft on APN for your review, thank you!

Dear all, 

Many thanks!

Best regards, 

Shuping 

Dear all, 

Best regards, 

Shuping 

Revision: 00

Pages:              11

 

Abstract:

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 22 Jan 2021 17:26:25 +0000

Feng,

MEF88 (Application Security for SD-WAN services) states that if subscribers need the Security services by the SDWAN services provided by the Service Providers, the subscribers need to provide the security key (such as TLS1.2 keys) to the Providers. https://wiki.mef.net/display/DSC/SD-WAN+Application+Security+Project+Contributions

I am curious from China Mobile perspective, is it a feasible for China Mobile subscribers to provide their TLS1.2 key to you?

Thanks, Linda Dunbar

From: rtgwg <[email-masked]> On Behalf Of Feng Yang
Sent: Friday, January 22, 2021 1:54 AM
To: 'Pengshuping (Peng Shuping)' <[email-masked]>; [email-masked]; [email-masked]
Subject: 答复: [Apn] A new draft on APN for your review, thank you!

Hi Shuping,

BR，

杨锋
Feng Yang

发件人: Apn [mailto:[email-masked]] 代表 Pengshuping (Peng Shuping)
发送时间: 2021年1月20日 14:18
收件人: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: Re: [Apn] A new draft on APN for your review, thank you!

Dear all,

https://www.mef.net/wp-content/uploads/2019/07/MEF-70.pdf<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.mef.net%2Fwp-content%2Fuploads%2F2019%2F07%2FMEF-70.pdf&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437111085%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=N0zZ3aZ%2F88oYs3GG4FJbj3eUbXQz%2B1xZKZ5HX8KW99Y%3D&reserved=0>

Many thanks!

Best regards,
Shuping

Dear all,

A new draft on APN has been posted, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437121080%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=2zHps5x%2BPAngdBs2OmoWDoZVfcuJR00vulMhdP8Q%2B%2FA%3D&reserved=0>.

Best regards,

Shuping

Revision: 00

Pages:              11

URL:            https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-peng-apn-scope-gap-analysis-00.txt&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437121080%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=xM21DHtsz2HcEqAWrNzsSvcTxTKtXCaGHat2kx4Dn0c%3D&reserved=0>

Status:         https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-peng-apn-scope-gap-analysis%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437131063%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=gqxkPULsqdZjCJ7xw3qTabkdm96wv%2BSnYpNBEQ0VjA0%3D&reserved=0>

Htmlized:       https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437131063%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=%2FqDARDM4UG0Drbr%2F5U4nx3HF5E1fG%2Fv2dbX3rGB5Mo0%3D&reserved=0>

Htmlized:       https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-00&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437141061%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=A2v6Dqx61FmMXdHf8K2guAmQEutAz55CBye7iFscNNo%3D&reserved=0>

Abstract:

---

From: "Feng Yang" <[email-masked]>
Date: Mon, 25 Jan 2021 10:13:33 +0800

Hi Linda,

It is feasible if we do this based on regulation and agreement with customer. 

There are many ways to do application identification, DPI\DNS\5 Tuples\URL\APN. Needs to use different  technology to handle different scenarios. That is the pain point.

BR，

杨锋

Feng Yang

发件人: Apn [mailto:[email-masked]] 代表 Linda Dunbar
发送时间: 2021年1月23日 01:26
收件人: Feng Yang; 'Pengshuping (Peng Shuping)'; [email-masked]; [email-masked]
主题: Re: [Apn] A new draft on APN for your review, thank you!

Feng, 

Thanks, Linda Dunbar

Hi Shuping,

BR，

杨锋

Feng Yang

Dear all, 

https://www.mef.net/wp-content/uploads/2019/07/MEF-70.pdf <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.mef.net%2Fwp-content%2Fuploads%2F2019%2F07%2FMEF-70.pdf&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437111085%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=N0zZ3aZ%2F88oYs3GG4FJbj3eUbXQz%2B1xZKZ5HX8KW99Y%3D&reserved=0> 

Many thanks!

Best regards, 

Shuping 

Dear all, 

A new draft on APN has been posted, https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437121080%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=2zHps5x%2BPAngdBs2OmoWDoZVfcuJR00vulMhdP8Q%2B%2FA%3D&reserved=0> .

Best regards, 

Shuping 

Revision: 00

Pages:              11

URL:            https://www.ietf.org/archive/id/draft-peng-apn-scope-gap-analysis-00.txt <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-peng-apn-scope-gap-analysis-00.txt&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437121080%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=xM21DHtsz2HcEqAWrNzsSvcTxTKtXCaGHat2kx4Dn0c%3D&reserved=0> 

Status:         https://datatracker.ietf.org/doc/draft-peng-apn-scope-gap-analysis/ <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-peng-apn-scope-gap-analysis%2F&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437131063%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=gqxkPULsqdZjCJ7xw3qTabkdm96wv%2BSnYpNBEQ0VjA0%3D&reserved=0> 

Htmlized:       https://datatracker.ietf.org/doc/html/draft-peng-apn-scope-gap-analysis <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437131063%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=%2FqDARDM4UG0Drbr%2F5U4nx3HF5E1fG%2Fv2dbX3rGB5Mo0%3D&reserved=0> 

Htmlized:       https://tools.ietf.org/html/draft-peng-apn-scope-gap-analysis-00 <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-peng-apn-scope-gap-analysis-00&data=04%7C01%7Clinda.dunbar%40futurewei.com%7C4c092e96fa604c5f89eb08d8beaae006%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637468988437141061%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=A2v6Dqx61FmMXdHf8K2guAmQEutAz55CBye7iFscNNo%3D&reserved=0> 

Abstract: