Subject: I-D Action: draft-ietf-rtgwg-policy-model-30.txt

From: [email-masked]
Date: Thu, 29 Jul 2021 21:44:57 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Area Working Group WG of the IETF.

        Title           : A YANG Data Model for Routing Policy
        Authors         : Yingzhen Qu
                          Jeff Tantsura
                          Acee Lindem
                          Xufeng Liu
	Filename        : draft-ietf-rtgwg-policy-model-30.txt
	Pages           : 42
	Date            : 2021-07-29

Abstract:
   This document defines a YANG data model for configuring and managing
   routing policies in a vendor-neutral way.  The model provides a
   generic routing policy framework which can be extended for specific
   routing protocols using the YANG 'augment' mechanism.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-policy-model/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-policy-model-30

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-rtgwg-policy-model-30

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 30 Jul 2021 12:03:38 +0000

Routing WG,

This version addresses comments from Routing Directorate and YANG doctors reviews, as well as, WG last call comments.  Non-editorial changes include:

     1. Removal of references to YANG interface drafts in order to match on specific VLANs. These models haven't moved forward in some time and the consensus was it was best not to gate publication on normative references to the drafts. 
     2. Addition of a read-only leaf indicating whether or not changes to route attributes within a policy are reflected in subsequent match checking. We discovered that different vendors implemented this subtle point differently. 
     
      leaf match-modified-attributes {
        type boolean;
        config false;
        description
          "This boolean value dictates whether matches are performed
           on the actual route attributes or route attributes
           modified by policy statements preceding the match.";
      }

We feel we have consensus on both these changes. 

Thanks,
Yingzhen (who did most of the changes) and Acee 

On 7/30/21, 12:46 AM, "rtgwg on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    Abstract:

    _______________________________________________
    rtgwg mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/rtgwg