Subject: [Rtgwg] draft-eckert-intarea-functional-addr-internets-00.txt

From: Toerless Eckert <[email-masked]>
Date: Thu, 15 Jul 2021 19:16:12 +0200

Dear RTG-WG

As attached below, i have written up an idea about why and how variable-length
addresses in the network layer would be useful for many limited domain internetworks,
but also how they could provide a simple and easily extensible framework to
add additional semantics (the likes of multicast, BIER, ICN), and also make it easier 
to express the programmability that SRv6 introduced.

I am very intered to hear feedback from the RTG WG community and will be asking
for a slot at RTG-WG IETF111. This draft is named inder int-area given how
it is driven by better addressing, but in the end, the way it does achieve
better addressing is by doing additional forwarding plane "routing" to
build internetworks, especially in limited domains (such as metropolitan networks
or factory floors).

Note that the -00 writeup is mostly inspirational for what i think the cool
things one could do with it are and to explain the concepts.

Obviously, if/when there is interest in this
direction, the harder work of figuring out how to best introduce this
incrementally, and ideally backward compatible into existing networks wold
be the next big set of items to work out.

Cheers
    Toerless

On Mon, Jul 12, 2021 at 01:00:25PM -0700, [email-masked] wrote:
> A new version of I-D, draft-eckert-intarea-functional-addr-internets-00.txt
> has been successfully submitted by Toerless Eckert and posted to the
> IETF repository.
> 
> Name:		draft-eckert-intarea-functional-addr-internets
> Revision:	00
> Title:		Functional Addressing (FA) for internets with Independent Network Address Spaces (IINAS)
> Document date:	2021-07-12
> Group:		Individual Submission
> Pages:		30
> URL:            https://www.ietf.org/archive/id/draft-eckert-intarea-functional-addr-internets-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-eckert-intarea-functional-addr-internets/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-eckert-intarea-functional-addr-internets
> 
> 
> Abstract:
>    Recent work has raised interest in exploring network layer addressing
>    that is more flexible than fixed-length addressing as used in IPv4
>    (32 bit) and IPv6 (128 bit).
> 
>    The reasons for the interest include both support for multiple and
>    potentially novel address semantics, but also optimizations of
>    addressing for existing semantics such as unicast tailored not for
>    the global Internet but to better support private networks / limited
>    domains.
> 
>    This memo explores in the view of the author yet little explored
>    reasons for more flexible addresses namely the problems and
>    opportunities for Internetworking with Independent Network Address
>    Spaces (IINAS).
> 
>    To better enable such internetworks, this memo proposes a framework
>    for a Functional Addressing model.  This model also intends to
>    support several other addressing goals including programmability and
>    multiple semantics.
> 
>                                                                                   
> 
> 
> The IETF Secretariat

---

From: JeffT <[email-masked]>
Date: Thu, 15 Jul 2021 11:32:48 -0700

Hi Toerless,

Please request the slot ASAP, responding to Yingzhen’ email.

Thanks!

Cheers,

Jeff

From: Toerless Eckert
Sent: Thursday, July 15, 2021 10:18 AM
To: [email-masked]
Subject: [Rtgwg] draft-eckert-intarea-functional-addr-internets-00.txt

Dear RTG-WG

or factory floors).

Cheers

Toerless

> The IETF Secretariat

_______________________________________________

rtgwg mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/rtgwg