Subject: [Rum] Outstanding Issues

From: Isaac Roach <[email-masked]>
Date: Fri, 12 Mar 2021 15:27:31 +0000

Hi Brian,

As discussed during the IETF110 meeting, there are still concerns we have with the current version of the RUM Profile. These are the outstanding issues: 
 
Section 4 - IPv6 was added as requirement for the RUE but it is not clear how this affects the interface between the RUE and the provider. 

Section 5.2.5 - There is nothing indicating how registered location should be handled for 911 in the UI. We are required to maintain a registered address for the user. We use a device identifier to save one location for each device the user logs into. We need a method to identify multiple locations for multiple devices for a single user. 

Section 6 - The providers have agreed to use SIP to ensure interoperability. WebRTC is out of scope and should not have been added. If the RUE implementor wants to use WebRTC it needs to also provide a WebRTC to SIP gateway. 

Section 7.2 - XCard was changed to jCard. The FCC rules already require providers to support XCard. Requiring support for jCard is an unnecessary increase in scope; there is no reason why providers should have to support XCard and jCard.

Section 7.1 and 7.2 - Automatic contact export is not needed and should not have been added as it unnecessarily increased scope.  

Section 8 - MWI should be removed as it is not a minimum requirement from the FCC, and providers shouldn’t be limited to supporting MWI on a RUE in this one specific way. 

Missing - There is nothing specified for push notifications to enable incoming calls which are now required for mobile.  
 
These are issues we can help resolve but it will require a significant amount of time. Given that the FCC has suspended the VATRP project until there is an appropriately developed consensus standard, it doesn’t seem like a good idea to me to rush this through.

Thanks,

Isaac

Isaac Roach
VP Engineering
P: 801-558-0814
E: [email-masked]

Sorenson Communications, LLC
4192 S. Riverboat Rd.
Salt Lake City, UT 84123
www.sorenson.com
 
CONFIDENTIALITY NOTICE. The information contained in this e-mail transmission and any documents, files or previous e-mail messages attached to it, may contain confidential and proprietary information and is intended only for the use of the intended recipient. If the reader of this message is not the intended recipient or the employee or agent responsible to deliver it to the intended recipient, you are hereby notified that any dissemination, distribution, copying or use of any of the information contained in or attached to this message is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply email at [email-masked] or by telephone at 801-287-9801, and destroy the original transmission and its attachments without reading them or saving them to disk.

On 3/9/21, 1:26 PM, "Rum on behalf of Brian Rosen" <[email-masked] on behalf of [email-masked]> wrote:

    [EXTERNAL] 

    Our meeting is tomorrow, 14:30-15:30 UTC, 9:30-10:30 EST.  

    The meeting Meetecho link is: https://meetings.conf.meetecho.com/ietf110/?group=rum&short=&item=1
    You need to be registered to attend via Meetecho.  Registration is https://www.ietf.org/how/meetings/register/

    The audio stream is: http://mp3.conf.meetecho.com/ietf110/rum/1.m3u
    And the jabber room is: xmpp:[email-masked]?join

    I hope you all will attend.  

    Brian
    -- 
    Rum mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/rum

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 12 Mar 2021 11:13:08 -0500

Isaac,

Following up on a couple of your points...

> Section 7.1 and 7.2 - Automatic contact export is not needed and should not have been added as it unnecessarily increased scope.

I don't understand what you are saying here. IIUC you currently manage a 
contact list on the server and your proprietary client devices access 
this in a proprietary way in order to make calls to contacts.

If we are to have a standardized RUE use a contact list then we need 
some standardized way to access it.

The CardDAV feature in 7.1 is optional for providers, but is the 
"modern" way to synchronize lists of contacts.

The contact list import specified in 7.2 is based on the existing fcc 
requirement. It is suboptimal compared to CardDAV but is sufficient to 
allow the RUE to provide contact list support.

What do you think should be specified?

> Section 8 - MWI should be removed as it is not a minimum requirement from the FCC, and providers shouldn’t be limited to supporting MWI on a RUE in this one specific way.

For the RUE to be interoperable across providers we need one mandatory 
to implement mechanism. AFAIK this is the only standards-based mechanism 
that we could reference.

Again I'm not clear what you are suggesting as an alternative.

	Thanks,
	Paul