Subject: [sacm] ASR RFC Questions

From: "Davidson II, Mark S" <[email-masked]>
Date: Mon, 24 Sep 2012 14:23:29 +0000

All,

First, a couple of notes:
ASR NIST IR: http://csrc.nist.gov/publications/drafts/nistir-7848/draft_nistir_7848.pdf
I am currently using NRoffEdit to create the ASR.

As David and I work through the draft RFC for ASR, I have some questions for the group:

0. Is the draft's deadline 10/15?
1. In the case that a contributor does not represent an organization, what is the appropriate text that would go in place of the organization?
2. ASR has a few tables (notably tables 6-1 through 6-12). What is the best way to represent these tables in RFC format?
3. Is it worth sharing the NRoffEdit file in this forum before posting as a draft, or should it just be posted as a draft when ready?

The conversion to RFC is mostly complete, though I'm sure there will be plenty of topics to address within the draft. The major work left to be done is creating the data model tables in the RFC.

Thank you.

Mark Davidson
[email-masked]
Information Security Engineer
G022 - Information Assurance
The MITRE Corporation

---

From: Adam Montville <[email-masked]>
Date: Mon, 24 Sep 2012 14:31:04 +0000

From: "<Davidson II>", Mark S <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 24, 2012 7:23 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sacm] ASR RFC Questions

All,

0. Is the draft’s deadline 10/15?

One of the BoF chairs would know for sure, but I believe that is correct.

I don't really know the answer, but there are others on this list who probably do.

This depends on the complexity of the tables.  I don't know about creating tables using the Nroff editor, just XML.  When all else fails, using something that helps create ascii diagrams is useful (UltraEdit or http://www.asciiflow.com).

I would just post it.  That's what I did for the AI transformation.

The conversion to RFC is mostly complete, though I’m sure there will be plenty of topics to address within the draft. The major work left to be done is creating the data model tables in the RFC.

Outstanding!  Thanks for your collective efforts!

Thank you.

Mark Davidson
[email-masked]<mailto:[email-masked]>
Information Security Engineer
G022 - Information Assurance
The MITRE Corporation

---

From: Sean Turner <[email-masked]>
Date: Tue, 25 Sep 2012 11:07:01 -0400

On 9/24/12 10:31 AM, Adam Montville wrote:
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>"
> <[email-masked] <mailto:[email-masked]>>
>     ASR NIST IR:
>     http://csrc.nist.gov/publications/drafts/nistir-7848/draft_nistir_7848.pdf
>

Friendly AD jumping in :)

General reminder to you and all: Please make sure to read and follow the 
NOTE WELL on the submission page: 
https://datatracker.ietf.org/submit/note-well/

> One of the BoF chairs would know for sure, but I believe that is correct.

Cutoff for -00 version is 10/15.

>
>     1. In the case that a contributor does not represent an
>     organization, what is the appropriate text that would go in place of
>     the organization?
>
>

On the front page do something like the following if they're listed last:

         Author 1
       Author Org
      Author Name
October 15, 2012

If they're not listed last then use a blank line like:

      Author Name

         Author 2
       Author Org
October 15, 2012

In the Author' addresses section at a minimum name and email address are 
needed.

This reminds me though that not all authors need to be listed on the 
front page.  If there's really just one editor you can list your name, 
put (ed.) next to it, and then have a contributors section where you 
also list the other authors.  Like s8 in:
https://datatracker.ietf.org/doc/draft-ietf-sidr-bgpsec-protocol/

There's no hard and fast rule but try to keep the # of authors on the 
front low.  Nobody wants the boiler plate to take two pages ;)

>     2. ASR has a few tables (notably tables 6-1 through 6-12). What is
>     the best way to represent these tables in RFC format?
>
>
>
> This depends on the complexity of the tables.  I don't know about
> creating tables using the Nroff editor, just XML.  When all else fails,
> using something that helps create ascii diagrams is useful (UltraEdit or
> http://www.asciiflow.com).

ascii art is your friend ;)  Do the best you can, but I normally just do 
it by hand

+----------------+----------------+----------------+
| Column Heading | Column Heading | Column Heading |
+----------------+----------------+----------------+
| Entry          | Entry          | Entry          |
+----------------+----------------+----------------+
| Entry          | Entry          | Entry          |
+----------------+----------------+----------------+
...

>     3. Is it worth sharing the NRoffEdit file in this forum before
>     posting as a draft, or should it just be posted as a draft when ready?
>
>

I'd just post it too.  Once it's posted then when you do edits everyone 
can use the tools to see what's changed from version to version.

But, do run the nits checker on it so your (if you have any) will stop 
fall out when the submission tool kicks it back for odd errors you 
didn't know about: https://tools.ietf.org/tools/idnits/

>     The conversion to RFC is mostly complete, though I’m sure there will
>     be plenty of topics to address within the draft. The major work left
>     to be done is creating the data model tables in the RFC.
>
>

+1

The best way to get work done is to do it and then submit it.

spt

>     Thank you.
>
>     Mark Davidson
>
>     [email-masked] <mailto:[email-masked]>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>