Subject: [sacm] draft liaison - call for contributions for the SACM Information Model

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 17 Apr 2014 15:57:02 +0000

Hi,

We believe that it's time to issue a call for contributions for the SACM Information Model. After discussing the issue with our AD we suggest to send this call for contributions both in the IETF, as well as to a number of SDOs doing relevant work out of the IETF. As many of these organizations are accustomed to work with formal liaison statements, we have drafted the Call the Contributions below.

Please send your comments, questions, concerns and proposals to improve the wording to the WG mail list before 4/25 COB. We would like to send this CfC before the virtual interim scheduled for 4/30/

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group
      The Open Management Group
      NIST
      OASIS
      ITU-T Study Groups 2 and 17
From: IETF SACM WG - Adam Montville, Dan Romascanu (co-chairs)
Cc: Kathleen Moriarty (Security AD), Scott Mansfield (IETF liaison manager to the ITU-T)

The Security Automation and Continuous Monitoring (SACM) Working
Group in the IETF is chartered to define a set of standards to enable assessment
of endpoint posture [5].

Please find below a call for contributions for the SACM Information Model.
Although the work on use cases and requirements is not completed, we
believe that there is enough substance and stability in the existing work-in-
progress documents and that we should not serialize the process. We believe
that we need the future SACM information model to cover  at least the
following general areas:

  1) Endpoint Identification

  2) Endpoint Characterization

  3) Endpoint Attribute Expression/Representation

  4) Policy evaluation expression and results reporting

We invite interested parties to submit their potential contributions as
follows:

  1) Area being addressed (from the list above)

  2) Textual description of the proposed contribution

  3) References to freely available existing work (i.e.
specifications)

  4) Mapping of the proposed contribution to existing use cases [1]
and requirements [2] (terminology definitions in our use cases and
requirements can be found in [3])

The best way to submit contributions is by writing individual Internet-
Drafts, but to begin with emails to the SACM mailing list [4] work as well.

While SACM holds (virtual) interim meetings as needed, the next face-to-
face session is expected to take place during the 90th meeting of the
Internet Engineering Task Force which will take place in Toronto between
July 20-25, 2014.  During this session, we will discuss the
merits of potential contributions. The cut-off date to submit Internet-Drafts
for this meeting is July 4, 2014.

For further information, please contact one or both of the SACM chairs:
Adam Montville ([email-masked]<mailto:[email-masked]>) or Dan Romascanu
([email-masked]<mailto:[email-masked]>).

----
[1] http://datatracker.ietf.org/doc/draft-ietf-sacm-use-cases/

[2] http://datatracker.ietf.org/doc/draft-camwinget-sacm-requirements/

[3] http://datatracker.ietf.org/doc/draft-ietf-sacm-terminology/

[4] https://www.ietf.org/mailman/listinfo/sacm

[5] http://datatracker.ietf.org/wg/sacm/charter/

---

From: Scott Mansfield <[email-masked]>
Date: Thu, 17 Apr 2014 16:05:14 +0000

It might be useful to point out where the virtual meetings are announced and how to join.

If we know of someone that is planning to go to the next ITU-T SG17 (17-26 Sept 2014) meeting, it would be useful to leverage their presence at the meeting to ensure the liaison is presented and properly understood.

Regards,
-scott.

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 11:57 AM
To: [email-masked]
Cc: Moriarty, Kathleen; Scott Mansfield
Subject: draft liaison - call for contributions for the SACM Information Model

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 17 Apr 2014 16:14:28 +0000

Thanks, Scott. Good comments. We'll make sure that we add information on the virtual interim sessions. We'll try to find out who plans to attend the September meetings. Al Morton maybe?

Regards,

Dan

From: Scott Mansfield [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 7:05 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]; Moriarty, Kathleen
Subject: RE: draft liaison - call for contributions for the SACM Information Model

Regards,
-scott.

To: [email-masked]<mailto:[email-masked]>

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: Gunnar Engelbach <[email-masked]>
Date: Thu, 17 Apr 2014 12:40:26 -0400

* Does "Endpoint Attribute Expression" refer to how to request certain 
attributes rather than how to express the set of those attributes?  Both 
are needed.

* Will the recipients of this be aware of the distinction between 
Endpoint Identification and Endpoint Characterization?

Some explanation of these terms might be necessary.

On 4/17/2014 11:57 AM, Romascanu, Dan (Dan) wrote:
> Hi,
>
> We believe that it’s time to issue a call for contributions for the SACM
> Information Model. After discussing the issue with our AD we suggest to
> send this call for contributions both in the IETF, as well as to a
> number of SDOs doing relevant work out of the IETF. As many of these
> organizations are accustomed to work with formal liaison statements, we
> have drafted the Call the Contributions below.
>
> Please send your comments, questions, concerns and proposals to improve
> the wording to the WG mail list before 4/25 COB. We would like to send
> this CfC before the virtual interim scheduled for 4/30/
>
> Thanks and Regards,
>
> Adam and Dan
>
> To: DMTF
>
>        The Open Group
>
> From: IETF SACM WG – Adam Montville, Dan Romascanu (co-chairs)
>
> of endpoint posture[5].
> Adam Montville ([email-masked] <mailto:[email-masked]>)
> or Dan Romascanu
> ([email-masked] <mailto:[email-masked]>).
>
>
>
> ----
> [1]http://datatracker.ietf.org/doc/draft-ietf-sacm-use-cases/
>
> [2]http://datatracker.ietf.org/doc/draft-camwinget-sacm-requirements/
>
> [3]http://datatracker.ietf.org/doc/draft-ietf-sacm-terminology/
>
> [4]https://www.ietf.org/mailman/listinfo/sacm
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: Adam Montville <[email-masked]>
Date: Thu, 17 Apr 2014 11:52:56 -0500

On Apr 17, 2014, at 11:40 AM, Gunnar Engelbach <[email-masked]> wrote:

> 
> 
> * Does "Endpoint Attribute Expression" refer to how to request certain attributes rather than how to express the set of those attributes?  Both are needed.

I’m the guilty party in terms of writing this.  I left it somewhat ambiguous purposefully.  I would argue that we may not need both, but that we necessarily need “how to express”, which is another way of saying “what”.  We need to be able to describe *what* we want to look at, but we may not need to describe *how* to look at it.  In a CfC, it seems better to leave things scoped by guardrails rather than down to the lines on the road.

> 
> * Will the recipients of this be aware of the distinction between Endpoint Identification and Endpoint Characterization?

Maybe.

> Some explanation of these terms might be necessary.

Are these in our terminology draft?  If so, then they should already be explained.

---

From: "Moriarty, Kathleen" <[email-masked]>
Date: Thu, 17 Apr 2014 13:08:46 -0400

Take,

Are you planning to attend the next SG 17 meeting?

Thank you,
Kathleen

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 12:14 PM
To: Scott Mansfield
Cc: [email-masked]; Moriarty, Kathleen; MORTON, ALFRED C (AL)
Subject: RE: draft liaison - call for contributions for the SACM Information Model

Regards,

Dan

From: Scott Mansfield [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 7:05 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]<mailto:[email-masked]>; Moriarty, Kathleen
Subject: RE: draft liaison - call for contributions for the SACM Information Model

Regards,
-scott.

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: "Waltermire, David A." <[email-masked]>
Date: Thu, 17 Apr 2014 17:55:14 +0000

What about ISO/IEC JTC1 SC7 (Software and systems engineering) and SC27 (IT Security techniques) which might also have relevant work?

Dave

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, April 17, 2014 11:57 AM
To: [email-masked]
Cc: Moriarty, Kathleen; Scott Mansfield
Subject: [sacm] draft liaison - call for contributions for the SACM Information Model

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: Ira McDonald <[email-masked]>
Date: Thu, 17 Apr 2014 15:18:56 -0400

Hi,

How about TCG who probably have contributions?  TNC WG contributed
four specs to IETF NEA WG.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Apr 17, 2014 at 1:55 PM, Waltermire, David A. <
[email-masked]> wrote:

>  What about ISO/IEC JTC1 SC7 (Software and systems engineering) and SC27
> (IT Security techniques) which might also have relevant work?
>
>
>
> Dave
>
>
>
> *From:* sacm [mailto:[email-masked]] *On Behalf Of *Romascanu, Dan
> (Dan)
>
> *Sent:* Thursday, April 17, 2014 11:57 AM
> *To:* [email-masked]
> *Cc:* Moriarty, Kathleen; Scott Mansfield
> *Subject:* [sacm] draft liaison - call for contributions for the SACM
> Information Model
>
>
>
> Hi,
>
>
>
> send this call for contributions both in the IETF, as well as to a number
> of SDOs doing relevant work out of the IETF. As many of these organizations
> are accustomed to work with formal liaison statements, we have drafted the
> Call the Contributions below.
>
>
>
> the wording to the WG mail list before 4/25 COB. We would like to send this
> CfC before the virtual interim scheduled for 4/30/
>
>
>
> Thanks and Regards,
>
>
>
> Adam and Dan
>
>
>
>
>
>
>
>
>
>
>
> To: DMTF
>
>       The Open Group
>
> Adam Montville ([email-masked]) or Dan Romascanu
> ([email-masked]).
>
>
> ----

---

From: "Waltermire, David A." <[email-masked]>
Date: Thu, 17 Apr 2014 21:32:28 +0000

+1

From: Ira McDonald [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 3:19 PM
To: Waltermire, David A.
Cc: Romascanu, Dan (Dan); [email-masked]; Moriarty, Kathleen; Scott Mansfield
Subject: Re: [sacm] draft liaison - call for contributions for the SACM Information Model

Hi,

mailto: [email-masked]<mailto:[email-masked]>

On Thu, Apr 17, 2014 at 1:55 PM, Waltermire, David A. <[email-masked]<mailto:[email-masked]>> wrote:
What about ISO/IEC JTC1 SC7 (Software and systems engineering) and SC27 (IT Security techniques) which might also have relevant work?

Dave

From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Romascanu, Dan (Dan)

Hi,

We believe that it’s time to issue a call for contributions for the SACM Information Model. After discussing the issue with our AD we suggest to send this call for contributions both in the IETF, as well as to a number of SDOs doing relevant work out of the IETF. As many of these organizations are accustomed to work with formal liaison statements, we have drafted the Call the Contributions below.

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Fri, 18 Apr 2014 09:52:42 +0900

Hi Kathleen,

I am thinking to come to the next SG 17 meeting.
(I will attend only for a couple of days, though.)
So, if some works need to be done for SACM, I am happy to do that.

Kind regards,
Take

From: Moriarty, Kathleen [mailto:[email-masked]] 
Sent: Friday, April 18, 2014 2:09 AM
To: Romascanu, Dan (Dan); Scott Mansfield
Cc: [email-masked]; MORTON, ALFRED C (AL); [email-masked]
Subject: RE: draft liaison - call for contributions for the SACM Information
Model

Take,

Thank you,
Kathleen

From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, April 17, 2014 12:14 PM
To: Scott Mansfield
Cc: [email-masked]; Moriarty, Kathleen; MORTON, ALFRED C (AL)
Subject: RE: draft liaison - call for contributions for the SACM Information
Model

Thanks, Scott. Good comments. We’ll make sure that we add information on the
virtual interim sessions. We’ll try to find out who plans to attend the
September meetings. Al Morton maybe? 

Regards,

Dan

From: Scott Mansfield [mailto:[email-masked]] 
Sent: Thursday, April 17, 2014 7:05 PM
To: Romascanu, Dan (Dan)
Cc: [email-masked]; Moriarty, Kathleen
Subject: RE: draft liaison - call for contributions for the SACM Information
Model

It might be useful to point out where the virtual meetings are announced and
how to join.

If we know of someone that is planning to go to the next ITU-T SG17 (17-26
Sept 2014) meeting, it would be useful to leverage their presence at the
meeting to ensure the liaison is presented and properly understood.

Regards,
-scott.

From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Thursday, April 17, 2014 11:57 AM
To: [email-masked]
Cc: Moriarty, Kathleen; Scott Mansfield
Subject: draft liaison - call for contributions for the SACM Information
Model

Hi,

We believe that it’s time to issue a call for contributions for the SACM
Information Model. After discussing the issue with our AD we suggest to send
this call for contributions both in the IETF, as well as to a number of SDOs
doing relevant work out of the IETF. As many of these organizations are
accustomed to work with formal liaison statements, we have drafted the Call
the Contributions below. 

Please send your comments, questions, concerns and proposals to improve the
wording to the WG mail list before 4/25 COB. We would like to send this CfC
before the virtual interim scheduled for 4/30/ 

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group
      The Open Management Group
      NIST
      OASIS
      ITU-T Study Groups 2 and 17  
From: IETF SACM WG – Adam Montville, Dan Romascanu (co-chairs)
Cc: Kathleen Moriarty (Security AD), Scott Mansfield (IETF liaison manager
to the ITU-T)  

The Security Automation and Continuous Monitoring (SACM) Working
Group in the IETF is chartered to define a set of standards to enable
assessment
of endpoint posture [5].

believe that there is enough substance and stability in the existing
work-in-

merits of potential contributions. The cut-off date to submit
Internet-Drafts

----

---

From: Kathleen Moriarty <[email-masked]>
Date: Thu, 17 Apr 2014 21:15:15 -0400

Thank you very much, Take!  

Sent from my iPhone

> On Apr 17, 2014, at 8:52 PM, "Takeshi Takahashi" <[email-masked]> wrote:
> 
> Hi Kathleen,
>

---

From: Scott Mansfield <[email-masked]>
Date: Fri, 18 Apr 2014 11:36:05 +0000

Thanks from me as well!  I will be in touch once the liaison is finalized and posted to the SG 17 Gen area in temporary documents for the September meeting.

Regards,
-scott.

-----Original Message-----
From: Kathleen Moriarty [mailto:[email-masked]] 
Sent: Thursday, April 17, 2014 9:15 PM
To: Takeshi Takahashi
Cc: Moriarty, Kathleen; Romascanu, Dan (Dan); Scott Mansfield; [email-masked]; MORTON, ALFRED C (AL)
Subject: Re: [sacm] draft liaison - call for contributions for the SACM Information Model

Sent from my iPhone

> (I will attend only for a couple of days, though.) So, if some works 
> need to be done for SACM, I am happy to do that.
> 
> Kind regards,
> Take
> 
> 
> Thanks, Scott. Good comments. We’ll make sure that we add information 
> on the virtual interim sessions. We’ll try to find out who plans to 
> attend the September meetings. Al Morton maybe?
> 
> Regards,
> 
> Dan
> 
> 
> If we know of someone that is planning to go to the next ITU-T SG17 
> (17-26 Sept 2014) meeting, it would be useful to leverage their 
> presence at the meeting to ensure the liaison is presented and properly understood.
> 
> Regards,
> -scott.
> 
> We believe that it’s time to issue a call for contributions for the 
> SACM Information Model. After discussing the issue with our AD we 
> suggest to send this call for contributions both in the IETF, as well 
> as to a number of SDOs doing relevant work out of the IETF. As many of 
> these organizations are accustomed to work with formal liaison 
> statements, we have drafted the Call the Contributions below.
> 
> Please send your comments, questions, concerns and proposals to 
> improve the wording to the WG mail list before 4/25 COB. We would like 
> to send this CfC before the virtual interim scheduled for 4/30/
> 
> Thanks and Regards,
> 
> Adam and Dan
> 
> 
> 
> 
> 
> To: DMTF
>       The Open Group
> The Security Automation and Continuous Monitoring (SACM) Working Group 
> in the IETF is chartered to define a set of standards to enable 
> assessment of endpoint posture [5].
> 
> progress documents and that we should not serialize the process. We 
> believe that we need the future SACM information model to cover  at 
> least the following general areas:
> 
> The best way to submit contributions is by writing individual 
> Internet- Drafts, but to begin with emails to the SACM mailing list [4] work as well.
> 
> While SACM holds (virtual) interim meetings as needed, the next 
> face-to- face session is expected to take place during the 90th 
> meeting of the Internet Engineering Task Force which will take place 
> in Toronto between July 20-25, 2014.  During this session, we will 
> discuss the merits of potential contributions. The cut-off date to 
> submit Internet-Drafts for this meeting is July 4, 2014.
>

---

From: Steve Klos <[email-masked]>
Date: Fri, 18 Apr 2014 23:53:44 +0000

+1

From: Waltermire, David A. [mailto:[email-masked]]
Sent: Thursday, April 17, 2014 10:55 AM
To: Romascanu, Dan (Dan); [email-masked]
Cc: Moriarty, Kathleen; Scott Mansfield
Subject: Re: [sacm] draft liaison - call for contributions for the SACM Information Model

Dave

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: "Waltermire, David A." <[email-masked]>
Date: Tue, 22 Apr 2014 15:59:47 +0000

A couple other comments:

1)      By information model, I am assuming you are referring to RFC 3444. If so, it would be useful to include a reference to this RFC in the request.

2)      Since some organizations and participants in those organizations might not be well versed in contributing to the IETF, it might make sense to provide a reference or two to example I/Ds or RFCs that represent good samples of an information model definition. This will help contributors to figure out how best to organize their submissions in way that will be easily received by the IETF.
Thanks,
Dave

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 22 Apr 2014 18:22:47 +0000

Thanks, David. Good comments - we shall factor these in as well.

All, please keep these comments coming. Immediately after the 4/25 cutoff I will post a revised version addressing the comments and proposals received until then.

Regards,

Dan

From: Waltermire, David A. [mailto:[email-masked]]
Sent: Tuesday, April 22, 2014 7:00 PM
To: Romascanu, Dan (Dan); [email-masked]
Cc: Moriarty, Kathleen; Scott Mansfield
Subject: RE: [sacm] draft liaison - call for contributions for the SACM Information Model

A couple other comments:

Hi,

Thanks and Regards,

Adam and Dan

To: DMTF
      The Open Group

----