Subject: [sacm] Comments on draft-ietf-sacm-requirements-01

From: "Adam W. Montville" <[email-masked]>
Date: Wed, 15 Oct 2014 09:12:47 -0500

Nancy,

Nice update to the draft, thank you!  

I have a few wording changes I would recommend, and I’m not sure if you want those now or after the next submission, which would give you the opportunity to clean things up first (you mentioned cleaning things up a bit during the last virtual interim).  I’m holding the nits for now.

G-013 (Discovery) mentions the need for discovering the information that’s available in the ecosystem, and that may imply that capabilities are discoverable as well.  Should this be made explicit?  I see that it’s mentioned in ARCH-005, so that may be sufficient.

How are REQ-009 and IM-014 different (aside from one being specific to the information model)?

Is there a need to express requirements in terms of real numbers or otherwise speak to requirements that would affect operations in a given deployment?  For example, if we want to limit network bandwidth consumption to some throttled level, or if we want to provide the ability in the architecture to accommodate such throttling, etc.  I don’t see these types of things mentioned in the requirements document, and they may turn into something important down the road (some enterprises would yield terabytes of data each day under certain circumstances).  If things like this fall under one of the existing architectural requirements, perhaps we should consider how to make that clear.

Finally, do we need additional authors to help build out the information model requirement descriptions?

Regards,

Adam

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 20 Oct 2014 17:26:44 +0000

Hi Adam,
Thanks for the review, please see further below:

On 10/15/14, 7:12 AM, "Adam W. Montville" <[email-masked]>
wrote:

>I have a few wording changes I would recommend, and I¹m not sure if you
>want those now or after the next submission, which would give you the
>opportunity to clean things up first (you mentioned cleaning things up a
>bit during the last virtual interim).  I¹m holding the nits for now.
[NCW] If you give them to me by EOB tomorrow, I will try to work them inŠ.

>
>G-013 (Discovery) mentions the need for discovering the information
>that¹s available in the ecosystem, and that may imply that capabilities
>are discoverable as well.  Should this be made explicit?  I see that it¹s
>mentioned in ARCH-005, so that may be sufficient.
[NCW] What is a capability in this instance?  I think originally the text
was to require discovery of ³capabilities² and the response was to be more
explicit e.g. The notion that in the ecosystem there may be different
information that can be shared in specific instances of a data model and
protocol.  Would it be more clear to say that?

>How are REQ-009 and IM-014 different (aside from one being specific to
[NCW] None, other than the REQ- are viewed from use cases and IM- are
imposed on the information model to be designed.  Perhaps we should
revisit the Use Case section and fold those in (now that we¹re closer to
an architecture and functional components) that we can deprecate this
section and fold the requirements to the other sections?

>
>Is there a need to express requirements in terms of real numbers or
>otherwise speak to requirements that would affect operations in a given
>deployment?  For example, if we want to limit network bandwidth
>consumption to some throttled level, or if we want to provide the ability
>in the architecture to accommodate such throttling, etc.  I don¹t see
>these types of things mentioned in the requirements document, and they
>may turn into something important down the road (some enterprises would
>yield terabytes of data each day under certain circumstances).  If things
>like this fall under one of the existing architectural requirements,
>perhaps we should consider how to make that clear.
[NCW] It depends on how the group wants to handle the proposal.  In the
past (in EAP and NEA) we used the requirements as the criteria to ensure
that the proposals were meeting all the requirements and where there were
gaps, they had to call out the specific requirement and explain how it
fell short or notŠ.
I think it is up to the group to decide how they want to best make use of
the requirementsŠ.

>model requirement descriptions?
[NCW] I am fine making the edits and additions, if others want to help
that¹s great.  BUT most important is to get actual feedback from the group!

>
>Regards,
>
>Adam
>
>
>_______________________________________________
>sacm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/sacm

---

From: "Adam W. Montville" <[email-masked]>
Date: Tue, 21 Oct 2014 08:48:58 -0500

> On Oct 20, 2014, at 12:26 PM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
> 
> Hi Adam,

Yes, that might clarify.  What I was looking at is some recognition that we’re going to eventually need to agree on a controlled vocabulary for what a “capability” is.

> section and fold the requirements to the other sections?

I’m not sure of the appropriate action to take on this one.  On one hand, it can be confusing to have the same requirement stated twice.  On the other hand, if one requirement pertains to “meeting use cases” and another pertains to the information model, they might be considered separate requirements.  

Do others have helpful advice?

> I think it is up to the group to decide how they want to best make use of

I mentioned this specifically because it was a comment I had heard back in August.  I was hoping my comment would elicit further comments from the interested parties, but that does not appear to have happened.  For now, and until we gain some clarity, I guess we’ll leave it as is, unless others opine.

> that¹s great.  BUT most important is to get actual feedback from the group!

+1