Subject: Re: [sacm] [draft-ietf-sacm-terminology] Management Plane vs. Control Plane (#3)

From: jarrettlu <[email-masked]>
Date: Tue, 30 Jun 2015 11:46:17 -0700

I don't recall seeing discussion or consensus on this. Based on the intended functionalities of this component, I personally like the term Management Plane better. I think you should remove the "TBD..." part. Both the architecture draft and IM draft currently use the term Control Plane. They need the corresponding change to be consistent.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/3#issuecomment-117298944

---

From: Ira McDonald <[email-masked]>
Date: Tue, 30 Jun 2015 15:45:40 -0400

Hi,

I agree with Jarret.  I much prefer "Management Plane" to the rather
obscure (and telecom-centric) "Control Plane" term.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Jun 30, 2015 at 2:46 PM, jarrettlu <[email-masked]> wrote:

> I don't recall seeing discussion or consensus on this. Based on the
> intended functionalities of this component, I personally like the term
> Management Plane better. I think you should remove the "TBD..." part. Both
> the architecture draft and IM draft currently use the term Control Plane.
> They need the corresponding change to be consistent.
>
> —
> Reply to this email directly or view it on GitHub
> <https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/3#issuecomment-117298944>
> .
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>
>

---

From: "Natale, Bob" <[email-masked]>
Date: Tue, 30 Jun 2015 20:13:58 +0000

I am not an active contributor to the SACM work, so discount my input here accordingly … however, what term to use should not be a matter of preference … Management Plane and Control Plane have fairly well-defined meanings in network management architecture (and I’m pretty sure that Ira is familiar with the applicable references)… which one is SACM concerned with? … cannot tell from this thread (my bad, for not researching it further, I know … see opening statement!) … would almost be willing to bet you probably need both and need to use them properly.

The “New IP” uses them distinctly (and in accordance with their fairly well-defined meanings) in contexts which encompass but go way beyond “telecom-centric”.

Avanti,
BobN

From: sacm [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Tuesday, June 30, 2015 3:46 PM
To: [email-masked]; Ira McDonald
Cc: sacmwg/draft-ietf-sacm-terminology
Subject: Re: [sacm] [draft-ietf-sacm-terminology] Management Plane vs. Control Plane (#3)

Hi,

Cheers,
- Ira

mailto: [email-masked]<mailto:[email-masked]>

On Tue, Jun 30, 2015 at 2:46 PM, jarrettlu <[email-masked]<mailto:[email-masked]>> wrote:

—
Reply to this email directly or view it on GitHub<https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/3#issuecomment-117298944>.

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: Jarrett Lu <[email-masked]>
Date: Tue, 30 Jun 2015 14:26:35 -0700

Hi Bob,

Thanks for the reference to the existing definition of the three planes. 
I believe we are using the terms in SACM context, with our own 
definitions. For example, in the terminology draft, the term Management 
Plane is currently defined as :

       Architectural component providing common functions to all SACM
       participants, including authentication, authorization,
       capabilities mappings, and the like.

Similarly, the architecture draft defines Data Plane Capability as:

    Data plane capabilities represent the ability of a Provider or
    Consumer to perform a SACM-related task.  For example, the Collector
    capability indicates that a Provider can perform Collection tasks;
    the Evaluator capability indicates that a Consumer can perform
    Evaluation tasks.

While the actual definitions can be refined, the point is that we are 
not adhering to the (telecom) industry definitions.

Regards,

- Jarrett

On 06/30/15 01:13 PM, Natale, Bob wrote:
>
> I am not an active contributor to the SACM work, so discount my input 
> here accordingly ... however, what term to use should not be a matter 
> of preference ... Management Plane and Control Plane have fairly 
> well-defined meanings in network management architecture (and I'm 
> pretty sure that Ira is familiar with the applicable references)... 
> which one is SACM concerned with? ... cannot tell from this thread (my 
> bad, for not researching it further, I know ... see opening 
> statement!) ... would almost be willing to bet you probably need both 
> and need to use them properly.
>
> The "New IP" uses them distinctly (and in accordance with their fairly 
> well-defined meanings) in contexts which encompass but go way beyond 
> "telecom-centric".
>
> Avanti,
>
> BobN
>
> *From:*sacm [mailto:[email-masked]] *On Behalf Of *Ira McDonald
> *Sent:* Tuesday, June 30, 2015 3:46 PM
> *To:* [email-masked]; Ira McDonald
> *Cc:* sacmwg/draft-ietf-sacm-terminology
> *Subject:* Re: [sacm] [draft-ietf-sacm-terminology] Management Plane 
> vs. Control Plane (#3)
>
> Hi,
>
> mailto: [email-masked] <mailto:[email-masked]>
> On Tue, Jun 30, 2015 at 2:46 PM, jarrettlu <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     I don't recall seeing discussion or consensus on this. Based on
>     the intended functionalities of this component, I personally like
>     the term Management Plane better. I think you should remove the
>     "TBD..." part. Both the architecture draft and IM draft currently
>     use the term Control Plane. They need the corresponding change to
>     be consistent.
>
>     ---
>     <https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/3#issuecomment-117298944>.Image
>     removed by sender.
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 30 Jun 2015 17:27:16 -0400

Hi Bob,

Not enough caffeine - certainly Management (by admins) and Control (between
routers) are distinct.

I agree we should use these terms precisely (and not redefine them for
SACM).

"Overview of OAM Tools" (RFC 7276) defines the Data Plane, Control Plane,
and
Management Plane - and is, I imagine, the authoritative IETF reference.

"SDN: Layers and Architecture Terminology" (RFC 7426) expands their
definitions
for SDN, although it also replaces Data Plane with Forwarding Plane and
defines
additional Operational Plane and Application Plane terms.

This web page contrasts the three OAM terms:

  http://whatis.techtarget.com/definition/plane-in-networking

Cheers,
- Ira

On Tue, Jun 30, 2015 at 4:13 PM, Natale, Bob <[email-masked]> wrote:

> here accordingly … however, what term to use should not be a matter of
> preference … Management Plane and Control Plane have fairly well-defined
> meanings in network management architecture (and I’m pretty sure that Ira
> is familiar with the applicable references)… which one is SACM concerned
> with? … cannot tell from this thread (my bad, for not researching it
> further, I know … see opening statement!) … would almost be willing to bet
> you probably need both and need to use them properly.
>
>
>
> The “New IP” uses them distinctly (and in accordance with their fairly
> “telecom-centric”.
> *From:* sacm [mailto:[email-masked]] *On Behalf Of *Ira McDonald
> *Subject:* Re: [sacm] [draft-ietf-sacm-terminology] Management Plane vs.
> Control Plane (#3)
>
>
>
> Hi,
>