Subject: [sacm] [draft-ietf-sacm-architecture] Section 3.1.3 - Controller - Registration/Discovery (#29)

From: Jim Schaad <[email-masked]>
Date: Wed, 08 Jul 2015 16:43:11 -0700

version -03

There needs to be a statement about discovery of consumers as well.  This is needed in order to do spontaneous publication of attributes.

You need to be able to discover portions of the control plane as well.  You need to be able to find brokers and proxies as well as their capabilities.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/29

---

From: henkbirkholz <[email-masked]>
Date: Wed, 08 Jul 2015 23:04:31 -0700

In general, the discovery of target endpoints and the discovery of SACM components (with specific attributes, such as roles or functions or acting as a provider or consumer via SACM interfaces or even existing standard interfaces) must be distinguished, I think. This would also "solve" the discovery of consumers as well.

Also, the subsection "Registration/Discovery" is basically focusing on discovery and not registration.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/29#issuecomment-119830109

---

From: Nancy <[email-masked]>
Date: Sun, 19 Jul 2015 13:12:32 -0700

Fair point, the draft can be clearer in these distinctions.  I think I cited the "obvious" one which is the publishers, but consumers should be mentioned.
As for target endpoints, the discovery of target endpoints am not sure is a SACM component, but perhaps an operation of the SACM model?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/29#issuecomment-122699314