Subject: [sacm] Discussion of remaining work items for the information model

From: Lisa Lorenzin <[email-masked]>
Date: Tue, 21 Jul 2015 12:17:45 +0000

Greetings!

During the information model update yesterday, the WG chairs asked that for a discussion of what work items remain outstanding towards completion of the information model.

To get us started, here's a first pass based topics raised during the update yesterday, 
* finalize the list of identifying attributes
* define the standard relationships between attributes
* define the standard metadata required about attributes
* add a section addressing SACM operations
* review the draft for privacy implications and add a privacy considerations section

Plus a couple of additional thoughts
* terminology review for consistency with terminology draft
* address all the TODO comments/sections in the existing draft

What else?

							Regards,

								Lisa

-- 
Lisa Lorenzin    /    Principal Solutions Architect
[email-masked]    /    919-384-7275

Pulse Secure    /    https://www.pulsesecure.net
Facebook: https://www.facebook.com/pulsesecure1
LinkedIn: https://www.linkedin.com/company/pulse-secure
Twitter: https://twitter.com/PulseSecure1

---

From: "Haynes, Dan" <[email-masked]>
Date: Tue, 21 Jul 2015 12:40:50 +0000

Hi Lisa,

One other area, off the top of my head, is that we need to work is on the sections related to guidance.  Specifically, collection and evaluation guidance, if we want to consider something like OVAL as a starting point for SACM.

Thanks,

Danny

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Lisa Lorenzin
Sent: Tuesday, July 21, 2015 2:18 PM
To: [email-masked]
Subject: [sacm] Discussion of remaining work items for the information model

Greetings!

What else?

							Regards,

								Lisa

_______________________________________________
sacm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sacm

---

From: "Adam W. Montville" <[email-masked]>
Date: Tue, 21 Jul 2015 15:36:30 +0200

A quick look at the (potentially out-of-date) table of contents may yield additional items.  Each of the following are under “SACM Information Model” at this point.

Identifying Attributes
Software Component
Software Instance
Hardware Component
Hardware Instance
Network Interface
Address
Identity
Location
Endpoint
Endpoint Attribute Assertion
Attribute-value Pair
Evaluation Result
Report
SACM Component
Organization
Guidance
Internal Collection
External Collection
Evaluation
Retention
Reporting
User

The bold-faced items are those that seem appropriate to ensure we’ve appropriately covered.

As a note, when it comes to Software Component/Instance we might find some commonality with what MILE is doing (their session tomorrow will include discussion about expressing SoftwareType, which seems to be a similar problem we’ll face).

Adam

> On Jul 21, 2015, at 2:40 PM, Haynes, Dan <[email-masked]> wrote:
> 
> Hi Lisa,
>