Subject: [sacm] [draft-ietf-sacm-architecture] Section 3.1.3 - Controller - Authorization (#26)

From: Jim Schaad <[email-masked]>
Date: Wed, 08 Jul 2015 16:36:16 -0700

version -03

The bullet list does not seem to be specific to authorization as stated.  It would seem that this is really a new paragraph two to justify having a controller component. 

One of the things that is not mentioned here, but I don't know how to deal with it is the requirement that consumers must do something when they receive data.  That I think falls under this bullet.  (Requirement ARCH-007).

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/26

---

From: Nancy <[email-masked]>
Date: Sun, 19 Jul 2015 13:30:21 -0700

I don't see a bullet list for authorization (but some for authentication?).....

What do you mean by "consumers must do something when they receive data"?  Do you mean akin to an "ack"?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/26#issuecomment-122701537

---

From: Jim Schaad <[email-masked]>
Date: Mon, 20 Jul 2015 23:33:35 -0700

Yes - I got it backwards - the bullet list is under authentication.   I still think that comment follows.

Look at ARCH-007 as an example of consumer requirements.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-architecture/issues/26#issuecomment-123184785