Subject: [sacm] Changing the IM "Object" Construct to "Subject"

From: "Haynes, Dan" <[email-masked]>
Date: Thu, 19 May 2016 23:23:04 +0000

At IETF 95, there was an informal SACM working session after the first SACM session [1].  During the meeting, it was proposed that we change the name of the IM construct "Object" to "Subject".  The definitions effectively remain the same although worded differently:

    Object: Objects are the mechanism by which attributes (Section 3.1) and/or other objects can be logically grouped together to create more complex models.

    Subject: A subject is a richer structure that has a unique subject name and one or more attributes or subjects.

Anyways, during the virtual interim meeting on Tuesday, I realized that I forgot to bring this proposed change to the list for broader consensus.  As a result, I wanted to do that now as part of the IM updates.

Please let me know if you have any objections or concerns with this change by May 25th.

Thanks,

Danny

[1] https://www.ietf.org/mail-archive/web/sacm/current/msg03907.html

---

From: Jerome Athias <[email-masked]>
Date: Fri, 20 May 2016 08:17:02 +0300

Yes and No
While the wording is better, it seems there is still semantic
confusion regarding triples subject(-predicate-)object

2016-05-20 2:23 GMT+03:00 Haynes, Dan <[email-masked]>:
> At IETF 95, there was an informal SACM working session after the first SACM
> session [1].  During the meeting, it was proposed that we change the name of
> the IM construct “Object” to “Subject”.  The definitions effectively remain
> the same although worded differently:
>
>
>
>     Object: Objects are the mechanism by which attributes (Section 3.1)
> and/or other objects can be logically grouped together to create more
> complex models.
>
>
>
> Anyways, during the virtual interim meeting on Tuesday, I realized that I
> forgot to bring this proposed change to the list for broader consensus.  As
> a result, I wanted to do that now as part of the IM updates.
>
>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: "Haynes, Dan" <[email-masked]>
Date: Tue, 31 May 2016 16:58:42 +0000

Hi Jerome,

Using our new terms:

  Subject: unique name and one or more Subjects and/or Attributes
  Attribute: unique name and value

I think it would map as follows to subject-predicate-object.

  subject: Subject 
  predicate: always a "has-a" relationship
  object: Subject/Attribute

Does this help clarify things?

Thanks,

Danny

> -----Original Message-----
> From: Jerome Athias [mailto:[email-masked]]
> Sent: Friday, May 20, 2016 1:17 AM
> To: Haynes, Dan <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [sacm] Changing the IM "Object" Construct to "Subject"
> 
> Yes and No
> While the wording is better, it seems there is still semantic confusion
> regarding triples subject(-predicate-)object
> 
> > At IETF 95, there was an informal SACM working session after the first
> > SACM session [1].  During the meeting, it was proposed that we change
> > the name of the IM construct “Object” to “Subject”.  The definitions
> > effectively remain the same although worded differently:
> >
> >
> >
> >     Object: Objects are the mechanism by which attributes (Section
> > 3.1) and/or other objects can be logically grouped together to create
> > more complex models.
> >
> >
> >
> >     Subject: A subject is a richer structure that has a unique subject
> > name and one or more attributes or subjects.
> >
> >
> >
> > Anyways, during the virtual interim meeting on Tuesday, I realized
> > that I forgot to bring this proposed change to the list for broader
> > consensus.  As a result, I wanted to do that now as part of the IM updates.
> >
> >
> >