Subject: [sacm] FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

From: "Haynes, Dan" <[email-masked]>
Date: Mon, 16 May 2016 18:54:37 +0000

Hi Everyone,

More recently, we have continued our I-D and WG IM merger work in Henk's GitHub repository [1] for easier collaboration and in case anyone wants to follow along with our progress :).

With that said, Henk, Nancy, Mike, and I have spent some more time merging the text between the I-D IM [1] and the WG IM [2] and would like to make some additional proposals.

1.       Replace the text in the beginning of Section 3 of the WG IM with the text from Section "Structure of Information Elements" of the I-D IM (note: we plan to maintain the current IPFIX syntax sections although it will be updated in the near future to address some of the concerns Jim raised)

2.       Insert Sections "SACM Content Elements" and "SACM Statements" of the I-D IM into Section 3 of the WG IM as subsections

3.       Replace Section 3.4 of the WG IM with Section "Relationships" in the I-D IM

4.       Insert Section "Events" of the I-D IM into the Section 3 of the WG IM as a subsection. Remove Section 5.4.5 of the WG IM.

Please review and provide any feedback by Tuesday May 31st.  Let me know if you have any questions.

As a side note, we plan to briefly discuss SACM statements, content elements, relationships, events, and categories at tomorrow's virtual interim meeting.

Thanks,

Danny

[1] https://github.com/henkbirkholz/sacmim/blob/master/draft-camwinget-sacm-information-model-01.md
[2] https://datatracker.ietf.org/doc/draft-ietf-sacm-information-model/

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 17 May 2016 10:28:49 +0000

Hi,

I do not know if I am the only one, but I have difficulties visualizing the proposed changes as a 'dry' intellectual exercise.

I suspect that you have a work-in-progress version that includes these changes. Why do not you post it together with the Log of Changes, and we can more easily see and debate what we like or do not like. Any I-D is anyway w-i-p.

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Monday, May 16, 2016 9:55 PM
To: [email-masked]
Subject: [sacm] FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

Hi Everyone,

Thanks,

Danny

[1] https://github.com/henkbirkholz/sacmim/blob/master/draft-camwinget-sacm-information-model-01.md<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_henkbirkholz_sacmim_blob_master_draft-2Dcamwinget-2Dsacm-2Dinformation-2Dmodel-2D01.md&d=CwQFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=9ZyV_bkMpYQnoCCKlFxN_bYDtaT6wRHC1ouRXv2B1M4&s=3SjJWUS1QN6nPl-TW5joJfntnd8o2Tmd6VSVa91Fe5k&e=>
[2] https://datatracker.ietf.org/doc/draft-ietf-sacm-information-model/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsacm-2Dinformation-2Dmodel_&d=CwQFAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=9ZyV_bkMpYQnoCCKlFxN_bYDtaT6wRHC1ouRXv2B1M4&s=JREucFbqo4Xgn1ObI71zkq0rDNAJnjOWaM5oO-S93gY&e=>

---

From: "Haynes, Dan" <[email-masked]>
Date: Tue, 17 May 2016 11:42:07 +0000

Hi Dan,

That seems like a reasonable request.  I will take the current WG IM and integrate the proposed changes from the I-D IM into it and send it out on this thread so everyone can more easily review the changes.

Thanks,

Danny

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Tuesday, May 17, 2016 6:29 AM
To: Haynes, Dan <[email-masked]>; [email-masked]
Subject: RE: FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

Hi,

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Monday, May 16, 2016 9:55 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sacm] FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

Hi Everyone,

Thanks,

Danny

---

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 25 May 2016 12:20:15 +0000

Just an update on this. I committed the proposed changes regarding the merger in a branch in the IM GitHub repository [1].

For your convenience, I also have attached a updated text version so you can diff it against the version up on the IETF site [2].

A couple of things to note about this draft (in addition to the changes listed earlier in this thread):

*         Includes text for SACM Statements and SACM Content-Elements. There was discussion around whether or not this was needed at the Virtual Interim Meeting [3]. Please review and provide feedback.

*         Contains change from "Object" to "Subject". There is ongoing discussion here [4].

*         Does not include the IEs from the I-D IM. These will be carried over once the IPFIX syntax is updated as long as there are no objections to the proposed IEs.  So far, we haven't heard any, but, the thread is here [5] in case you want to provide any feedback.

*         The WG IM is now "standards track" instead of "informational". I had forgotten to update that in the XML version of the I-D when we made the decision last year [6].

*         Removes text about SACM Components [7]. This was discussed here [8].

*         The updated IPFIX syntax is not included in this revision.

As a reminder, we have put a deadline of May 31st for review and feedback so that we can have a revised draft for June 8th which is a week before the next virtual interim meting (June 15th).

Let me know if you have any questions.

Thanks,

Danny

[1] https://github.com/sacmwg/draft-ietf-sacm-information-model/blob/proposed-im-merger-changes/draft-ietf-sacm-information-model.xml
[2] https://datatracker.ietf.org/doc/draft-ietf-sacm-information-model/
[3] http://www.ietf.org/mail-archive/web/sacm/current/msg04043.html
[4] http://www.ietf.org/mail-archive/web/sacm/current/msg04014.html
[5] http://www.ietf.org/mail-archive/web/sacm/current/msg03961.html
[6] https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/29
[7] https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/33
[8] http://www.ietf.org/mail-archive/web/sacm/current/msg03955.html

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Tuesday, May 17, 2016 7:42 AM
To: Romascanu, Dan (Dan) <[email-masked]>; [email-masked]
Subject: Re: [sacm] FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

Hi Dan,

Thanks,

Danny

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Tuesday, May 17, 2016 6:29 AM
To: Haynes, Dan <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: FOR REVIEW: IM Merge - Additional changes in the I-D IM to be considered for the WG IM

Hi,

Regards,

Dan

Hi Everyone,

Thanks,

Danny