Subject: [sacm] Disposition of Expired Architecture Draft

From: Adam Montville <[email-masked]>
Date: Tue, 17 May 2016 12:16:10 -0500

All:

During today’s virtual interim meeting we briefly discussed what we should do about the expired architecture draft [1].  Some of us would like to resubmit the draft and keep it alive, whereas others would like to let it sit in an expired state until we think we need it again.

As a contributor, I share the latter opinion for the following reasons.

It seems that the architecture draft (an informational draft) was conceived as an abstract notion against which we would be able to pit implementations (i.e. solutions drafts).  XMPP-grid was one such solution, but it has gone on to a different working group, and our focus now seems to be upon the Endpoint Compliance Standard (ECS) draft as our architectural solution [2].  Further, and I believe some would agree, the architecture draft feels very XMPP-grid focused (it essentially describes what XMPP-grid implements).

I am aware that we have not adopted the ECS draft, but I also believe it has the most momentum at this point and is a reasonable solution for our work.  It may also be instructive to note that we are in the middle of an adoption call for a draft that presumes an ECS or ECS-like architecture [3].

My proposal is that we allow the architecture draft to remain in an expired state, primarily for lack of relevance to our present course.

Kind regards,

Adam

[1] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/ <https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/>
[2] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/ <https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/>
[3] https://mailarchive.ietf.org/arch/msg/sacm/L3A-n6P3U-Khrhs_mYcXtjwy9-w <https://mailarchive.ietf.org/arch/msg/sacm/L3A-n6P3U-Khrhs_mYcXtjwy9-w>

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 17 May 2016 11:08:15 -0700

I was under the impression that the draft was to be parked for now and not that the work was being abandoned.  If the work is in a parked state, then I believe that it should be republished, quite likely without changes, in order to keep the document visible to people who are using the tools and getting an impression of what the working group is doing.

If the work is being abandoned, then I would agree that it can expire and go away.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Tuesday, May 17, 2016 10:16 AM
To: <[email-masked]> <[email-masked]>
Subject: [sacm] Disposition of Expired Architecture Draft

All:

Kind regards,

Adam

[1] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/

[2] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/

[3] https://mailarchive.ietf.org/arch/msg/sacm/L3A-n6P3U-Khrhs_mYcXtjwy9-w

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 17 May 2016 20:50:31 +0000

I too believe that we agreed we would park it.  I still believe it is a draft that shows how all the pieces of SACM would fit together (e.g. data models, interfaces and transports)....so, I am happy to resubmit it to keep it visible.

Thanks, Nancy

From: sacm <[email-masked]<mailto:[email-masked]>> on behalf of Jim Schaad <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 17, 2016 at 11:08 AM
To: 'Adam Montville' <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sacm] Disposition of Expired Architecture Draft

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Tuesday, May 17, 2016 10:16 AM
To: <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>>
Subject: [sacm] Disposition of Expired Architecture Draft

All:

During today's virtual interim meeting we briefly discussed what we should do about the expired architecture draft [1].  Some of us would like to resubmit the draft and keep it alive, whereas others would like to let it sit in an expired state until we think we need it again.

Kind regards,

Adam

---

From: "Jim Bieda (jbieda)" <[email-masked]>
Date: Wed, 18 May 2016 05:45:24 +0000

While I understand our agreement to park the architecture draft, there is the implication that we are tacitly adopting an “ECP-like" architecture through a back door.  If that is indeed the issue, then I propose we bring it up for open discussion.  In my view, the architectures are somewhat similar with the exception of the transport layer between the client and the server (XMPP-grid vs. PT-TLS).

So, is there an official call to adopt the ECP draft (https://tools.ietf.org/html/draft-haynes-sacm-ecp-00) as our architecture and implementation?

If so, does that mean we plan to deprecate the current “parked” architecture draft?

My apologies for being difficult, but I’m Just trying to understand the process here.  Of course, I’d also like to understand if there are any residual TCG licensing rights to ECP if we’re planning to discuss its adoption in the IETF.

Thanks,
Jim

From: sacm <[email-masked]<mailto:[email-masked]>> on behalf of Nancy Cam-Winget <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 17, 2016 at 1:50 PM
To: Jim Schaad <[email-masked]<mailto:[email-masked]>>, 'Adam Montville' <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sacm] Disposition of Expired Architecture Draft

I too believe that we agreed we would park it.  I still believe it is a draft that shows how all the pieces of SACM would fit together (e.g. data models, interfaces and transports)….so, I am happy to resubmit it to keep it visible.

Thanks, Nancy

Jim

All:

Kind regards,

Adam

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 18 May 2016 11:31:46 +0000

I had the same recollection. The consensus was to park, but my reading is that we need to continue to re-issue in order to have the I-D available for reference. It’s still my preference.

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Jim Schaad
Sent: Tuesday, May 17, 2016 9:08 PM
To: 'Adam Montville'; [email-masked]
Subject: Re: [sacm] Disposition of Expired Architecture Draft

Jim

All:

Kind regards,

Adam

[1] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_wg_sacm_draft-2Dietf-2Dsacm-2Darchitecture_&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=SqIFLDbg2vjBFsuqgmy-ne5eyFNi0fPZWX_k1xI4hAo&e=>
[2] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_wg_sacm_draft-2Dietf-2Dsacm-2Darchitecture_&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=SqIFLDbg2vjBFsuqgmy-ne5eyFNi0fPZWX_k1xI4hAo&e=>
[3] https://mailarchive.ietf.org/arch/msg/sacm/L3A-n6P3U-Khrhs_mYcXtjwy9-w<https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_sacm_L3A-2Dn6P3U-2DKhrhs-5FmYcXtjwy9-2Dw&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=QbVuF9tjoaBX-YGNnbksld0uzW9KBXZgiRq_rJ4wl90&e=>

---

From: Adam Montville <[email-masked]>
Date: Thu, 19 May 2016 19:11:13 -0500

If the consensus to park remains intact we can re-issue if we feel it’s necessary.

If there’s no real distraction to the group by having the architecture draft re-issued, and we can move on to more pertinent discussions, then we can probably just re-issue the draft.

Any objections?

> On May 18, 2016, at 6:31 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> From: sacm [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Adam Montville
> To: <[email-masked] <mailto:[email-masked]>> <[email-masked] <mailto:[email-masked]>>
> [1] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_wg_sacm_draft-2Dietf-2Dsacm-2Darchitecture_&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=SqIFLDbg2vjBFsuqgmy-ne5eyFNi0fPZWX_k1xI4hAo&e=>
> [2] https://tools.ietf.org/wg/sacm/draft-ietf-sacm-architecture/ <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_wg_sacm_draft-2Dietf-2Dsacm-2Darchitecture_&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=SqIFLDbg2vjBFsuqgmy-ne5eyFNi0fPZWX_k1xI4hAo&e=>
> [3] https://mailarchive.ietf.org/arch/msg/sacm/L3A-n6P3U-Khrhs_mYcXtjwy9-w <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_sacm_L3A-2Dn6P3U-2DKhrhs-5FmYcXtjwy9-2Dw&d=CwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=05C6A99sghgTYbR_U-ElYi3YKfq1lTnaasdOJLXx-nI&s=QbVuF9tjoaBX-YGNnbksld0uzW9KBXZgiRq_rJ4wl90&e=>