Subject: Re: [sacm] Changing the IM "Object" Construct to "Subject"

From: Jerome Athias <[email-masked]>
Date: Sat, 4 Jun 2016 09:58:10 +0300

IMHO I'm afraid not.
Where Subject is coming from? (is that aligned with IETF terminology,
an RFC...?)
It's adding complexity/confusion for me while for example not aligning
anymore with NIST SP 800-53A

2016-05-31 19:58 GMT+03:00 Haynes, Dan <[email-masked]>:
> Hi Jerome,
>
> Using our new terms:
>
>   Subject: unique name and one or more Subjects and/or Attributes
>   Attribute: unique name and value
>
> I think it would map as follows to subject-predicate-object.
>
>   subject: Subject
>   predicate: always a "has-a" relationship
>   object: Subject/Attribute
>
> Does this help clarify things?
>
> Thanks,
>
> Danny
>
>> -----Original Message-----
>> From: Jerome Athias [mailto:[email-masked]]
>> Sent: Friday, May 20, 2016 1:17 AM
>> To: Haynes, Dan <[email-masked]>
>> Cc: [email-masked]
>> Subject: Re: [sacm] Changing the IM "Object" Construct to "Subject"
>>
>> Yes and No
>> While the wording is better, it seems there is still semantic confusion
>> regarding triples subject(-predicate-)object
>>
>> 2016-05-20 2:23 GMT+03:00 Haynes, Dan <[email-masked]>:
>> > At IETF 95, there was an informal SACM working session after the first
>> > SACM session [1].  During the meeting, it was proposed that we change
>> > the name of the IM construct “Object” to “Subject”.  The definitions
>> > effectively remain the same although worded differently:
>> >
>> >
>> >
>> >     Object: Objects are the mechanism by which attributes (Section
>> > 3.1) and/or other objects can be logically grouped together to create
>> > more complex models.
>> >
>> >
>> >
>> >     Subject: A subject is a richer structure that has a unique subject
>> > name and one or more attributes or subjects.
>> >
>> >
>> >
>> > Anyways, during the virtual interim meeting on Tuesday, I realized
>> > that I forgot to bring this proposed change to the list for broader
>> > consensus.  As a result, I wanted to do that now as part of the IM updates.
>> >
>> >
>> >
>> > Please let me know if you have any objections or concerns with this
>> > change by May 25th.
>> >
>> >
>> >
>> > Thanks,
>> >
>> > Danny
>> >
>> >
>> >
>> > [1] https://www.ietf.org/mail-archive/web/sacm/current/msg03907.html
>> >
>> >
>> > _______________________________________________
>> > sacm mailing list
>> > [email-masked]
>> > https://www.ietf.org/mailman/listinfo/sacm
>> >

---

From: Adam Montville <[email-masked]>
Date: Mon, 6 Jun 2016 07:32:33 -0500

I don’t think “subject” is rooted in anything IETF/RFC at this point—it’s something we are exploring to provide a better way of articulating what we’re getting at within the information model.  I think some concrete examples might help.  An endpoint could be a subject that has a network interface (subject-predicate-object relationship).  That network interface “has a” IP address (another subject-predicate-object relationship).

I’m not saying those are exact examples, but they should be enough to demonstrate the intent.

Adam

> On Jun 4, 2016, at 1:58 AM, Jerome Athias <[email-masked]> wrote:
> 
> IMHO I'm afraid not.

---

From: Jerome Athias <[email-masked]>
Date: Mon, 6 Jun 2016 18:00:18 +0300

Right. Just putting things on the table...

So I think we agree on Objects-Attributes.
For physical things, I do like to use the notion of Components (e.g.
Components of a Device. And a Component could have (sub)Components.
e.g. processor, SIM card, etc.)

Now, back to the subject :p and your examples, just for information,
in (STIX)CybOX they use the term Top Level Object (TLO).