Subject: [sacm] NIST IR 8060 - Guidelines for the Creation of Interoperable Software Identification (SWID) Tags

From: "Schmidt, Charles M." <[email-masked]>
Date: Wed, 15 Jun 2016 19:34:31 +0000

Hello,

On today's call Jim requested a link to the NIST Interagency Report on SWID
tags. The link to that document (NISTIR 8060 "Guidelines for the Creation of
Interoperable Software Identification (SWID) Tags") is here:
http://nvlpubs.nist.gov/nistpubs/ir/2016/NIST.IR.8060.pdf

Between this and the freely available XML schema for ISO SWID 2015 tags
(http://standards.iso.org/iso/19770/-2/2015-current/schema.xsd) hopefully
this addresses most of the availability concerns regarding ISO SWID 2015 as
a data model.

And for the sake of being complete, the XML schema for ISO SWID 2009 is also
available (http://standards.iso.org/iso/19770/-2/2009/schema.xsd). Note that
the NIST document deals with SWID 2015, not SWID 2009.

Charles

---

From: Adam Montville <[email-masked]>
Date: Fri, 17 Jun 2016 17:03:07 -0500

Thank you, Charles.  This should, I agree, go a long way toward addressing availability concerns.

Adam

> On Jun 15, 2016, at 2:34 PM, Schmidt, Charles M. <[email-masked]> wrote:
> 
> Hello,
> 
> On today's call Jim requested a link to the NIST Interagency Report on SWID tags. The link to that document (NISTIR 8060 "Guidelines for the Creation of Interoperable Software Identification (SWID) Tags") is here: http://nvlpubs.nist.gov/nistpubs/ir/2016/NIST.IR.8060.pdf <http://nvlpubs.nist.gov/nistpubs/ir/2016/NIST.IR.8060.pdf>
> Between this and the freely available XML schema for ISO SWID 2015 tags (http://standards.iso.org/iso/19770/-2/2015-current/schema.xsd <http://standards.iso.org/iso/19770/-2/2015-current/schema.xsd>) hopefully this addresses most of the availability concerns regarding ISO SWID 2015 as a data model.
> 
> And for the sake of being complete, the XML schema for ISO SWID 2009 is also available (http://standards.iso.org/iso/19770/-2/2009/schema.xsd <http://standards.iso.org/iso/19770/-2/2009/schema.xsd>). Note that the NIST document deals with SWID 2015, not SWID 2009.
> 
> Charles
> 
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm