Subject: [sacm] IM Issue #2 from IETF 96 - IE Naming Conventions

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 20 Jul 2016 08:42:18 +0000

We discussed a few open issues during the first SACM session at IETF 96 and I wanted to follow up on the list to see if I could get some additional feedback.  Please review each question and let me know if you have any feedback on the proposed resolutions.

QUESTION:
Should SACM adopt the following IPFIX naming conventions for IM information elements?

1.       Names SHOULD be descriptive

2.       Names MUST be unique within the SACM registry. Enterprise-specific names SHOULD be prefixed with a vendor name.

3.       Names MUST start with lowercase letters

4.       Composed names MUST use capital letters for the first letter of each part (e.g. sourceMacAddress)

DISCUSSION:
During the meeting, it was asked if rather than enterprise-specific names being prefixed with a vendor name if it would be better to have the names prefixed with an organizations Private Enterprise Number (http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers). It was also noted that the syntax for composed names (4) doesn't really matter and that we just need to pick one. As a result, a choice of options will be provided.

PROPOSED RESOLUTION:
SACM should adopt the following naming conventions.

1.       Names SHOULD be descriptive

2.       Names MUST be unique within the SACM registry. Enterprise-specific names SHOULD be prefixed with a Private Enterprise Number (PEN)

3.       Names MUST start with lowercase letters unless a PEN is prefixed to it

4.       Composed names MUST use capital letters for the first letter of each part

Options for representing composed names (IPFIX uses option 1).  NOTE: (3) and (4) will be updated to align with whichever option is selected below.

1.       sourceMacAddress

2.       SourceMacAddress

3.       source-mac-address

4.       Source-Mac-Address

5.       source_mac_address

6.       Source_Mac_Address

7.       Other? Please specify :).

Please let me know if you have any questions.

Thanks,

Danny

---

From: Adam Montville <[email-masked]>
Date: Wed, 20 Jul 2016 13:04:02 +0200

Why don’t we just go with what IPFIX does, because we’re leveraging IPFIX.  Then, I would say option 1 (i.e. sourceMacAddress).

(Also, I really don’t wan to see this turn into a debate of preferences.)

> On Jul 20, 2016, at 10:42 AM, Haynes, Dan <[email-masked]> wrote:
> 
> During the meeting, it was asked if rather than enterprise-specific names being prefixed with a vendor name if it would be better to have the names prefixed with an organizations Private Enterprise Number (http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers <http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers>). It was also noted that the syntax for composed names (4) doesn’t really matter and that we just need to pick one. As a result, a choice of options will be provided.
> 
> PROPOSED RESOLUTION:

---

From: "Haynes, Dan" <[email-masked]>
Date: Wed, 20 Jul 2016 12:23:27 +0000

I would be happy with option 1 too.

-Danny

From: Adam Montville [mailto:[email-masked]]
Sent: Wednesday, July 20, 2016 1:04 PM
To: Haynes, Dan <[email-masked]>
Cc: [email-masked]
Subject: Re: [sacm] IM Issue #2 from IETF 96 - IE Naming Conventions

On Jul 20, 2016, at 10:42 AM, Haynes, Dan <[email-masked]<mailto:[email-masked]>> wrote:

QUESTION:

DISCUSSION:
During the meeting, it was asked if rather than enterprise-specific names being prefixed with a vendor name if it would be better to have the names prefixed with an organizations Private Enterprise Number (http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers). It was also noted that the syntax for composed names (4) doesn’t really matter and that we just need to pick one. As a result, a choice of options will be provided.

PROPOSED RESOLUTION:

1.       sourceMacAddress
2.       SourceMacAddress
3.       source-mac-address
4.       Source-Mac-Address
5.       source_mac_address
6.       Source_Mac_Address

Thanks,

Danny

---

From: "Haynes, Dan" <[email-masked]>
Date: Thu, 21 Jul 2016 08:56:35 +0000

Do others have thoughts on this?  Can everyone live with option 1 :)?

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Wednesday, July 20, 2016 2:23 PM
To: Adam Montville <[email-masked]>
Cc: [email-masked]
Subject: Re: [sacm] IM Issue #2 from IETF 96 - IE Naming Conventions

-Danny

From: Adam Montville [mailto:[email-masked]]
Sent: Wednesday, July 20, 2016 1:04 PM
To: Haynes, Dan <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] IM Issue #2 from IETF 96 - IE Naming Conventions

QUESTION:

DISCUSSION:

PROPOSED RESOLUTION:

1.       sourceMacAddress
2.       SourceMacAddress
3.       source-mac-address
4.       Source-Mac-Address
5.       source_mac_address
6.       Source_Mac_Address

Thanks,

Danny

---

From: Jerome Athias <[email-masked]>
Date: Thu, 21 Jul 2016 12:17:17 +0300

I like Option 2, but can live with Option 1.
(As long I can catch a pikatchu in the pokemonWorld)

On Thu, Jul 21, 2016 at 11:56 AM, Haynes, Dan <[email-masked]> wrote:
> Why don’t we just go with what IPFIX does, because we’re leveraging IPFIX.
> Then, I would say option 1 (i.e. sourceMacAddress).
>
>
>
> We discussed a few open issues during the first SACM session at IETF 96 and
> I wanted to follow up on the list to see if I could get some additional
> feedback.  Please review each question and let me know if you have any
> feedback on the proposed resolutions.
>
>
>
> QUESTION:
>
> 2.       Names MUST be unique within the SACM registry. Enterprise-specific
> names SHOULD be prefixed with a vendor name.
>
> During the meeting, it was asked if rather than enterprise-specific names
> being prefixed with a vendor name if it would be better to have the names
> prefixed with an organizations Private Enterprise Number
> (http://www.iana.org/assignments/enterprise-numbers/enterprise-numbers). It
> was also noted that the syntax for composed names (4) doesn’t really matter
> and that we just need to pick one. As a result, a choice of options will be
> provided.
>
>
>
> PROPOSED RESOLUTION:
>
> 2.       Names MUST be unique within the SACM registry. Enterprise-specific
> names SHOULD be prefixed with a Private Enterprise Number (PEN)
>
> Options for representing composed names (IPFIX uses option 1).  NOTE: (3)
> and (4) will be updated to align with whichever option is selected below.
>
>
>
> 1.       sourceMacAddress
>
> 2.       SourceMacAddress
>
> 3.       source-mac-address
>
> 4.       Source-Mac-Address
>
> 5.       source_mac_address
>
> 6.       Source_Mac_Address
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: "Haynes, Dan" <[email-masked]>
Date: Thu, 21 Jul 2016 09:31:47 +0000

Thanks for the quick reply Jerome. Sorry, I do not have a pikachu for you :(.

-Danny

> -----Original Message-----
> From: Jerome Athias [mailto:[email-masked]]
> Sent: Thursday, July 21, 2016 11:17 AM
> Cc: Adam Montville <[email-masked]>; [email-masked]
> > We discussed a few open issues during the first SACM session at IETF
> > 96 and I wanted to follow up on the list to see if I could get some
> > additional feedback.  Please review each question and let me know if
> > you have any feedback on the proposed resolutions.
> >
> >
> >
> > QUESTION:
> >
> > During the meeting, it was asked if rather than enterprise-specific
> > names being prefixed with a vendor name if it would be better to have
> > the names prefixed with an organizations Private Enterprise Number
> > (http://www.iana.org/assignments/enterprise-numbers/enterprise-
> numbers
> > ). It was also noted that the syntax for composed names (4) doesn’t
> > really matter and that we just need to pick one. As a result, a choice
> > of options will be provided.
> >
> >
> >
> > PROPOSED RESOLUTION:
> >
> > Options for representing composed names (IPFIX uses option 1).  NOTE:
> > (3) and (4) will be updated to align with whichever option is selected below.
> >
> >
> >
> > 1.       sourceMacAddress
> >
> > 2.       SourceMacAddress
> >
> > 3.       source-mac-address
> >
> > 4.       Source-Mac-Address
> >
> > 5.       source_mac_address
> >
> > 6.       Source_Mac_Address
> >

---

From: Jim Schaad <[email-masked]>
Date: Thu, 21 Jul 2016 12:56:22 +0200

I think that these are all good rules.  My personal preference is for
camel-case on identifiers which is what is recommended.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Haynes, Dan
Sent: Wednesday, July 20, 2016 10:42 AM
To: [email-masked]
Subject: [sacm] IM Issue #2 from IETF 96 - IE Naming Conventions

QUESTION:

Should SACM adopt the following IPFIX naming conventions for IM information
elements?

4.      Composed names MUST use capital letters for the first letter of each
part (e.g. sourceMacAddress)

DISCUSSION:

was also noted that the syntax for composed names (4) doesn't really matter

PROPOSED RESOLUTION: 

3.      Names MUST start with lowercase letters unless a PEN is prefixed to
it

4.      Composed names MUST use capital letters for the first letter of each
part

1.      sourceMacAddress

2.      SourceMacAddress

3.      source-mac-address

4.      Source-Mac-Address

5.      source_mac_address

6.      Source_Mac_Address

Thanks,

Danny