Subject: Re: [sacm] [sacmwg/draft-ietf-sacm-information-model] Define a Providence/Chain of Custody Information Module (#8)

From: Danny Haynes <[email-masked]>
Date: Fri, 06 Jan 2017 11:10:23 -0800

Can we close out this issue since it sounds like we are in agreement that we do not need to define an explicit mechanism for provenance and chain-of-custody and because we have a mechanism to add any metadata IEs that we may need to the IM? 

-- 
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/8#issuecomment-270980141

---

From: adammontville <[email-masked]>
Date: Fri, 06 Jan 2017 11:21:37 -0800

+1

-- 
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/8#issuecomment-270982725

---

From: Jim Schaad <[email-masked]>
Date: Mon, 09 Jan 2017 14:31:10 -0800

If you want to close it - that is fine.  However what I asked for was the elements to be defined which is not apparently going to be done.

-- 
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/8#issuecomment-271428805

---

From: Danny Haynes <[email-masked]>
Date: Tue, 10 Jan 2017 04:32:38 -0800

Hi Jim,
Looking at your original post, you mention a few requirements (assuming requirements -04 given the date of the post).  I think the current IM captures at least some of the IEs for these requirements (if not completely).

•	DM-008: ...MUST include the ability to identify data from a specific provider.
  o	dataSource (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.32)
  o	targetEndpoint (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.5)
  o	dataOrigin (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.31)
  o	statementType (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.31)
  o	contentType (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.126). 

Currently, it says “type”. I think this needs to be updated to contentType. 

•	DM-011: ...MUST include the ability for providers to identify the data origin and provide a method for provenance information to be captured and communicated.
  o	dataOrigin (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.31)
  o	Regarding more generic provenance constructs, implementers are free to define new IEs that capture their representation of what provenance means

•	DM-014: ...SHOULD allow the provider to include the information's origination time.
  o	creationTimestamp (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.120)

•	DM-015: ...SHOULD allow the provider to include attributes defining how the data was generated (e.g. self-reported, reported by aggregator, scan result, etc.).
  o	collectionTaskType (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.27)
  o	

•	DM-016: ...SHOULD allow the provider to include attributes defining the location of the data source.
  o	dataSource (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.32)
  o	targetEndpoint (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.5)
  o	locationName (https://tools.ietf.org/html/draft-ietf-sacm-information-model-08#section-7.52)

Do these IEs align with your interpretations of the requirements? 

Lastly, additional IEs can be included, as necessary, to satisfy the needs of the WG. If there are major gaps, please propose them and they can be incorporated into the IM.

Thanks,

Danny

-- 
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/8#issuecomment-271564115

---

From: Jim Schaad <[email-masked]>
Date: Tue, 10 Jan 2017 14:19:27 -0800

>From that it looks like all except for the crypto aspects are present.  However, I am not the person to say what does and does not need to be present and what does and does not need to be documented as a common IM understanding of how this information is setup.  

-- 
You are receiving this because you commented.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/8#issuecomment-271716333