Subject: Re: [sacm] [sacmwg/draft-ietf-sacm-terminology] Guidance (#29)

From: henkbirkholz <[email-masked]>
Date: Fri, 13 Jan 2017 07:59:54 -0800

Addressed by differentiating two types of guidance in the definition:

* declarative guidance

* imperative guidance

The only non-trivial and discussion-worthy exmaple we could find in regard to "configuration is transported via the management-plane was the use of a DHCP client by a target endpoint.

The conclusion was that the configuration here is the DHCP configuration stored on the DHPC server and the configuration to use a DHCP client (and not to configure an IP address) on the target endpoint. The result of this configuration is the creation and synchronization of lease files, which represent the resulting state of a (typically) randomly selected IP address to used by the target endpoint for a span of time (defined by the configuration of the DHCP server). If there is a static association of a MAC address used by one of the target endpoint's interfaces and an IP address provided by the DHCP server, this results still results in - now rather deterministic - state on both sides (the successful distribution of the pre-selected address).

I will leave this issue open to allow for comments or questions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/29#issuecomment-272478297

---

From: adammontville <[email-masked]>
Date: Sat, 28 Jan 2017 03:43:35 -0800

I like the differences between declarative and imperative guidance, but I'm not quite following the DHCP reasoning.  The reason I like declarative and imperative is because, eventually, I can see remediation guidance being imperative consequent to some declarative guidance resulting in detection of an undesired state.  Perhaps that was the DHCP example?  Declarative guidance used to determine the state of both the DHCP server and the DHCP client, and then some imperative guidance following to remedy the situation, so that the DHCP server and DHCP client start working as desired.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/29#issuecomment-275843542