Subject: [sacm] Use of GitHub for ECP draft?

From: Adam Montville <[email-masked]>
Date: Thu, 29 Mar 2018 06:55:50 -0500

Hello ECP authors and SACM Chairs,

I've been spending some time with the latest ECP draft, and I would like to make some comments about it. I went to take a look at the GitHub repository [1] and saw that it's empty. I was going to ask if you'd prefer comments on the list directly or whether you'd prefer issues to be created.

Looks like I'll send comments to the list when they're ready. :-)

Have you any plans to use GitHub for the ECP draft? FWIW, I've found GitHub helpful when working with other drafts in this WG - not only for the added transparency of draft state, but for the project and issue management capabilities. 

Kind regards,

Adam

---

From: "Fitzgerald-McKay, Jessica M" <[email-masked]>
Date: Thu, 29 Mar 2018 17:07:09 +0000

Hello, all,

Adam, thanks for taking the time to read through the latest ECP draft. I'm looking forward to your comments. We haven't gotten many, and I appreciate the feedback.

Because we haven't received a lot of feedback yet, I am hesitant to use GitHub to coordinate comments. Not everyone uses GitHub with regularity, and I am worried it presents an additional barrier to getting any feedback at all. And, we don't really need to help right now to organize our (current lack of) comments. However, I appreciate the need for transparency. Is there any concern about using the list for comments? Is that less transparent than using GitHub?

I could be persuaded that this is a better path, particularly if the chairs want us to move in that direction. Karen, Chris, any thoughts?

Thanks,
Jess

-----Original Message-----
From: Adam Montville <[email-masked]> 
Sent: Thursday, March 29, 2018 7:56 AM
To: [email-masked]; <[email-masked]> <[email-masked]>
Cc: <[email-masked]> <[email-masked]>
Subject: [Non-DoD Source] Use of GitHub for ECP draft?

Kind regards,

Adam

---

From: Adam Montville <[email-masked]>
Date: Thu, 29 Mar 2018 12:19:34 -0500

I have no reservation about using the list. My comment on additional transparency was about the editor's copy being readily available (i.e. like the terminology draft is: https://github.com/sacmwg/draft-ietf-sacm-terminology <https://github.com/sacmwg/draft-ietf-sacm-terminology>) - of course, using the list and submitted, numbered drafts is inherently transparent.

I agree with you, though, that whatever gets (and keeps) the conversation going is the way we should roll.

Adam

> On Mar 29, 2018, at 12:07 PM, Fitzgerald-McKay, Jessica M <[email-masked]> wrote:
> 
> Hello, all,
>