Subject: [sacm] Referencing the TCG IF-IMC and IF-IMV Specifications for ECP

From: "Haynes Jr., Dan" <[email-masked]>
Date: Mon, 2 Apr 2018 18:10:59 +0000

Hi Everyone,

The current ECP draft (-01) calls out the TCG IF-IMC [1] and IF-IMV [2] specifications which serve as interfaces between Posture Collectors and the Posture Broker Client and Posture Validators and the Posture Broker Server respectively.

At IETF 101, we proposed that we would like to just continue pointing to the TCG documents rather than submit them to SACM. The group in the room seemed amenable to that idea.

As a result, we wanted to follow-up and get confirmation on the list that this approach was reasonable and that there were no major objections.

Thanks,

Danny

[1] https://trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMC_v1_3_r18.pdf
[2] https://www.trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMV_v1_4_r11.pdf

---

From: Ira McDonald <[email-masked]>
Date: Mon, 2 Apr 2018 14:19:05 -0400

Hi Danny,

Makes sense to me to just reference TGC TNC IF-IMC and IF-IMV specs.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Apr 2, 2018 at 2:10 PM, Haynes Jr., Dan <[email-masked]> wrote:

> Hi Everyone,
>
>
>
> The current ECP draft (-01) calls out the TCG IF-IMC [1] and IF-IMV [2]
> specifications which serve as interfaces between Posture Collectors and the
> Posture Broker Client and Posture Validators and the Posture Broker Server
> respectively.
>
>
>
> At IETF 101, we proposed that we would like to just continue pointing to
> the TCG documents rather than submit them to SACM. The group in the room
> seemed amenable to that idea.
>
>
>
> As a result, we wanted to follow-up and get confirmation on the list that
> this approach was reasonable and that there were no major objections.
>
>
>
> Thanks,
>
> Danny
>
>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>
>

---

From: Adam Montville <[email-masked]>
Date: Mon, 2 Apr 2018 14:34:41 -0500

Provided there's no IETF issue with referencing these two drafts (along with server discovery), why not just reference them? I suppose we'll learn more as we go...

> On Apr 2, 2018, at 1:19 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Danny,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Mon, Apr 2, 2018 at 2:10 PM, Haynes Jr., Dan <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Everyone,
> 
>  
> 
> [1] https://trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMC_v1_3_r18.pdf <https://trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMC_v1_3_r18.pdf>
> [2] https://www.trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMV_v1_4_r11.pdf <https://www.trustedcomputinggroup.org/wp-content/uploads/TNC_IFIMV_v1_4_r11.pdf>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>
> 
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 2 Apr 2018 15:19:06 -0500

> Provided there's no IETF issue with referencing these two drafts (along with server discovery), why not just reference them? I suppose we'll learn more as we go...

It's generally okay to cite outside work when there's a clear
division of responsibilities, especially if there's a stable
reference.  (I have not looked at the specifics of this case, of
course.)

For example, RFC 4942 cites
www.trustedcomputinggroup.org/groups/TCG_1_0_Architecture_Overview.pdf
(though 4942 is only Informational)

-Ben

---

From: Ira McDonald <[email-masked]>
Date: Mon, 2 Apr 2018 17:06:56 -0400

Hi,

FYI - all TCG specs are permanently, publicly, freely available (without
click-thru or pay-wall).
TCG specs have dated, immutable, version and revision identifiers.

Cheers,
- Ira

On Mon, Apr 2, 2018 at 4:19 PM, Benjamin Kaduk <[email-masked]> wrote:

> > Provided there's no IETF issue with referencing these two drafts (along
> with server discovery), why not just reference them? I suppose we'll learn
> more as we go...
>