Subject: Re: [sacm] [sacmwg/draft-ietf-sacm-terminology] Should SACM scope statements belong in the terminology draft? (#64)

From: jarrettlu <[email-masked]>
Date: Wed, 04 Apr 2018 18:19:21 +0000 (UTC)

I second Adam's proposal about removing term Data In Motion from the terminology draft. It could appear in an architecture draft when appropriate. I also agree on removing the "data at rest" sentence, which appears to belong to a information/data module draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-378696710

---

From: adammontville <[email-masked]>
Date: Wed, 04 Apr 2018 18:27:03 +0000 (UTC)

Jarrett, just to be clear, my proposal was to remove the quoted sentences concerning scope. But, because your second mentions it... Should we define data in motion and data at rest at all? Wouldn't this be a bit like defining network address (see #89 ). 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-378699004

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 04 Apr 2018 18:38:24 +0000 (UTC)

Okay, I have to chime in here. The problem with our past "role" definition was that it was mixing two scopes:

1. roles that define the interaction on the data plane
2. roles that define the function inside a sacm component

The first is a role involving (amongst other things) data in motion - we are prescriptive about that to some extend as we will select/define a common data model for interaction between sacm components on the data plane (data in motion).

The second is a role about (among other things) data at rest - we are not prescriptive about that, but provide the semantics what is supposed to happen "inside" a sacm component (e.g. a repository).

As we could not find existing standards or specifications that we could use as a reference, we defined the term data in motion and data at rest ourselves a long time ago. If this has changed, we can just refer to the source definition in an architecture document. If there is none, I think we avoid a lot of imprecision by just defining them. I totally agree with removing any expositional text wrt to scope or charter.

To reiterate, I would prefer to point to a exiting definition if it is stable and available. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/64#issuecomment-378702521